You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Hadoop QA (JIRA)" <ji...@apache.org> on 2014/08/10 08:54:11 UTC
[jira] [Commented] (HDFS-6837) Code cleanup for Balancer and
Dispatcher
[ https://issues.apache.org/jira/browse/HDFS-6837?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14092036#comment-14092036 ]
Hadoop QA commented on HDFS-6837:
---------------------------------
{color:red}-1 overall{color}. Here are the results of testing the latest attachment
http://issues.apache.org/jira/secure/attachment/12660835/h6837_20140810.patch
against trunk revision .
{color:green}+1 @author{color}. The patch does not contain any @author tags.
{color:green}+1 tests included{color}. The patch appears to include 4 new or modified test files.
{color:green}+1 javac{color}. The applied patch does not increase the total number of javac compiler warnings.
{color:green}+1 javadoc{color}. There were no new javadoc warning messages.
{color:green}+1 eclipse:eclipse{color}. The patch built with eclipse:eclipse.
{color:green}+1 findbugs{color}. The patch does not introduce any new Findbugs (version 2.0.3) warnings.
{color:red}-1 release audit{color}. The applied patch generated 1 release audit warnings.
{color:red}-1 core tests{color}. The patch failed these unit tests in hadoop-hdfs-project/hadoop-hdfs:
org.apache.hadoop.hdfs.server.namenode.ha.TestPipelinesFailover
{color:green}+1 contrib tests{color}. The patch passed contrib unit tests.
Test results: https://builds.apache.org/job/PreCommit-HDFS-Build/7601//testReport/
Release audit warnings: https://builds.apache.org/job/PreCommit-HDFS-Build/7601//artifact/trunk/patchprocess/patchReleaseAuditProblems.txt
Console output: https://builds.apache.org/job/PreCommit-HDFS-Build/7601//console
This message is automatically generated.
> Code cleanup for Balancer and Dispatcher
> ----------------------------------------
>
> Key: HDFS-6837
> URL: https://issues.apache.org/jira/browse/HDFS-6837
> Project: Hadoop HDFS
> Issue Type: Improvement
> Components: balancer
> Reporter: Tsz Wo Nicholas Sze
> Assignee: Tsz Wo Nicholas Sze
> Priority: Minor
> Attachments: h6837_20140810.patch
>
>
> A few minor code cleanup changes:
> - The constructor of Dispatcher should not read Balancer's conf properties; the values should be passed by parameters.
> - StorageGroup.utilization can be removed; it is only used in toString().
> - Move Balancer.ReturnStatus to a standalone class.
> - In Dispatcher, rename BalancerDatanode to DDatanode.
--
This message was sent by Atlassian JIRA
(v6.2#6252)