You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@ozone.apache.org by "Ethan Rose (Jira)" <ji...@apache.org> on 2025/06/26 18:06:00 UTC
[jira] [Created] (HDDS-13341) Change ScanResult#isHealthy to ScanResult#hasErrors
Ethan Rose created HDDS-13341:
---------------------------------
Summary: Change ScanResult#isHealthy to ScanResult#hasErrors
Key: HDDS-13341
URL: https://issues.apache.org/jira/browse/HDDS-13341
Project: Apache Ozone
Issue Type: Sub-task
Reporter: Ethan Rose
As suggested in [this mail thread|https://lists.apache.org/thread/w4s0op1joqkk5t7v7rp58vfxqs88s01d], in all non-test code instances, {{ScanResult#isHealthy}} is inverted. We can clarify what this term means and avoid the inversion by changing the name of the method to {{{}ScanResult#hasErrors{}}}.
--
This message was sent by Atlassian Jira
(v8.20.10#820010)
---------------------------------------------------------------------
To unsubscribe, e-mail: issues-unsubscribe@ozone.apache.org
For additional commands, e-mail: issues-help@ozone.apache.org