You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@commons.apache.org by gg...@apache.org on 2025/11/02 15:11:51 UTC

(commons-codec) branch master updated (4368bfeb -> 13208005)

This is an automated email from the ASF dual-hosted git repository.

ggregory pushed a change to branch master
in repository https://gitbox.apache.org/repos/asf/commons-codec.git


    from 4368bfeb Add dependabot email [skip ci]
     new af58c1af Use final
     new fcb8bf61 Use component logo
     new 13208005 Use HTTPS in URL

The 3 revisions listed above as "new" are entirely new to this
repository and will be described in separate emails.  The revisions
listed as "add" were already present in the repository and have only
been added to this reference.


Summary of changes:
 pom.xml                                                             | 2 +-
 src/changes/changes.xml                                             | 2 +-
 src/main/java/org/apache/commons/codec/DecoderException.java        | 2 +-
 src/main/java/org/apache/commons/codec/binary/Base16.java           | 2 +-
 src/main/java/org/apache/commons/codec/binary/Base32.java           | 6 +++---
 .../java/org/apache/commons/codec/binary/Base32InputStream.java     | 2 +-
 .../java/org/apache/commons/codec/binary/Base32OutputStream.java    | 2 +-
 src/main/java/org/apache/commons/codec/binary/Base64.java           | 4 ++--
 .../java/org/apache/commons/codec/binary/Base64InputStream.java     | 2 +-
 .../java/org/apache/commons/codec/binary/Base64OutputStream.java    | 2 +-
 src/main/java/org/apache/commons/codec/binary/BaseNCodec.java       | 6 +++---
 src/main/java/org/apache/commons/codec/digest/Md5Crypt.java         | 2 +-
 .../org/apache/commons/codec/language/DaitchMokotoffSoundex.java    | 2 +-
 .../java/org/apache/commons/codec/language/DoubleMetaphone.java     | 2 +-
 src/main/java/org/apache/commons/codec/language/Nysiis.java         | 2 +-
 src/main/java/org/apache/commons/codec/net/BCodec.java              | 6 +++---
 src/main/java/org/apache/commons/codec/net/QCodec.java              | 6 +++---
 .../java/org/apache/commons/codec/net/QuotedPrintableCodec.java     | 4 ++--
 src/main/java/org/apache/commons/codec/net/RFC1522Codec.java        | 4 ++--
 src/main/java/org/apache/commons/codec/net/URLCodec.java            | 4 ++--
 src/main/javadoc/overview.html                                      | 4 +++-
 src/site/xdoc/index.xml                                             | 2 +-
 src/test/java/org/apache/commons/codec/binary/Base32TestData.java   | 2 +-
 src/test/java/org/apache/commons/codec/binary/Base64Test.java       | 2 +-
 src/test/java/org/apache/commons/codec/binary/Base64TestData.java   | 2 +-
 src/test/java/org/apache/commons/codec/language/NysiisTest.java     | 2 +-
 26 files changed, 40 insertions(+), 38 deletions(-)


(commons-codec) 01/03: Use final

Posted by gg...@apache.org.
This is an automated email from the ASF dual-hosted git repository.

ggregory pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/commons-codec.git

commit af58c1af853cd705fa08a5313c7fecd870ed37c6
Author: Gary Gregory <ga...@gmail.com>
AuthorDate: Sun Nov 2 09:16:27 2025 -0500

    Use final
---
 src/main/java/org/apache/commons/codec/DecoderException.java | 2 +-
 src/main/java/org/apache/commons/codec/binary/Base16.java    | 2 +-
 src/main/java/org/apache/commons/codec/binary/Base32.java    | 2 +-
 3 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/src/main/java/org/apache/commons/codec/DecoderException.java b/src/main/java/org/apache/commons/codec/DecoderException.java
index 99091d14..fea2e82b 100644
--- a/src/main/java/org/apache/commons/codec/DecoderException.java
+++ b/src/main/java/org/apache/commons/codec/DecoderException.java
@@ -60,7 +60,7 @@ public class DecoderException extends Exception {
      * @see String#format(String, Object...)
      * @since 1.20.0
      */
-    public DecoderException(final String message, Object... args) {
+    public DecoderException(final String message, final Object... args) {
         super(String.format(message, args));
     }
 
diff --git a/src/main/java/org/apache/commons/codec/binary/Base16.java b/src/main/java/org/apache/commons/codec/binary/Base16.java
index bebd82ce..fe1ff3bf 100644
--- a/src/main/java/org/apache/commons/codec/binary/Base16.java
+++ b/src/main/java/org/apache/commons/codec/binary/Base16.java
@@ -79,7 +79,7 @@ public class Base16 extends BaseNCodec {
         }
 
         @Override
-        public Builder setEncodeTable(byte... encodeTable) {
+        public Builder setEncodeTable(final byte... encodeTable) {
             super.setDecodeTableRaw(Arrays.equals(encodeTable, LOWER_CASE_ENCODE_TABLE) ? LOWER_CASE_DECODE_TABLE : UPPER_CASE_DECODE_TABLE);
             return super.setEncodeTable(encodeTable);
         }
diff --git a/src/main/java/org/apache/commons/codec/binary/Base32.java b/src/main/java/org/apache/commons/codec/binary/Base32.java
index 80246528..9b1b0cef 100644
--- a/src/main/java/org/apache/commons/codec/binary/Base32.java
+++ b/src/main/java/org/apache/commons/codec/binary/Base32.java
@@ -97,7 +97,7 @@ public class Base32 extends BaseNCodec {
         }
 
         @Override
-        public Builder setEncodeTable(byte... encodeTable) {
+        public Builder setEncodeTable(final byte... encodeTable) {
             super.setDecodeTableRaw(Arrays.equals(encodeTable, HEX_ENCODE_TABLE) ? HEX_DECODE_TABLE : DECODE_TABLE);
             return super.setEncodeTable(encodeTable);
         }


(commons-codec) 02/03: Use component logo

Posted by gg...@apache.org.
This is an automated email from the ASF dual-hosted git repository.

ggregory pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/commons-codec.git

commit fcb8bf612ccdf25c11573ebe82dd9f0474e606d5
Author: Gary Gregory <ga...@gmail.com>
AuthorDate: Sun Nov 2 09:29:48 2025 -0500

    Use component logo
---
 src/main/javadoc/overview.html | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

diff --git a/src/main/javadoc/overview.html b/src/main/javadoc/overview.html
index 16ea0f6d..cbe5e8d3 100644
--- a/src/main/javadoc/overview.html
+++ b/src/main/javadoc/overview.html
@@ -19,7 +19,9 @@
 <title>Apache Commons Codec Overview</title>
 </head>
 <body>
-  <img src="../images/commons-logo.png" alt="Apache Commons Codec">
+  <a href="https://commons.apache.org/codec">
+    <img src="../images/logo.png" alt="Apache Commons Codec">
+  </a>
   <p>Apache Commons Codec consists of a set of utilities and a simple framework for encoding and decoding text and binary data.</p>
   <p>
     You can find the Javadoc package list at the <a href="#all-packages-table">bottom of this page</a>.


(commons-codec) 03/03: Use HTTPS in URL

Posted by gg...@apache.org.
This is an automated email from the ASF dual-hosted git repository.

ggregory pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/commons-codec.git

commit 13208005b9cf043ecd09c149a53eff03c1e7db61
Author: Gary Gregory <ga...@gmail.com>
AuthorDate: Sun Nov 2 10:11:45 2025 -0500

    Use HTTPS in URL
---
 pom.xml                                                             | 2 +-
 src/changes/changes.xml                                             | 2 +-
 src/main/java/org/apache/commons/codec/binary/Base32.java           | 4 ++--
 .../java/org/apache/commons/codec/binary/Base32InputStream.java     | 2 +-
 .../java/org/apache/commons/codec/binary/Base32OutputStream.java    | 2 +-
 src/main/java/org/apache/commons/codec/binary/Base64.java           | 4 ++--
 .../java/org/apache/commons/codec/binary/Base64InputStream.java     | 2 +-
 .../java/org/apache/commons/codec/binary/Base64OutputStream.java    | 2 +-
 src/main/java/org/apache/commons/codec/binary/BaseNCodec.java       | 6 +++---
 src/main/java/org/apache/commons/codec/digest/Md5Crypt.java         | 2 +-
 .../org/apache/commons/codec/language/DaitchMokotoffSoundex.java    | 2 +-
 .../java/org/apache/commons/codec/language/DoubleMetaphone.java     | 2 +-
 src/main/java/org/apache/commons/codec/language/Nysiis.java         | 2 +-
 src/main/java/org/apache/commons/codec/net/BCodec.java              | 6 +++---
 src/main/java/org/apache/commons/codec/net/QCodec.java              | 6 +++---
 .../java/org/apache/commons/codec/net/QuotedPrintableCodec.java     | 4 ++--
 src/main/java/org/apache/commons/codec/net/RFC1522Codec.java        | 4 ++--
 src/main/java/org/apache/commons/codec/net/URLCodec.java            | 4 ++--
 src/site/xdoc/index.xml                                             | 2 +-
 src/test/java/org/apache/commons/codec/binary/Base32TestData.java   | 2 +-
 src/test/java/org/apache/commons/codec/binary/Base64Test.java       | 2 +-
 src/test/java/org/apache/commons/codec/binary/Base64TestData.java   | 2 +-
 src/test/java/org/apache/commons/codec/language/NysiisTest.java     | 2 +-
 23 files changed, 34 insertions(+), 34 deletions(-)

diff --git a/pom.xml b/pom.xml
index 714e7e63..d11fd38c 100644
--- a/pom.xml
+++ b/pom.xml
@@ -388,7 +388,7 @@ limitations under the License.
       <name>Julius Davies</name>
       <id>julius</id>
       <email>julius@apache.org</email>
-      <organizationUrl>http://juliusdavies.ca/</organizationUrl>
+      <organizationUrl>https://juliusdavies.ca/</organizationUrl>
       <timezone>-8</timezone>
     </developer>
     <developer>
diff --git a/src/changes/changes.xml b/src/changes/changes.xml
index 4169982e..eaf0eba9 100644
--- a/src/changes/changes.xml
+++ b/src/changes/changes.xml
@@ -576,7 +576,7 @@ The <action> type attribute can be add,update,fix,remove.
         This version is released under the
         &lt;a href="https://www.apache.org/licenses/LICENSE-2.0">Apache License 2.0&lt;/a>
         , please see LICENSE.txt. Previous versions were released under the
-        &lt;a href="http://www.apache.org/licenses/LICENSE-1.1">Apache License 1.1&lt;/a>
+        &lt;a href="https://www.apache.org/licenses/LICENSE-1.1">Apache License 1.1&lt;/a>
       </action>
       <action dev="ggregory" type="update">
         The Board recommendation to remove Javadoc author tags has been
diff --git a/src/main/java/org/apache/commons/codec/binary/Base32.java b/src/main/java/org/apache/commons/codec/binary/Base32.java
index 9b1b0cef..68a048c8 100644
--- a/src/main/java/org/apache/commons/codec/binary/Base32.java
+++ b/src/main/java/org/apache/commons/codec/binary/Base32.java
@@ -22,7 +22,7 @@ import java.util.Arrays;
 import org.apache.commons.codec.CodecPolicy;
 
 /**
- * Provides Base32 encoding and decoding as defined by <a href="http://www.ietf.org/rfc/rfc4648.txt">RFC 4648</a>.
+ * Provides Base32 encoding and decoding as defined by <a href="https://www.ietf.org/rfc/rfc4648.txt">RFC 4648</a>.
  *
  * <p>
  * The class can be parameterized in the following manner with various constructors:
@@ -53,7 +53,7 @@ import org.apache.commons.codec.CodecPolicy;
  *
  * @see Base32InputStream
  * @see Base32OutputStream
- * @see <a href="http://www.ietf.org/rfc/rfc4648.txt">RFC 4648</a>
+ * @see <a href="https://www.ietf.org/rfc/rfc4648.txt">RFC 4648</a>
  * @since 1.5
  */
 public class Base32 extends BaseNCodec {
diff --git a/src/main/java/org/apache/commons/codec/binary/Base32InputStream.java b/src/main/java/org/apache/commons/codec/binary/Base32InputStream.java
index d8399eda..481cd0a0 100644
--- a/src/main/java/org/apache/commons/codec/binary/Base32InputStream.java
+++ b/src/main/java/org/apache/commons/codec/binary/Base32InputStream.java
@@ -48,7 +48,7 @@ import org.apache.commons.codec.binary.BaseNCodecInputStream.AbstracBuilder; //
  * </p>
  *
  * @see Base32
- * @see <a href="http://www.ietf.org/rfc/rfc4648.txt">RFC 4648</a>
+ * @see <a href="https://www.ietf.org/rfc/rfc4648.txt">RFC 4648</a>
  * @since 1.5
  */
 public class Base32InputStream extends BaseNCodecInputStream<Base32, Base32InputStream, Base32InputStream.Builder> {
diff --git a/src/main/java/org/apache/commons/codec/binary/Base32OutputStream.java b/src/main/java/org/apache/commons/codec/binary/Base32OutputStream.java
index 936e09b0..5f8153b0 100644
--- a/src/main/java/org/apache/commons/codec/binary/Base32OutputStream.java
+++ b/src/main/java/org/apache/commons/codec/binary/Base32OutputStream.java
@@ -52,7 +52,7 @@ import org.apache.commons.codec.binary.BaseNCodecOutputStream.AbstractBuilder; /
  * </p>
  *
  * @see Base32
- * @see <a href="http://www.ietf.org/rfc/rfc4648.txt">RFC 4648</a>
+ * @see <a href="https://www.ietf.org/rfc/rfc4648.txt">RFC 4648</a>
  * @since 1.5
  */
 public class Base32OutputStream extends BaseNCodecOutputStream<Base32, Base32OutputStream, Base32OutputStream.Builder> {
diff --git a/src/main/java/org/apache/commons/codec/binary/Base64.java b/src/main/java/org/apache/commons/codec/binary/Base64.java
index b2eb9430..0b108091 100644
--- a/src/main/java/org/apache/commons/codec/binary/Base64.java
+++ b/src/main/java/org/apache/commons/codec/binary/Base64.java
@@ -24,7 +24,7 @@ import java.util.Objects;
 import org.apache.commons.codec.CodecPolicy;
 
 /**
- * Provides Base64 encoding and decoding as defined by <a href="http://www.ietf.org/rfc/rfc2045.txt">RFC 2045</a>.
+ * Provides Base64 encoding and decoding as defined by <a href="https://www.ietf.org/rfc/rfc2045.txt">RFC 2045</a>.
  *
  * <p>
  * This class implements section <cite>6.8. Base64 Content-Transfer-Encoding</cite> from RFC 2045 <cite>Multipurpose
@@ -66,7 +66,7 @@ import org.apache.commons.codec.CodecPolicy;
  *
  * @see Base64InputStream
  * @see Base64OutputStream
- * @see <a href="http://www.ietf.org/rfc/rfc2045.txt">RFC 2045</a>
+ * @see <a href="https://www.ietf.org/rfc/rfc2045.txt">RFC 2045</a>
  * @since 1.0
  */
 public class Base64 extends BaseNCodec {
diff --git a/src/main/java/org/apache/commons/codec/binary/Base64InputStream.java b/src/main/java/org/apache/commons/codec/binary/Base64InputStream.java
index 1121e36f..14e0a1bb 100644
--- a/src/main/java/org/apache/commons/codec/binary/Base64InputStream.java
+++ b/src/main/java/org/apache/commons/codec/binary/Base64InputStream.java
@@ -52,7 +52,7 @@ import org.apache.commons.codec.binary.BaseNCodecInputStream.AbstracBuilder; //
  * </p>
  *
  * @see Base64
- * @see <a href="http://www.ietf.org/rfc/rfc2045.txt">RFC 2045</a>
+ * @see <a href="https://www.ietf.org/rfc/rfc2045.txt">RFC 2045</a>
  * @since 1.4
  */
 public class Base64InputStream extends BaseNCodecInputStream<Base64, Base64InputStream, Base64InputStream.Builder> {
diff --git a/src/main/java/org/apache/commons/codec/binary/Base64OutputStream.java b/src/main/java/org/apache/commons/codec/binary/Base64OutputStream.java
index a2339def..a5097aa5 100644
--- a/src/main/java/org/apache/commons/codec/binary/Base64OutputStream.java
+++ b/src/main/java/org/apache/commons/codec/binary/Base64OutputStream.java
@@ -56,7 +56,7 @@ import org.apache.commons.codec.binary.BaseNCodecOutputStream.AbstractBuilder; /
  * </p>
  *
  * @see Base64
- * @see <a href="http://www.ietf.org/rfc/rfc2045.txt">RFC 2045</a>
+ * @see <a href="https://www.ietf.org/rfc/rfc2045.txt">RFC 2045</a>
  * @since 1.4
  */
 public class Base64OutputStream extends BaseNCodecOutputStream<Base64, Base64OutputStream, Base64OutputStream.Builder> {
diff --git a/src/main/java/org/apache/commons/codec/binary/BaseNCodec.java b/src/main/java/org/apache/commons/codec/binary/BaseNCodec.java
index 575bb9b4..a430f61d 100644
--- a/src/main/java/org/apache/commons/codec/binary/BaseNCodec.java
+++ b/src/main/java/org/apache/commons/codec/binary/BaseNCodec.java
@@ -302,7 +302,7 @@ public abstract class BaseNCodec implements BinaryEncoder, BinaryDecoder {
      * The {@value} character limit does not count the trailing CRLF, but counts all other characters, including any equal signs.
      * </p>
      *
-     * @see <a href="http://www.ietf.org/rfc/rfc2045.txt">RFC 2045 section 6.8</a>
+     * @see <a href="https://www.ietf.org/rfc/rfc2045.txt">RFC 2045 section 6.8</a>
      */
     public static final int MIME_CHUNK_SIZE = 76;
     /**
@@ -345,7 +345,7 @@ public abstract class BaseNCodec implements BinaryEncoder, BinaryDecoder {
     /**
      * Chunk separator per RFC 2045 section 2.1.
      *
-     * @see <a href="http://www.ietf.org/rfc/rfc2045.txt">RFC 2045 section 2.1</a>
+     * @see <a href="https://www.ietf.org/rfc/rfc2045.txt">RFC 2045 section 2.1</a>
      */
     static final byte[] CHUNK_SEPARATOR = { '\r', '\n' };
     /**
@@ -381,7 +381,7 @@ public abstract class BaseNCodec implements BinaryEncoder, BinaryDecoder {
      * Gets a copy of the chunk separator per RFC 2045 section 2.1.
      *
      * @return the chunk separator
-     * @see <a href="http://www.ietf.org/rfc/rfc2045.txt">RFC 2045 section 2.1</a>
+     * @see <a href="https://www.ietf.org/rfc/rfc2045.txt">RFC 2045 section 2.1</a>
      * @since 1.15
      */
     public static byte[] getChunkSeparator() {
diff --git a/src/main/java/org/apache/commons/codec/digest/Md5Crypt.java b/src/main/java/org/apache/commons/codec/digest/Md5Crypt.java
index f1c055eb..73761347 100644
--- a/src/main/java/org/apache/commons/codec/digest/Md5Crypt.java
+++ b/src/main/java/org/apache/commons/codec/digest/Md5Crypt.java
@@ -29,7 +29,7 @@ import java.util.regex.Pattern;
  * The libc crypt() "$1$" and Apache "$apr1$" MD5-based hash algorithm.
  * <p>
  * Based on the public domain ("beer-ware") C implementation from Poul-Henning Kamp which was found at: <a
- * href="http://www.freebsd.org/cgi/cvsweb.cgi/src/lib/libcrypt/crypt-md5.c?rev=1.1;content-type=text%2Fplain">
+ * href="https://www.freebsd.org/cgi/cvsweb.cgi/src/lib/libcrypt/crypt-md5.c?rev=1.1;content-type=text%2Fplain">
  * crypt-md5.c @ freebsd.org</a>
  * </p>
  * <p>
diff --git a/src/main/java/org/apache/commons/codec/language/DaitchMokotoffSoundex.java b/src/main/java/org/apache/commons/codec/language/DaitchMokotoffSoundex.java
index ee7bbed7..0d075713 100644
--- a/src/main/java/org/apache/commons/codec/language/DaitchMokotoffSoundex.java
+++ b/src/main/java/org/apache/commons/codec/language/DaitchMokotoffSoundex.java
@@ -64,7 +64,7 @@ import org.apache.commons.codec.StringEncoder;
  *
  * @see Soundex
  * @see <a href="https://en.wikipedia.org/wiki/Daitch%E2%80%93Mokotoff_Soundex"> Wikipedia - Daitch-Mokotoff Soundex</a>
- * @see <a href="http://www.avotaynu.com/soundex.htm">Avotaynu - Soundexing and Genealogy</a>
+ * @see <a href="https://www.avotaynu.com/soundex.htm">Avotaynu - Soundexing and Genealogy</a>
  * @since 1.10
  */
 public class DaitchMokotoffSoundex implements StringEncoder {
diff --git a/src/main/java/org/apache/commons/codec/language/DoubleMetaphone.java b/src/main/java/org/apache/commons/codec/language/DoubleMetaphone.java
index 2ec17c59..5a360e14 100644
--- a/src/main/java/org/apache/commons/codec/language/DoubleMetaphone.java
+++ b/src/main/java/org/apache/commons/codec/language/DoubleMetaphone.java
@@ -35,7 +35,7 @@ import org.apache.commons.codec.binary.StringUtils;
  *
  * @see <a href="https://drdobbs.com/the-double-metaphone-search-algorithm/184401251?pgno=2">Dr. Dobbs Original Article</a>
  * @see <a href="https://en.wikipedia.org/wiki/Metaphone">Wikipedia Metaphone</a>
- * @see <a href="http://aspell.net/metaphone/dmetaph.cpp">Double Metaphone C++ source by Lawrence Philips</a>
+ * @see <a href="https://aspell.net/metaphone/dmetaph.cpp">Double Metaphone C++ source by Lawrence Philips</a>
  */
 public class DoubleMetaphone implements StringEncoder {
 
diff --git a/src/main/java/org/apache/commons/codec/language/Nysiis.java b/src/main/java/org/apache/commons/codec/language/Nysiis.java
index 033b571c..3e8fbd7b 100644
--- a/src/main/java/org/apache/commons/codec/language/Nysiis.java
+++ b/src/main/java/org/apache/commons/codec/language/Nysiis.java
@@ -65,7 +65,7 @@ import org.apache.commons.codec.StringEncoder;
  * </p>
  *
  * @see <a href="https://en.wikipedia.org/wiki/NYSIIS">NYSIIS on Wikipedia</a>
- * @see <a href="http://www.dropby.com/NYSIIS.html">NYSIIS on dropby.com</a>
+ * @see <a href="https://www.dropby.com/NYSIIS.html">NYSIIS on dropby.com</a>
  * @see Soundex
  * @since 1.7
  */
diff --git a/src/main/java/org/apache/commons/codec/net/BCodec.java b/src/main/java/org/apache/commons/codec/net/BCodec.java
index 3cc1e7fe..d824f3f1 100644
--- a/src/main/java/org/apache/commons/codec/net/BCodec.java
+++ b/src/main/java/org/apache/commons/codec/net/BCodec.java
@@ -31,10 +31,10 @@ import org.apache.commons.codec.binary.Base64;
 import org.apache.commons.codec.binary.BaseNCodec;
 
 /**
- * Identical to the Base64 encoding defined by <a href="http://www.ietf.org/rfc/rfc1521.txt">RFC 1521</a>
+ * Identical to the Base64 encoding defined by <a href="https://www.ietf.org/rfc/rfc1521.txt">RFC 1521</a>
  * and allows a character set to be specified.
  * <p>
- * <a href="http://www.ietf.org/rfc/rfc1522.txt">RFC 1522</a> describes techniques to allow the encoding of non-ASCII
+ * <a href="https://www.ietf.org/rfc/rfc1522.txt">RFC 1522</a> describes techniques to allow the encoding of non-ASCII
  * text in various portions of a RFC 822 [2] message header, in a manner which is unlikely to confuse existing message
  * handling software.
  * </p>
@@ -42,7 +42,7 @@ import org.apache.commons.codec.binary.BaseNCodec;
  * This class is immutable and thread-safe.
  * </p>
  *
- * @see <a href="http://www.ietf.org/rfc/rfc1522.txt">MIME (Multipurpose Internet Mail Extensions) Part Two: Message
+ * @see <a href="https://www.ietf.org/rfc/rfc1522.txt">MIME (Multipurpose Internet Mail Extensions) Part Two: Message
  *          Header Extensions for Non-ASCII Text</a>
  *
  * @since 1.3
diff --git a/src/main/java/org/apache/commons/codec/net/QCodec.java b/src/main/java/org/apache/commons/codec/net/QCodec.java
index 284bb04e..36b92ce2 100644
--- a/src/main/java/org/apache/commons/codec/net/QCodec.java
+++ b/src/main/java/org/apache/commons/codec/net/QCodec.java
@@ -30,10 +30,10 @@ import org.apache.commons.codec.StringEncoder;
 
 /**
  * Similar to the Quoted-Printable content-transfer-encoding defined in
- * <a href="http://www.ietf.org/rfc/rfc1521.txt">RFC 1521</a> and designed to allow text containing mostly ASCII
+ * <a href="https://www.ietf.org/rfc/rfc1521.txt">RFC 1521</a> and designed to allow text containing mostly ASCII
  * characters to be decipherable on an ASCII terminal without decoding.
  * <p>
- * <a href="http://www.ietf.org/rfc/rfc1522.txt">RFC 1522</a> describes techniques to allow the encoding of non-ASCII
+ * <a href="https://www.ietf.org/rfc/rfc1522.txt">RFC 1522</a> describes techniques to allow the encoding of non-ASCII
  * text in various portions of a RFC 822 [2] message header, in a manner which is unlikely to confuse existing message
  * handling software.
  * </p>
@@ -46,7 +46,7 @@ import org.apache.commons.codec.StringEncoder;
  * {@link #setEncodeBlanks(boolean)} after initial setup.
  * </p>
  *
- * @see <a href="http://www.ietf.org/rfc/rfc1522.txt">MIME (Multipurpose Internet Mail Extensions) Part Two: Message
+ * @see <a href="https://www.ietf.org/rfc/rfc1522.txt">MIME (Multipurpose Internet Mail Extensions) Part Two: Message
  *          Header Extensions for Non-ASCII Text</a>
  *
  * @since 1.3
diff --git a/src/main/java/org/apache/commons/codec/net/QuotedPrintableCodec.java b/src/main/java/org/apache/commons/codec/net/QuotedPrintableCodec.java
index b867c73a..4f9baaaa 100644
--- a/src/main/java/org/apache/commons/codec/net/QuotedPrintableCodec.java
+++ b/src/main/java/org/apache/commons/codec/net/QuotedPrintableCodec.java
@@ -34,7 +34,7 @@ import org.apache.commons.codec.StringEncoder;
 import org.apache.commons.codec.binary.StringUtils;
 
 /**
- * Codec for the Quoted-Printable section of <a href="http://www.ietf.org/rfc/rfc1521.txt">RFC 1521</a>.
+ * Codec for the Quoted-Printable section of <a href="https://www.ietf.org/rfc/rfc1521.txt">RFC 1521</a>.
  * <p>
  * The Quoted-Printable encoding is intended to represent data that largely consists of octets that correspond to
  * printable characters in the ASCII character set. It encodes the data in such a way that the resulting octets are
@@ -63,7 +63,7 @@ import org.apache.commons.codec.binary.StringUtils;
  * This class is immutable and thread-safe.
  * </p>
  *
- * @see <a href="http://www.ietf.org/rfc/rfc1521.txt">RFC 1521 MIME (Multipurpose Internet Mail Extensions) Part One:
+ * @see <a href="https://www.ietf.org/rfc/rfc1521.txt">RFC 1521 MIME (Multipurpose Internet Mail Extensions) Part One:
  *          Mechanisms for Specifying and Describing the Format of Internet Message Bodies </a>
  *
  * @since 1.3
diff --git a/src/main/java/org/apache/commons/codec/net/RFC1522Codec.java b/src/main/java/org/apache/commons/codec/net/RFC1522Codec.java
index f9ee4df7..08ced993 100644
--- a/src/main/java/org/apache/commons/codec/net/RFC1522Codec.java
+++ b/src/main/java/org/apache/commons/codec/net/RFC1522Codec.java
@@ -29,7 +29,7 @@ import org.apache.commons.codec.binary.StringUtils;
 /**
  * Implements methods common to all codecs defined in RFC 1522.
  * <p>
- * <a href="http://www.ietf.org/rfc/rfc1522.txt">RFC 1522</a> describes techniques to allow the
+ * <a href="https://www.ietf.org/rfc/rfc1522.txt">RFC 1522</a> describes techniques to allow the
  * encoding of non-ASCII text in various portions of a RFC 822 [2] message header, in a manner which
  * is unlikely to confuse existing message handling software.
  * </p>
@@ -37,7 +37,7 @@ import org.apache.commons.codec.binary.StringUtils;
  * This class is immutable and thread-safe.
  * </p>
  *
- * @see <a href="http://www.ietf.org/rfc/rfc1522.txt">MIME (Multipurpose Internet Mail Extensions) Part Two:
+ * @see <a href="https://www.ietf.org/rfc/rfc1522.txt">MIME (Multipurpose Internet Mail Extensions) Part Two:
  *          Message Header Extensions for Non-ASCII Text</a>
  * @since 1.3
  */
diff --git a/src/main/java/org/apache/commons/codec/net/URLCodec.java b/src/main/java/org/apache/commons/codec/net/URLCodec.java
index 641c7235..73e3a4d3 100644
--- a/src/main/java/org/apache/commons/codec/net/URLCodec.java
+++ b/src/main/java/org/apache/commons/codec/net/URLCodec.java
@@ -41,8 +41,8 @@ import org.apache.commons.codec.binary.StringUtils;
  * This class is thread-safe as of 1.11
  * </p>
  *
- * @see <a href="http://www.w3.org/TR/html4/interact/forms.html#h-17.13.4.1">Chapter 17.13.4 Form content types</a>
- *           of the <a href="http://www.w3.org/TR/html4/">HTML 4.01 Specification</a>
+ * @see <a href="https://www.w3.org/TR/html4/interact/forms.html#h-17.13.4.1">Chapter 17.13.4 Form content types</a>
+ *           of the <a href="https://www.w3.org/TR/html4/">HTML 4.01 Specification</a>
  *
  * @since 1.2
  */
diff --git a/src/site/xdoc/index.xml b/src/site/xdoc/index.xml
index e8f4160e..7f63c874 100644
--- a/src/site/xdoc/index.xml
+++ b/src/site/xdoc/index.xml
@@ -51,7 +51,7 @@ forked versions of Base64 had significantly diverged from one
 another.  XML-RPC had applied numerous fixes and patches which
 were not applied to the Commons HttpClient Base64.  Different
 subprojects had differing implementations at various levels
-of compliance with the <a href="http://www.ietf.org/rfc/rfc2045.txt">
+of compliance with the <a href="https://www.ietf.org/rfc/rfc2045.txt">
 RFC 2045</a>.
 </p>
 <p>
diff --git a/src/test/java/org/apache/commons/codec/binary/Base32TestData.java b/src/test/java/org/apache/commons/codec/binary/Base32TestData.java
index 76eb75a4..045f7ce7 100644
--- a/src/test/java/org/apache/commons/codec/binary/Base32TestData.java
+++ b/src/test/java/org/apache/commons/codec/binary/Base32TestData.java
@@ -21,7 +21,7 @@ package org.apache.commons.codec.binary;
  * This random data was encoded by OpenSSL. Java had nothing to do with it. This data helps us test interop between
  * Commons-Codec and OpenSSL. Notice that OpenSSL creates 64 character lines instead of the 76 of Commons-Codec.
  *
- * @see <a href="http://www.ietf.org/rfc/rfc2045.txt">RFC 2045</a>
+ * @see <a href="https://www.ietf.org/rfc/rfc2045.txt">RFC 2045</a>
  */
 public class Base32TestData {
 
diff --git a/src/test/java/org/apache/commons/codec/binary/Base64Test.java b/src/test/java/org/apache/commons/codec/binary/Base64Test.java
index 2f4ee674..47d0fdca 100644
--- a/src/test/java/org/apache/commons/codec/binary/Base64Test.java
+++ b/src/test/java/org/apache/commons/codec/binary/Base64Test.java
@@ -46,7 +46,7 @@ import org.junit.jupiter.params.provider.ValueSource;
 /**
  * Tests {@link Base64}.
  *
- * @see <a href="http://www.ietf.org/rfc/rfc2045.txt">RFC 2045</a>
+ * @see <a href="https://www.ietf.org/rfc/rfc2045.txt">RFC 2045</a>
  */
 class Base64Test {
 
diff --git a/src/test/java/org/apache/commons/codec/binary/Base64TestData.java b/src/test/java/org/apache/commons/codec/binary/Base64TestData.java
index ebca757f..170fe57a 100644
--- a/src/test/java/org/apache/commons/codec/binary/Base64TestData.java
+++ b/src/test/java/org/apache/commons/codec/binary/Base64TestData.java
@@ -21,7 +21,7 @@ package org.apache.commons.codec.binary;
  * This random data was encoded by OpenSSL. Java had nothing to do with it. This data helps us test interop between
  * Commons-Codec and OpenSSL. Notice that OpenSSL creates 64 character lines instead of the 76 of Commons-Codec.
  *
- * @see <a href="http://www.ietf.org/rfc/rfc2045.txt">RFC 2045</a>
+ * @see <a href="https://www.ietf.org/rfc/rfc2045.txt">RFC 2045</a>
  */
 class Base64TestData {
 
diff --git a/src/test/java/org/apache/commons/codec/language/NysiisTest.java b/src/test/java/org/apache/commons/codec/language/NysiisTest.java
index d728dc28..5e594eac 100644
--- a/src/test/java/org/apache/commons/codec/language/NysiisTest.java
+++ b/src/test/java/org/apache/commons/codec/language/NysiisTest.java
@@ -80,7 +80,7 @@ class NysiisTest extends AbstractStringEncoderTest<Nysiis> {
     /**
      * Tests data gathered from around the internet.
      *
-     * @see <a href="http://www.dropby.com/NYSIISTextStrings.html">http://www.dropby.com/NYSIISTextStrings.html</a>*/
+     * @see <a href="https://www.dropby.com/NYSIISTextStrings.html">http://www.dropby.com/NYSIISTextStrings.html</a>*/
     @Test
     void testDropBy() {
         // Explanation of differences between this implementation and the one at dropby.com is