You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@subversion.apache.org by Greg Stein <gs...@lyra.org> on 2002/05/10 20:26:01 UTC

Re: svn commit: rev 1926 - trunk/subversion/svnadmin trunk/subversion/libsvn_fs trunk/subversion/libsvn_wc trunk/subversion/libsvn_subr trunk/subversion/libsvn_client trunk/subversion/clients/cmdline trunk/subversion/tests/libsvn_wc trunk/subversion/tests/libsvn_subr trunk/subversion/libsvn_repos trunk/subversion/libsvn_delta trunk/subversion/libsvn_ra_dav

On Fri, May 10, 2002 at 01:32:53PM -0500, philip@tigris.org wrote:
>...
> +++ trunk/subversion/libsvn_fs/fs.c	Fri May 10 13:32:51 2002
> @@ -396,7 +396,7 @@
>  
>    /* Create the directory for the new Berkeley DB environment.  */
>    apr_err = apr_dir_make (fs->path, APR_OS_DEFAULT, fs->pool);
> -  if (! APR_STATUS_IS_SUCCESS (apr_err))
> +  if (apr_err != APR_SUCCESS)

nit: most of the others have just been 'if (apr_err)'

(this was the only one like this out of the whole batch)

>...
> +++ trunk/subversion/libsvn_client/commit.c	Fri May 10 13:32:52 2002
>...
> @@ -156,7 +156,7 @@
>    this_edit_path = svn_stringbuf_dup (edit_path, pool);
>  
>    for (apr_err = apr_dir_read (&finfo, flags, dir);
> -       APR_STATUS_IS_SUCCESS (apr_err);
> +       apr_err == APR_SUCCESS;
>         svn_pool_clear (subpool), apr_err = apr_dir_read (&finfo, flags, dir))

While "different", I would support this for clarity's sake since it is
within the 'for' construct.

>...
> +++ trunk/subversion/tests/libsvn_wc/translate-test.c	Fri May 10 13:32:52 2002
>...
> @@ -202,12 +202,12 @@
>    apr_status_t apr_err;
>    apr_finfo_t finfo;
>  
> -  if (APR_STATUS_IS_SUCCESS (apr_stat (&finfo, fname, APR_FINFO_TYPE, pool)))
> +  if (apr_stat (&finfo, fname, APR_FINFO_TYPE, pool) == APR_SUCCESS)

Again, while different, I'd support the test against APR_SUCCESS.

Cheers,
-g

-- 
Greg Stein, http://www.lyra.org/

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org

Re: svn commit: rev 1926 - trunk/subversion/svnadmin trunk/subversion/libsvn_fs trunk/subversion/libsvn_wc trunk/subversion/libsvn_subr trunk/subversion/libsvn_client trunk/subversion/clients/cmdline trunk/subversion/tests/libsvn_wc trunk/subversion/tests/libsvn_subr trunk/subversion/libsvn_repos trunk/subversion/libsvn_delta trunk/subversion/libsvn_ra_dav

Posted by Greg Stein <gs...@lyra.org>.
On Fri, May 10, 2002 at 11:31:17PM +0100, Philip Martin wrote:
> Greg Stein <gs...@lyra.org> writes:
> > nit: most of the others have just been 'if (apr_err)'
> > 
> > (this was the only one like this out of the whole batch)
> 
> It maches other tests in that function.  Yes, I made most of the
> changes using perl one-liners, but yes I then looked at every one as
> well :)

Ah. Cool. I didn't look at the function context, which wasn't in the mail.
So yah... matching the others is Best(tm). :-)

Cheers,
-g

-- 
Greg Stein, http://www.lyra.org/

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org

Re: svn commit: rev 1926 - trunk/subversion/svnadmin trunk/subversion/libsvn_fs trunk/subversion/libsvn_wc trunk/subversion/libsvn_subr trunk/subversion/libsvn_client trunk/subversion/clients/cmdline trunk/subversion/tests/libsvn_wc trunk/subversion/tests/libsvn_subr trunk/subversion/libsvn_repos trunk/subversion/libsvn_delta trunk/subversion/libsvn_ra_dav

Posted by Philip Martin <ph...@codematters.co.uk>.
Greg Stein <gs...@lyra.org> writes:

> On Fri, May 10, 2002 at 01:32:53PM -0500, philip@tigris.org wrote:
> >...
> > +++ trunk/subversion/libsvn_fs/fs.c	Fri May 10 13:32:51 2002
> > @@ -396,7 +396,7 @@
> >  
> >    /* Create the directory for the new Berkeley DB environment.  */
> >    apr_err = apr_dir_make (fs->path, APR_OS_DEFAULT, fs->pool);
> > -  if (! APR_STATUS_IS_SUCCESS (apr_err))
> > +  if (apr_err != APR_SUCCESS)
> 
> nit: most of the others have just been 'if (apr_err)'
> 
> (this was the only one like this out of the whole batch)

It maches other tests in that function.  Yes, I made most of the
changes using perl one-liners, but yes I then looked at every one as
well :)

-- 
Philip

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@subversion.tigris.org
For additional commands, e-mail: dev-help@subversion.tigris.org