You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@pivot.apache.org by Noel Grandin <no...@gmail.com> on 2009/04/09 16:59:27 UTC

table class comments

(*) TablePane should maybe be called GridPane?
and then TableView could simply be called Table?

(*) TableView is much like JTable - it's very column centric.
It would be very nice if the relevant non-column-centric-bits could be
pulled out into a Grid base-class.
Such a base-class would make implementing other custom table-like things
(e.g. locked columns, row headers, spreadsheets) a lot easier,
particularly given how difficult it is to implement even a Grid class
(I've tried).

(*) TableView comments
 - TableView#RowEditor and it's related set/get should really be called
CellEditor, because it's not really row-centric.
 - javadoc - the selection methods don't say whether they are row or
column based
 - the #columns field be inside the ColumnSequence class.
 - it would nice to be able to set components on the corner spaces e.g.
the right hand edge of the columns, above the vertical scrollbar.
 - It would be nice to define some standard mechanism of daisy-chaining
TableView#CellRenderer classes to implement things like row highlighting.