You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@myfaces.apache.org by "Melloware (Jira)" <de...@myfaces.apache.org> on 2021/03/31 14:21:00 UTC

[jira] [Comment Edited] (MYFACES-4388) Faces 4.0: rename xmlns.jcp.org taglib URIs

    [ https://issues.apache.org/jira/browse/MYFACES-4388?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17312410#comment-17312410 ] 

Melloware edited comment on MYFACES-4388 at 3/31/21, 2:20 PM:
--------------------------------------------------------------

Right now we have something like this...
{code:java}
public final static String NAMESPACE = "http://xmlns.jcp.org/jsf/core";
public final static String ALIAS_NAMESPACE = "http://java.sun.com/jsf/core"; 
{code}

I am wondering if we should rename and do this...
{code:java}
public final static String NAMESPACE = "jakarta.faces.core";
public final static String JCP_NAMESPACE = "http://xmlns.jcp.org/jsf/core"; 
public final static String SUN_NAMESPACE = "http://java.sun.com/jsf/core"; 
{code}

Or should we drop "sun" altogether and just do...

{code:java}
public final static String NAMESPACE = "jakarta.faces.core";
public final static String ALIAS_NAMESPACE = "http://xmlns.jcp.org/jsf/core"; 
{code}


was (Author: melloware):
Right now we have something like this...
{code:java}
public final static String NAMESPACE = "http://xmlns.jcp.org/jsf/core";
public final static String ALIAS_NAMESPACE = "http://java.sun.com/jsf/core"; {code}

> Faces 4.0: rename xmlns.jcp.org taglib URIs
> -------------------------------------------
>
>                 Key: MYFACES-4388
>                 URL: https://issues.apache.org/jira/browse/MYFACES-4388
>             Project: MyFaces Core
>          Issue Type: Improvement
>            Reporter: Thomas Andraschko
>            Assignee: Thomas Andraschko
>            Priority: Major
>             Fix For: 4.0.0-RC1
>
>
> https://github.com/eclipse-ee4j/faces-api/issues/1553



--
This message was sent by Atlassian Jira
(v8.3.4#803005)