You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@sling.apache.org by "Carsten Ziegeler (JIRA)" <ji...@apache.org> on 2013/10/16 10:25:43 UTC

[jira] [Comment Edited] (SLING-3169) Job state and related enumerations

    [ https://issues.apache.org/jira/browse/SLING-3169?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13796544#comment-13796544 ] 

Carsten Ziegeler edited comment on SLING-3169 at 10/16/13 8:24 AM:
-------------------------------------------------------------------

I could imagine the following enum:

enum JobState 
  QUEUED,     // waiting in queue after adding or for restart after failing
  ACTIVE,       // job is currently processed
  SUCCEEDED,  // processing finished successfully
  STOPPED,  // processing was stopped by a user
  GIVEN_UP // number of retries reached
  ERROR      // processing signaled CANCELLED or throw an exception
  DROPPED // dropped due to queue configuration



[~sseifert@pro-vision.de] WDYT?


was (Author: cziegeler):
I could imagine the following enum:

enum JobState {
  QUEUED,     // waiting in queue after adding or for restart after failing
  ACTIVE,       // job is currently processed
  SUCCEEDED,  // processing finished successfully
  STOPPED,  // processing was stopped by a user
  GIVEN_UP // number of retries reached
  ERROR      // processing signaled CANCELLED or throw an exception
  DROPPED // dropped due to queue configuration

};

[~sseifert@pro-vision.de] WDYT?

> Job state and related enumerations
> ----------------------------------
>
>                 Key: SLING-3169
>                 URL: https://issues.apache.org/jira/browse/SLING-3169
>             Project: Sling
>          Issue Type: New Feature
>          Components: Extensions
>            Reporter: Carsten Ziegeler
>            Assignee: Carsten Ziegeler
>             Fix For: Extensions Event 3.3.0
>
>
> This is a follow up from SLING-3028 based on comments by Stefan Seifert:
>     I find the enum name Job.JobType not ideal, because it does not stand of a type but for a state of the job. But there is a JobState enum in the consumer API package already.
>     I find the enum and class names JobState and JobStatus in the consumer package not ideal, because they do not stand for a state, but for a job result.
>   



--
This message was sent by Atlassian JIRA
(v6.1#6144)