You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@commons.apache.org by "Gary Gregory (JIRA)" <ji...@apache.org> on 2011/01/25 02:53:43 UTC

[jira] Commented: (CODEC-110) Add a String version of Base64.isArrayByteBase64()

    [ https://issues.apache.org/jira/browse/CODEC-110?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12986173#action_12986173 ] 

Gary Gregory commented on CODEC-110:
------------------------------------

Since this is a new method, I plan on renaming it to isBase64(String). There is no sense in having the type of the input parameter in the name. This mirrors nicely the isBase64(byte) method. IMO the other isTypeNameBase64 methods should be deprecated in favor of typeless names. This is OO after all.

> Add a String version of Base64.isArrayByteBase64()
> --------------------------------------------------
>
>                 Key: CODEC-110
>                 URL: https://issues.apache.org/jira/browse/CODEC-110
>             Project: Commons Codec
>          Issue Type: New Feature
>            Reporter: Julius Davies
>            Assignee: Julius Davies
>            Priority: Trivial
>             Fix For: 1.5
>
>         Attachments: codec-110-junit-and-impl.patch
>
>
> Add a String version of Base64.isArrayByteBase64().  Right now we just have a byte[] version.
> We'll call it:  Base64.isStringBase64().

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.