You are viewing a plain text version of this content. The canonical link for it is here.
Posted to java-user@axis.apache.org by Anne Thomas Manes <at...@gmail.com> on 2006/08/25 15:47:04 UTC

Re: [axis2] Naming of the Request message by Java2WSDL

If you are using the wrapped convention, then the request message
element MUST be the same as the operation name. If you prefer to use
unwrapped doc/literal, you can name the request element anything you
want, but then you must also provide information to Axis (via the
WSDD) as to how to map the incoming QName to the appropriate method.

Anne

On 8/23/06, William Ferguson
<Wi...@contractorsolutions.com.au> wrote:
> The message elements and wsdl types that Java 2WSDL generates for the
> request portion of a Service method have the same name as the method
> itself, while the response portion is of the form <methodName>Response.
>
> IMHO, for clarity it would be better for the the request elements to
> follow the same pattern as that for the response elments. Eg for a
> method with signature:
>
>   public String getMyMethod(String someParam);
>
> It would be better to generate an operation element like:
>         <wsdl:operation name="getMyMethod">
>                 <wsdl:input message="axis2:getMyMethodRequestMessage"/>
>                 <wsdl:output message="axis2:getMyMethodReponseMessage"/>
>         </wsdl:operation>
>
> Message elements like:
>         <wsdl:message name="getMyMethodRequestMessage"/>
>         <wsdl:message name="getMyMethodResponseMessage"/>
>
> And WSDL types of:
>         <xs:element name="getMyMethodRequest">
>                 <xs:complexType>
>                         <xs:sequence>
>                                 <xs:element name="return"
> type="xs:string"/>
>                         </xs:sequence>
>                 </xs:complexType>
>         </xs:element>
>         <xs:element name="getMyMethodResponse">
>                 <xs:complexType>
>                         <xs:sequence>
>                                 <xs:element name="return"
> type="xs:string"/>
>                         </xs:sequence>
>                 </xs:complexType>
>         </xs:element>
>
> Doing so makes it much clearer in both the WSDL and in clients using the
> generated stubs and data bindings (IMHO). Does anyone else concur?
> If so I'll create an issue for it.
>
> William
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-user-help@ws.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org