You are viewing a plain text version of this content. The canonical link for it is here.
Posted to reviews@kudu.apache.org by "David Ribeiro Alves (Code Review)" <ge...@cloudera.org> on 2016/11/03 11:12:21 UTC

[kudu-CR] Improve debuggability of the delta/compaction path

David Ribeiro Alves has uploaded a new change for review.

  http://gerrit.cloudera.org:8080/4930

Change subject: Improve debuggability of the delta/compaction path
......................................................................

Improve debuggability of the delta/compaction path

This adds/modifies some log statements on the delta/compaction path
to aid with debugging. For example it makes some log statements
in delta_compaction.cc output the row id instead of the row index
within the block, which helps when grepping for changed to a particular
row.

Change-Id: I0fc6c6ed76f5ab929c04410228d5ea70f4fc9660
---
M src/kudu/tablet/delta_compaction.cc
M src/kudu/tablet/delta_store.cc
M src/kudu/tablet/deltafile.cc
3 files changed, 13 insertions(+), 7 deletions(-)


  git pull ssh://gerrit.cloudera.org:29418/kudu refs/changes/30/4930/1
-- 
To view, visit http://gerrit.cloudera.org:8080/4930
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: newchange
Gerrit-Change-Id: I0fc6c6ed76f5ab929c04410228d5ea70f4fc9660
Gerrit-PatchSet: 1
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: David Ribeiro Alves <dr...@apache.org>

[kudu-CR] Improve debuggability of the delta/compaction path

Posted by "David Ribeiro Alves (Code Review)" <ge...@cloudera.org>.
David Ribeiro Alves has submitted this change and it was merged.

Change subject: Improve debuggability of the delta/compaction path
......................................................................


Improve debuggability of the delta/compaction path

This adds/modifies some log statements on the delta/compaction path
to aid with debugging. For example it makes some log statements
in delta_compaction.cc output the row id instead of the row index
within the block, which helps when grepping for changes to a particular
row.

Change-Id: I0fc6c6ed76f5ab929c04410228d5ea70f4fc9660
Reviewed-on: http://gerrit.cloudera.org:8080/4930
Tested-by: Kudu Jenkins
Reviewed-by: Alexey Serbin <as...@cloudera.com>
---
M src/kudu/tablet/delta_compaction.cc
M src/kudu/tablet/delta_store.cc
M src/kudu/tablet/delta_store.h
M src/kudu/tablet/deltafile.cc
4 files changed, 29 insertions(+), 13 deletions(-)

Approvals:
  Alexey Serbin: Looks good to me, approved
  Kudu Jenkins: Verified



-- 
To view, visit http://gerrit.cloudera.org:8080/4930
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: merged
Gerrit-Change-Id: I0fc6c6ed76f5ab929c04410228d5ea70f4fc9660
Gerrit-PatchSet: 8
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: David Ribeiro Alves <dr...@apache.org>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: David Ribeiro Alves <dr...@apache.org>
Gerrit-Reviewer: Jean-Daniel Cryans <jd...@apache.org>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Todd Lipcon <to...@apache.org>

[kudu-CR] Improve debuggability of the delta/compaction path

Posted by "Jean-Daniel Cryans (Code Review)" <ge...@cloudera.org>.
Jean-Daniel Cryans has posted comments on this change.

Change subject: Improve debuggability of the delta/compaction path
......................................................................


Patch Set 5: Code-Review+2

-- 
To view, visit http://gerrit.cloudera.org:8080/4930
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I0fc6c6ed76f5ab929c04410228d5ea70f4fc9660
Gerrit-PatchSet: 5
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: David Ribeiro Alves <dr...@apache.org>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: David Ribeiro Alves <dr...@apache.org>
Gerrit-Reviewer: Jean-Daniel Cryans <jd...@apache.org>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Todd Lipcon <to...@apache.org>
Gerrit-HasComments: No

[kudu-CR] Improve debuggability of the delta/compaction path

Posted by "David Ribeiro Alves (Code Review)" <ge...@cloudera.org>.
Hello Alexey Serbin, Kudu Jenkins,

I'd like you to reexamine a change.  Please visit

    http://gerrit.cloudera.org:8080/4930

to look at the new patch set (#5).

Change subject: Improve debuggability of the delta/compaction path
......................................................................

Improve debuggability of the delta/compaction path

This adds/modifies some log statements on the delta/compaction path
to aid with debugging. For example it makes some log statements
in delta_compaction.cc output the row id instead of the row index
within the block, which helps when grepping for changes to a particular
row.

Change-Id: I0fc6c6ed76f5ab929c04410228d5ea70f4fc9660
---
M src/kudu/tablet/delta_compaction.cc
M src/kudu/tablet/delta_store.cc
M src/kudu/tablet/delta_store.h
M src/kudu/tablet/deltafile.cc
4 files changed, 29 insertions(+), 13 deletions(-)


  git pull ssh://gerrit.cloudera.org:29418/kudu refs/changes/30/4930/5
-- 
To view, visit http://gerrit.cloudera.org:8080/4930
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: newpatchset
Gerrit-Change-Id: I0fc6c6ed76f5ab929c04410228d5ea70f4fc9660
Gerrit-PatchSet: 5
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: David Ribeiro Alves <dr...@apache.org>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: David Ribeiro Alves <dr...@apache.org>
Gerrit-Reviewer: Jean-Daniel Cryans <jd...@apache.org>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Todd Lipcon <to...@apache.org>

[kudu-CR] Improve debuggability of the delta/compaction path

Posted by "David Ribeiro Alves (Code Review)" <ge...@cloudera.org>.
Hello Kudu Jenkins,

I'd like you to reexamine a change.  Please visit

    http://gerrit.cloudera.org:8080/4930

to look at the new patch set (#4).

Change subject: Improve debuggability of the delta/compaction path
......................................................................

Improve debuggability of the delta/compaction path

This adds/modifies some log statements on the delta/compaction path
to aid with debugging. For example it makes some log statements
in delta_compaction.cc output the row id instead of the row index
within the block, which helps when grepping for changes to a particular
row.

Change-Id: I0fc6c6ed76f5ab929c04410228d5ea70f4fc9660
---
M src/kudu/tablet/delta_compaction.cc
M src/kudu/tablet/delta_store.cc
M src/kudu/tablet/delta_store.h
M src/kudu/tablet/deltafile.cc
4 files changed, 29 insertions(+), 13 deletions(-)


  git pull ssh://gerrit.cloudera.org:29418/kudu refs/changes/30/4930/4
-- 
To view, visit http://gerrit.cloudera.org:8080/4930
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: newpatchset
Gerrit-Change-Id: I0fc6c6ed76f5ab929c04410228d5ea70f4fc9660
Gerrit-PatchSet: 4
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: David Ribeiro Alves <dr...@apache.org>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: David Ribeiro Alves <dr...@apache.org>
Gerrit-Reviewer: Jean-Daniel Cryans <jd...@apache.org>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Todd Lipcon <to...@apache.org>

[kudu-CR] Improve debuggability of the delta/compaction path

Posted by "David Ribeiro Alves (Code Review)" <ge...@cloudera.org>.
Hello Kudu Jenkins,

I'd like you to reexamine a change.  Please visit

    http://gerrit.cloudera.org:8080/4930

to look at the new patch set (#3).

Change subject: Improve debuggability of the delta/compaction path
......................................................................

Improve debuggability of the delta/compaction path

This adds/modifies some log statements on the delta/compaction path
to aid with debugging. For example it makes some log statements
in delta_compaction.cc output the row id instead of the row index
within the block, which helps when grepping for changed to a particular
row.

Change-Id: I0fc6c6ed76f5ab929c04410228d5ea70f4fc9660
---
M src/kudu/tablet/delta_compaction.cc
M src/kudu/tablet/delta_store.cc
M src/kudu/tablet/delta_store.h
M src/kudu/tablet/deltafile.cc
4 files changed, 28 insertions(+), 13 deletions(-)


  git pull ssh://gerrit.cloudera.org:29418/kudu refs/changes/30/4930/3
-- 
To view, visit http://gerrit.cloudera.org:8080/4930
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: newpatchset
Gerrit-Change-Id: I0fc6c6ed76f5ab929c04410228d5ea70f4fc9660
Gerrit-PatchSet: 3
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: David Ribeiro Alves <dr...@apache.org>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Todd Lipcon <to...@apache.org>

[kudu-CR] Improve debuggability of the delta/compaction path

Posted by "David Ribeiro Alves (Code Review)" <ge...@cloudera.org>.
David Ribeiro Alves has posted comments on this change.

Change subject: Improve debuggability of the delta/compaction path
......................................................................


Patch Set 6: Code-Review+2

just a rebase, keeping +2

-- 
To view, visit http://gerrit.cloudera.org:8080/4930
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I0fc6c6ed76f5ab929c04410228d5ea70f4fc9660
Gerrit-PatchSet: 6
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: David Ribeiro Alves <dr...@apache.org>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: David Ribeiro Alves <dr...@apache.org>
Gerrit-Reviewer: Jean-Daniel Cryans <jd...@apache.org>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Todd Lipcon <to...@apache.org>
Gerrit-HasComments: No

[kudu-CR] Improve debuggability of the delta/compaction path

Posted by "Alexey Serbin (Code Review)" <ge...@cloudera.org>.
Alexey Serbin has posted comments on this change.

Change subject: Improve debuggability of the delta/compaction path
......................................................................


Patch Set 2:

(3 comments)

http://gerrit.cloudera.org:8080/#/c/4930/2/src/kudu/tablet/delta_store.cc
File src/kudu/tablet/delta_store.cc:

PS2, Line 35: type == UNDO ? "UNDO" : "REDO"
nit: consider using the DeltaType_Name() function here instead.


PS2, Line 36: Substitute("$0@tx$1"
The previous format had fixed width TX ids, which is more readable, IMHO.  What is the reason for dropping that feature?


http://gerrit.cloudera.org:8080/#/c/4930/2/src/kudu/tablet/deltafile.cc
File src/kudu/tablet/deltafile.cc:

PS2, Line 612: (delta_type_ == DeltaType::REDO ? "REDO" : "UNDO")
Consider using DeltaType_Name() function instead.


-- 
To view, visit http://gerrit.cloudera.org:8080/4930
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I0fc6c6ed76f5ab929c04410228d5ea70f4fc9660
Gerrit-PatchSet: 2
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: David Ribeiro Alves <dr...@apache.org>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Todd Lipcon <to...@apache.org>
Gerrit-HasComments: Yes

[kudu-CR] Improve debuggability of the delta/compaction path

Posted by "David Ribeiro Alves (Code Review)" <ge...@cloudera.org>.
David Ribeiro Alves has posted comments on this change.

Change subject: Improve debuggability of the delta/compaction path
......................................................................


Patch Set 3:

(5 comments)

http://gerrit.cloudera.org:8080/#/c/4930/3//COMMIT_MSG
Commit Message:

PS3, Line 12: changed
> nit: changes
Done


http://gerrit.cloudera.org:8080/#/c/4930/3/src/kudu/tablet/delta_compaction.cc
File src/kudu/tablet/delta_compaction.cc:

PS3, Line 151: compaction flush
> So which one is it? :)
Done


PS3, Line 173: " << "
> nit: remove
there, remove one ":" and replaced another one by "-"


http://gerrit.cloudera.org:8080/#/c/4930/3/src/kudu/tablet/delta_store.h
File src/kudu/tablet/delta_store.h:

PS3, Line 112: If 'pad' is true pads
> nit "is true, pads" or "is true it pads". I seem to be using commas a lot m
Done


PS3, Line 113: the result strings will compare as the delta keys themselves.
> nit: rephrase this, a bit terse. I'm not even 100% sure what it means.
Done


-- 
To view, visit http://gerrit.cloudera.org:8080/4930
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I0fc6c6ed76f5ab929c04410228d5ea70f4fc9660
Gerrit-PatchSet: 3
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: David Ribeiro Alves <dr...@apache.org>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: David Ribeiro Alves <dr...@apache.org>
Gerrit-Reviewer: Jean-Daniel Cryans <jd...@apache.org>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Todd Lipcon <to...@apache.org>
Gerrit-HasComments: Yes

[kudu-CR] Improve debuggability of the delta/compaction path

Posted by "Jean-Daniel Cryans (Code Review)" <ge...@cloudera.org>.
Jean-Daniel Cryans has posted comments on this change.

Change subject: Improve debuggability of the delta/compaction path
......................................................................


Patch Set 3:

(5 comments)

http://gerrit.cloudera.org:8080/#/c/4930/3//COMMIT_MSG
Commit Message:

PS3, Line 12: changed
nit: changes


http://gerrit.cloudera.org:8080/#/c/4930/3/src/kudu/tablet/delta_compaction.cc
File src/kudu/tablet/delta_compaction.cc:

PS3, Line 151: compaction flush
So which one is it? :)


PS3, Line 173: " << "
nit: remove

Also it's a lot of ":" in that line.


http://gerrit.cloudera.org:8080/#/c/4930/3/src/kudu/tablet/delta_store.h
File src/kudu/tablet/delta_store.h:

PS3, Line 112: If 'pad' is true pads
nit "is true, pads" or "is true it pads". I seem to be using commas a lot more than you do.


PS3, Line 113: the result strings will compare as the delta keys themselves.
nit: rephrase this, a bit terse. I'm not even 100% sure what it means.


-- 
To view, visit http://gerrit.cloudera.org:8080/4930
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I0fc6c6ed76f5ab929c04410228d5ea70f4fc9660
Gerrit-PatchSet: 3
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: David Ribeiro Alves <dr...@apache.org>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: David Ribeiro Alves <dr...@apache.org>
Gerrit-Reviewer: Jean-Daniel Cryans <jd...@apache.org>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Todd Lipcon <to...@apache.org>
Gerrit-HasComments: Yes

[kudu-CR] Improve debuggability of the delta/compaction path

Posted by "Alexey Serbin (Code Review)" <ge...@cloudera.org>.
Alexey Serbin has posted comments on this change.

Change subject: Improve debuggability of the delta/compaction path
......................................................................


Patch Set 7: Code-Review+2

-- 
To view, visit http://gerrit.cloudera.org:8080/4930
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I0fc6c6ed76f5ab929c04410228d5ea70f4fc9660
Gerrit-PatchSet: 7
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: David Ribeiro Alves <dr...@apache.org>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: David Ribeiro Alves <dr...@apache.org>
Gerrit-Reviewer: Jean-Daniel Cryans <jd...@apache.org>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Todd Lipcon <to...@apache.org>
Gerrit-HasComments: No

[kudu-CR] Improve debuggability of the delta/compaction path

Posted by "David Ribeiro Alves (Code Review)" <ge...@cloudera.org>.
David Ribeiro Alves has posted comments on this change.

Change subject: Improve debuggability of the delta/compaction path
......................................................................


Patch Set 5: Code-Review+2

Just a rebase, keeping alexey's +2

-- 
To view, visit http://gerrit.cloudera.org:8080/4930
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I0fc6c6ed76f5ab929c04410228d5ea70f4fc9660
Gerrit-PatchSet: 5
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: David Ribeiro Alves <dr...@apache.org>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: David Ribeiro Alves <dr...@apache.org>
Gerrit-Reviewer: Jean-Daniel Cryans <jd...@apache.org>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Todd Lipcon <to...@apache.org>
Gerrit-HasComments: No

[kudu-CR] Improve debuggability of the delta/compaction path

Posted by "David Ribeiro Alves (Code Review)" <ge...@cloudera.org>.
David Ribeiro Alves has posted comments on this change.

Change subject: Improve debuggability of the delta/compaction path
......................................................................


Patch Set 2:

(3 comments)

http://gerrit.cloudera.org:8080/#/c/4930/2/src/kudu/tablet/delta_store.cc
File src/kudu/tablet/delta_store.cc:

PS2, Line 35: type == UNDO ? "UNDO" : "REDO"
> nit: consider using the DeltaType_Name() function here instead.
Ah, good catch missed that. Done


PS2, Line 36: Substitute("$0@tx$1"
> The previous format had fixed width TX ids, which is more readable, IMHO.  
As I mention in the commit message, having no padding allows to grep logs for specific keys (like "key=1") which doesn't work with the padding as its different from everywhere else we print it. However padding is handy for other purposes so I ended up adding a flag and keeping both.


http://gerrit.cloudera.org:8080/#/c/4930/2/src/kudu/tablet/deltafile.cc
File src/kudu/tablet/deltafile.cc:

PS2, Line 612: (delta_type_ == DeltaType::REDO ? "REDO" : "UNDO")
> Consider using DeltaType_Name() function instead.
Done


-- 
To view, visit http://gerrit.cloudera.org:8080/4930
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I0fc6c6ed76f5ab929c04410228d5ea70f4fc9660
Gerrit-PatchSet: 2
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: David Ribeiro Alves <dr...@apache.org>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: David Ribeiro Alves <dr...@apache.org>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Todd Lipcon <to...@apache.org>
Gerrit-HasComments: Yes

[kudu-CR] Improve debuggability of the delta/compaction path

Posted by "Alexey Serbin (Code Review)" <ge...@cloudera.org>.
Alexey Serbin has posted comments on this change.

Change subject: Improve debuggability of the delta/compaction path
......................................................................


Patch Set 4: Code-Review+2

-- 
To view, visit http://gerrit.cloudera.org:8080/4930
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: I0fc6c6ed76f5ab929c04410228d5ea70f4fc9660
Gerrit-PatchSet: 4
Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-Owner: David Ribeiro Alves <dr...@apache.org>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: David Ribeiro Alves <dr...@apache.org>
Gerrit-Reviewer: Jean-Daniel Cryans <jd...@apache.org>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Reviewer: Todd Lipcon <to...@apache.org>
Gerrit-HasComments: No