You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Arpit Agarwal (JIRA)" <ji...@apache.org> on 2013/04/09 00:30:16 UTC
[jira] [Updated] (HDFS-4673) Renaming file in subdirectory of a
snapshotted directory does not work.
[ https://issues.apache.org/jira/browse/HDFS-4673?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Arpit Agarwal updated HDFS-4673:
--------------------------------
Attachment: HDFS-4673.patch
When the source and destination directory are the same, unlinking the target file from the source directory renders dstIIP and dstParent invalid since the directory is replaced with an INodeDirectoryWithSnapshot.
The conditionally refreshes dstIIP and dstParent after unlinking the source file.
> Renaming file in subdirectory of a snapshotted directory does not work.
> -----------------------------------------------------------------------
>
> Key: HDFS-4673
> URL: https://issues.apache.org/jira/browse/HDFS-4673
> Project: Hadoop HDFS
> Issue Type: Sub-task
> Components: namenode
> Affects Versions: Snapshot (HDFS-2802)
> Reporter: Arpit Agarwal
> Assignee: Arpit Agarwal
> Fix For: Snapshot (HDFS-2802)
>
> Attachments: HDFS-4673.patch
>
>
> Steps to repro:
> # mkdir /1
> # Allow snapshot on /1
> # mkdir /1/2
> # Put file /1/2/f1
> # Take snapshot snap1 of /1
> # Rename /1/2/f1 to /1/2/f2
> Fails with exception in INodeDirectory.replaceSelf
> {code}
> Preconditions.checkArgument(parent != null, "parent is null, this=%s", this);
> {code}
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira