You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Tsz Wo Nicholas Sze (JIRA)" <ji...@apache.org> on 2014/08/10 06:04:12 UTC
[jira] [Created] (HDFS-6837) Code cleanup for Balancer and
Dispatcher
Tsz Wo Nicholas Sze created HDFS-6837:
-----------------------------------------
Summary: Code cleanup for Balancer and Dispatcher
Key: HDFS-6837
URL: https://issues.apache.org/jira/browse/HDFS-6837
Project: Hadoop HDFS
Issue Type: Improvement
Components: balancer
Reporter: Tsz Wo Nicholas Sze
Assignee: Tsz Wo Nicholas Sze
Priority: Minor
Attachments: h6837_20140810.patch
A few minor code cleanup changes:
- The constructor of Dispatcher should not read Balancer's conf properties; the values should be passed by parameters.
- StorageGroup.utilization can be removed; it is only used in toString().
- Move Balancer.ReturnStatus to a standalone class.
- In Dispatcher, rename BalancerDatanode to DDatanode.
--
This message was sent by Atlassian JIRA
(v6.2#6252)