You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@hbase.apache.org by "Jonathan Lawlor (JIRA)" <ji...@apache.org> on 2015/04/23 18:49:39 UTC

[jira] [Resolved] (HBASE-13442) Rename scanner caching to a more semantically correct term such as row limit

     [ https://issues.apache.org/jira/browse/HBASE-13442?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Jonathan Lawlor resolved HBASE-13442.
-------------------------------------
    Resolution: Duplicate

Closing this one in favor of HBASE-13541. Please reopen if there are any outstanding concerns.

> Rename scanner caching to a more semantically correct term such as row limit
> ----------------------------------------------------------------------------
>
>                 Key: HBASE-13442
>                 URL: https://issues.apache.org/jira/browse/HBASE-13442
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Jonathan Lawlor
>         Attachments: HBASE-13442-proposal.diff
>
>
> Caching acts more as a row limit now. By default in branch-1+, a Scan is configured with (caching=Integer.MAX_VALUE, maxResultSize=2MB) so that we service scans on the basis of buffer size rather than number of rows. As a result, caching should now only be configured in instances where the user knows that they will only need X rows. Thus, caching should be renamed to something that is more semantically correct such as rowLimit.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)