You are viewing a plain text version of this content. The canonical link for it is here.
Posted to notifications@asterixdb.apache.org by "abdullah alamoudi (Code Review)" <do...@asterixdb.incubator.apache.org> on 2016/12/02 00:45:55 UTC

Change in asterixdb[master]: Prepare AsterixDB for Pre-Distributed Jobs

abdullah alamoudi has posted comments on this change.

Change subject: Prepare AsterixDB for Pre-Distributed Jobs
......................................................................


Patch Set 3:

(3 comments)

Looks good overall. just minor comments.

https://asterix-gerrit.ics.uci.edu/#/c/1366/3/hyracks-fullstack/hyracks/hyracks-api/src/main/java/org/apache/hyracks/api/client/HyracksClientInterfaceFunctions.java
File hyracks-fullstack/hyracks/hyracks-api/src/main/java/org/apache/hyracks/api/client/HyracksClientInterfaceFunctions.java:

Line 112:         private StartJobFunction(DeploymentId deploymentId, byte[] acggfBytes, EnumSet<JobFlag> jobFlags, JobId jobId) {
why is this private? this is the only Constructor that can be used to set all 4 members.
with the current change, seems like it is not possible to have both deployment id and job id.
any particular reason? can we add a comment about that. to me, that strongly indicates a need for refactoring?

Not necessarily in this change since I think this was already bad! maybe create an issue to refactor?


https://asterix-gerrit.ics.uci.edu/#/c/1366/3/hyracks-fullstack/hyracks/hyracks-control/hyracks-control-nc/src/main/java/org/apache/hyracks/control/nc/NodeControllerService.java
File hyracks-fullstack/hyracks/hyracks-control/hyracks-control-nc/src/main/java/org/apache/hyracks/control/nc/NodeControllerService.java:

Line 363:     public Map<JobId, ActivityClusterGraph> getACGMap() {
should we rename this to getActivityClusterGraphMap()?. just a suggestion. seems easier than trying to know what ACG is


https://asterix-gerrit.ics.uci.edu/#/c/1366/3/hyracks-fullstack/hyracks/hyracks-control/hyracks-control-nc/src/main/java/org/apache/hyracks/control/nc/work/StartTasksWork.java
File hyracks-fullstack/hyracks/hyracks-control/hyracks-control-nc/src/main/java/org/apache/hyracks/control/nc/work/StartTasksWork.java:

Line 197:                     acgMap.put(jobId, acg);
this map is only growing. when/how do we remove activity cluster graphs from the map?

I think we need a way to do that. maybe a message from cc to nc using message broker to uncache job/ remove stored job, or something like that?


-- 
To view, visit https://asterix-gerrit.ics.uci.edu/1366
To unsubscribe, visit https://asterix-gerrit.ics.uci.edu/settings

Gerrit-MessageType: comment
Gerrit-Change-Id: Id809f4b563bbed808c7764d1af664a15919db35b
Gerrit-PatchSet: 3
Gerrit-Project: asterixdb
Gerrit-Branch: master
Gerrit-Owner: Steven Jacobs <sj...@ucr.edu>
Gerrit-Reviewer: Jenkins <je...@fulliautomatix.ics.uci.edu>
Gerrit-Reviewer: Steven Jacobs <sj...@ucr.edu>
Gerrit-Reviewer: Till Westmann <ti...@apache.org>
Gerrit-Reviewer: Yingyi Bu <bu...@gmail.com>
Gerrit-Reviewer: abdullah alamoudi <ba...@gmail.com>
Gerrit-HasComments: Yes