You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@cayenne.apache.org by "Andrus Adamchik (Updated) (JIRA)" <ji...@apache.org> on 2012/02/08 19:36:59 UTC

[jira] [Updated] (CAY-1665) Consistent and concise property names aggregated in one place

     [ https://issues.apache.org/jira/browse/CAY-1665?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Andrus Adamchik updated CAY-1665:
---------------------------------

    Description: 
One of the final things we need in 3.1 is to take all possible property names and DI collection names, with definitions scattered around various Java classes, and define them in a single place as String constants that follow some simple naming conventions. The naming convention that I am trying here is this:

cayenne.<tier_name_or_logical_module_name>.<undescore_separated_lowercase_property_description>[.optional_project_or_data_node_qualifier]

Here is the first cut (the current property names are in parenthesis) :

[DI Collections]

cayenne.server.properties    (org.apache.cayenne.configuration.DefaultRuntimeProperties.properties)
cayenne.server.adapter_detectors   ( org.apache.cayenne.configuration.server.DefaultDbAdapterFactory.detectors)
cayenne.server.domain_filters    (org.apache.cayenne.configuration.server.DataDomainProvider.filters)
cayenne.server.config_locations  ( org.apache.cayenne.configuration.server.DataDomainProvider.locations)

[JDBC Properties]

cayenne.jdbc.driver[.domain_name.node_name]
cayenne.jdbc.url[.domain_name.node_name] 
cayenne.jdbc.username[.domain_name.node_name]
cayenne.jdbc.password[.domain_name.node_name]
cayenne.jdbc.min.connections[.domain_name.node_name]
cayenne.jdbc.max.conections[.domain_name.node_name]

[Cross-tier Properties]

cayenne.querycache.max_size    (cayenne.MapQueryCacheFactory.cacheSize)

[Server properties]

cayenne.server.contexts_sync_strategy           (org.apache.cayenne.sync_contexts)
cayenne.server.object_retain_strategy  (org.apache.cayenne.context_object_retain_strategy)
cayenne.server.adapter[.domain_name.node_name] (cayenne.adapter[.domain_name.node_name])

[ROP Properties]

cayenne.rop.service_url     (cayenne.config.rop.service.url) 
cayenne.rop.service_username    (cayenne.config.rop.service.username)
cayenne.rop.service_password   (cayenne.config.rop.service.password) 
cayenne.rop.shared_session_name   (cayenne.config.rop.service.shared_session)
cayenne.rop.channel_events       (cayenne.config.rop.client.channel.events)
cayenne.rop.context_change_events   (cayenne.config.rop.client.context.change_events)
cayenne.rop.context_lifecycle_events (cayenne.config.rop.client.context.lifecycle_events)




  was:
One of the last things we need in 3.1 is to take all possible property names and DI collection names, with definitions scattered around various Java classes, and define them in a single place as String constants that follow some simple naming conventions. The naming convention that I am trying here is this:

cayenne.<tier_name_or_logical_module_name>.<undescore_separated_lowercase_property_description>[.optional_project_or_data_node_qualifier]

Here is the first cut (the current property names are in parenthesis) :

[DI Collections]

cayenne.server.properties    (org.apache.cayenne.configuration.DefaultRuntimeProperties.properties)
cayenne.server.adapter_detectors   ( org.apache.cayenne.configuration.server.DefaultDbAdapterFactory.detectors)
cayenne.server.domain_filters    (org.apache.cayenne.configuration.server.DataDomainProvider.filters)
cayenne.server.config_locations  ( org.apache.cayenne.configuration.server.DataDomainProvider.locations)

[JDBC Properties]

cayenne.jdbc.driver[.domain_name.node_name]
cayenne.jdbc.url[.domain_name.node_name] 
cayenne.jdbc.username[.domain_name.node_name]
cayenne.jdbc.password[.domain_name.node_name]
cayenne.jdbc.min.connections[.domain_name.node_name]
cayenne.jdbc.max.conections[.domain_name.node_name]

[Cross-tier Properties]

cayenne.querycache.max_size    (cayenne.MapQueryCacheFactory.cacheSize)

[Server properties]

cayenne.server.contexts_sync_strategy           (org.apache.cayenne.sync_contexts)
cayenne.server.object_retain_strategy  (org.apache.cayenne.context_object_retain_strategy)
cayenne.server.adapter[.domain_name.node_name] (cayenne.adapter[.domain_name.node_name])

[ROP Properties]

cayenne.rop.service_url     (cayenne.config.rop.service.url) 
cayenne.rop.service_username    (cayenne.config.rop.service.username)
cayenne.rop.service_password   (cayenne.config.rop.service.password) 
cayenne.rop.shared_session_name   (cayenne.config.rop.service.shared_session)
cayenne.rop.channel_events       (cayenne.config.rop.client.channel.events)
cayenne.rop.context_change_events   (cayenne.config.rop.client.context.change_events)
cayenne.rop.context_lifecycle_events (cayenne.config.rop.client.context.lifecycle_events)




    
> Consistent and concise property names aggregated in one place 
> --------------------------------------------------------------
>
>                 Key: CAY-1665
>                 URL: https://issues.apache.org/jira/browse/CAY-1665
>             Project: Cayenne
>          Issue Type: Improvement
>          Components: Core Library
>    Affects Versions: 3.1M3
>            Reporter: Andrus Adamchik
>            Assignee: Andrus Adamchik
>
> One of the final things we need in 3.1 is to take all possible property names and DI collection names, with definitions scattered around various Java classes, and define them in a single place as String constants that follow some simple naming conventions. The naming convention that I am trying here is this:
> cayenne.<tier_name_or_logical_module_name>.<undescore_separated_lowercase_property_description>[.optional_project_or_data_node_qualifier]
> Here is the first cut (the current property names are in parenthesis) :
> [DI Collections]
> cayenne.server.properties    (org.apache.cayenne.configuration.DefaultRuntimeProperties.properties)
> cayenne.server.adapter_detectors   ( org.apache.cayenne.configuration.server.DefaultDbAdapterFactory.detectors)
> cayenne.server.domain_filters    (org.apache.cayenne.configuration.server.DataDomainProvider.filters)
> cayenne.server.config_locations  ( org.apache.cayenne.configuration.server.DataDomainProvider.locations)
> [JDBC Properties]
> cayenne.jdbc.driver[.domain_name.node_name]
> cayenne.jdbc.url[.domain_name.node_name] 
> cayenne.jdbc.username[.domain_name.node_name]
> cayenne.jdbc.password[.domain_name.node_name]
> cayenne.jdbc.min.connections[.domain_name.node_name]
> cayenne.jdbc.max.conections[.domain_name.node_name]
> [Cross-tier Properties]
> cayenne.querycache.max_size    (cayenne.MapQueryCacheFactory.cacheSize)
> [Server properties]
> cayenne.server.contexts_sync_strategy           (org.apache.cayenne.sync_contexts)
> cayenne.server.object_retain_strategy  (org.apache.cayenne.context_object_retain_strategy)
> cayenne.server.adapter[.domain_name.node_name] (cayenne.adapter[.domain_name.node_name])
> [ROP Properties]
> cayenne.rop.service_url     (cayenne.config.rop.service.url) 
> cayenne.rop.service_username    (cayenne.config.rop.service.username)
> cayenne.rop.service_password   (cayenne.config.rop.service.password) 
> cayenne.rop.shared_session_name   (cayenne.config.rop.service.shared_session)
> cayenne.rop.channel_events       (cayenne.config.rop.client.channel.events)
> cayenne.rop.context_change_events   (cayenne.config.rop.client.context.change_events)
> cayenne.rop.context_lifecycle_events (cayenne.config.rop.client.context.lifecycle_events)

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira