You are viewing a plain text version of this content. The canonical link for it is here.
Posted to hdfs-issues@hadoop.apache.org by "Chen Liang (JIRA)" <ji...@apache.org> on 2018/06/07 00:02:00 UTC
[jira] [Commented] (HDFS-13608) [Edit Tail Fast Path Pt 2] Add
ability for JournalNode to serve edits via RPC
[ https://issues.apache.org/jira/browse/HDFS-13608?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16504065#comment-16504065 ]
Chen Liang commented on HDFS-13608:
-----------------------------------
Thanks [~xkrogen] for the patch, looks good to me overall, a couple minor comments:
1. Looks like {{maxTxns}}, unlike nameservice ID, is always set and got picked up, and since Journal#getJournalEdits always takes maxTxns, I wonder if it makes sense to make this {{required}}. If it should be optional, probably we should check {{hasMaxTxns}} in getJournaledEdits for better readability and so that the value does't rely on protobuf setting a default value.
2. {{getJournaledEdits}} requires cache not null, which requires {{DFS_HA_TAILEDITS_INPROGRESS_KEY}} to be set. I feel that this information should be present somehow, e.g. in the javadoc of {{getJournaledEdits}}, or even rename this method to indicate the dependency on tail edits be enabled.
3. Having another random thought: Since this is under the context of SbN read, I wonder will we have multiple observers calling into {{getJournaledEdits}} of same node at the same time? If so, do we need any additional protection?
> [Edit Tail Fast Path Pt 2] Add ability for JournalNode to serve edits via RPC
> -----------------------------------------------------------------------------
>
> Key: HDFS-13608
> URL: https://issues.apache.org/jira/browse/HDFS-13608
> Project: Hadoop HDFS
> Issue Type: Sub-task
> Reporter: Erik Krogen
> Assignee: Erik Krogen
> Priority: Major
> Attachments: HDFS-13608-HDFS-12943.000.patch, HDFS-13608-HDFS-12943.001.patch
>
>
> See HDFS-13150 for full design.
> This JIRA is to make the JournalNode-side changes necessary to support serving edits via RPC. This includes interacting with the cache added in HDFS-13607.
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)
---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-help@hadoop.apache.org