You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@nifi.apache.org by "Daniel Stieglitz (Jira)" <ji...@apache.org> on 2025/11/21 18:26:00 UTC

[jira] [Comment Edited] (NIFI-15242) Remove redundant name and display name in the VAULT_URI property descriptor found in HashiCorpVaultClientService

    [ https://issues.apache.org/jira/browse/NIFI-15242?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=18039938#comment-18039938 ] 

Daniel Stieglitz edited comment on NIFI-15242 at 11/21/25 6:25 PM:
-------------------------------------------------------------------

[~exceptionfactory] Thank you for reminding me.

What about this
{code:java}
.name("Vault URI"){code}
that would not seem necessary. I had added that but it seems as I did not remove it.

In addition in the migrateProperties method there still is
{code:java}
config.renameProperty("vault.uri", VAULT_URI.getName());{code}
which would seem unnecessary.


was (Author: JIRAUSER294662):
[~exceptionfactory] Thank you for reminding me.

What about this
.name("Vault URI")
that would not seem necessary. I had added that but it seems as I did not remove it.

In addition in the migrateProperties method there still is
{code:java}
config.renameProperty("vault.uri", VAULT_URI.getName());{code}
which would seem unnecessary.

> Remove redundant name and display name in the VAULT_URI property descriptor found in HashiCorpVaultClientService
> ----------------------------------------------------------------------------------------------------------------
>
>                 Key: NIFI-15242
>                 URL: https://issues.apache.org/jira/browse/NIFI-15242
>             Project: Apache NiFi
>          Issue Type: Bug
>            Reporter: Daniel Stieglitz
>            Assignee: Daniel Stieglitz
>            Priority: Minor
>
> Currently the property descriptor has 
> {code:java}
> PropertyDescriptor VAULT_URI = new PropertyDescriptor.Builder()
>             .name("Vault URI")
>             .name("vault.uri")
>             .displayName("Vault URI"){code}
> and it should look like
> {code:java}
> PropertyDescriptor VAULT_URI = new PropertyDescriptor.Builder()
>             .name("Vault URI"){code}



--
This message was sent by Atlassian Jira
(v8.20.10#820010)