You are viewing a plain text version of this content. The canonical link for it is here.
Posted to notifications@accumulo.apache.org by "Christopher Tubbs (JIRA)" <ji...@apache.org> on 2014/04/28 21:08:17 UTC

[jira] [Updated] (ACCUMULO-1499) Move sanity checks from MiniAccumuloCluster constructor into MiniAccumuloConfig.initialize method.

     [ https://issues.apache.org/jira/browse/ACCUMULO-1499?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Christopher Tubbs updated ACCUMULO-1499:
----------------------------------------

    Affects Version/s:     (was: 1.6.0)

> Move sanity checks from MiniAccumuloCluster constructor into MiniAccumuloConfig.initialize method.
> --------------------------------------------------------------------------------------------------
>
>                 Key: ACCUMULO-1499
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-1499
>             Project: Accumulo
>          Issue Type: Improvement
>            Reporter: David Medinets
>            Assignee: Miguel Pereira
>            Priority: Trivial
>             Fix For: 1.6.0
>
>         Attachments: ACCUMULO-1499.patch
>
>
> The code below seems like it should be in the config class:
>     if (config.getDir().exists() && !config.getDir().isDirectory())
>       throw new IllegalArgumentException("Must pass in directory, " + config.getDir() + " is a file");
>     if (config.getDir().exists() && config.getDir().list().length != 0)
>       throw new IllegalArgumentException("Directory " + config.getDir() + " is not empty");
>     this.config = config.initialize();
> Any objections to this change?



--
This message was sent by Atlassian JIRA
(v6.2#6252)