You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@directory.apache.org by "Emmanuel Lecharny (JIRA)" <ji...@apache.org> on 2007/02/12 18:39:06 UTC

[jira] Created: (DIRSERVER-853) Ldap ref values incorrectly handled for referrals

Ldap ref values incorrectly handled for referrals
-------------------------------------------------

                 Key: DIRSERVER-853
                 URL: https://issues.apache.org/jira/browse/DIRSERVER-853
             Project: Directory ApacheDS
          Issue Type: Bug
            Reporter: Emmanuel Lecharny
            Priority: Minor
             Fix For: 1.5.0


In case we have a referral, and if the LdapURLs stored in the ref values refers to Ldap serve r(if they start by ldap://), RFC 3296 states that :

"If the URI contained in a ref attribute value refers to a LDAP
   [RFC2251] server, it MUST be in the form of a LDAP URL [RFC2255].
   The LDAP URL SHOULD NOT contain an explicit scope specifier, filter,
   attribute description list, or any extensions.  The LDAP URL SHOULD
   contain a non-empty DN"

The current ReferralService code does not really implement those controls. We can have empty DNs, scope, filter ... 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (DIRSERVER-853) Ldap ref values incorrectly handled for referrals

Posted by "Emmanuel Lecharny (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/DIRSERVER-853?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Emmanuel Lecharny updated DIRSERVER-853:
----------------------------------------

    Fix Version/s:     (was: 1.5.0)
                   1.5.1

Postponed to 1.5.1

> Ldap ref values incorrectly handled for referrals
> -------------------------------------------------
>
>                 Key: DIRSERVER-853
>                 URL: https://issues.apache.org/jira/browse/DIRSERVER-853
>             Project: Directory ApacheDS
>          Issue Type: Bug
>            Reporter: Emmanuel Lecharny
>            Priority: Minor
>             Fix For: 1.5.1
>
>
> In case we have a referral, and if the LdapURLs stored in the ref values refers to Ldap serve r(if they start by ldap://), RFC 3296 states that :
> "If the URI contained in a ref attribute value refers to a LDAP
>    [RFC2251] server, it MUST be in the form of a LDAP URL [RFC2255].
>    The LDAP URL SHOULD NOT contain an explicit scope specifier, filter,
>    attribute description list, or any extensions.  The LDAP URL SHOULD
>    contain a non-empty DN"
> The current ReferralService code does not really implement those controls. We can have empty DNs, scope, filter ... 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (DIRSERVER-853) Ldap ref values incorrectly handled for referrals

Posted by "Emmanuel Lecharny (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/DIRSERVER-853?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12522754 ] 

Emmanuel Lecharny commented on DIRSERVER-853:
---------------------------------------------

The RFC text is not that clear : how do we determine that the URI address a LDAP server ? I guess that if the scheme is 'ldap', then this is the case. Let's assume that.

> Ldap ref values incorrectly handled for referrals
> -------------------------------------------------
>
>                 Key: DIRSERVER-853
>                 URL: https://issues.apache.org/jira/browse/DIRSERVER-853
>             Project: Directory ApacheDS
>          Issue Type: Bug
>            Reporter: Emmanuel Lecharny
>            Priority: Minor
>             Fix For: 1.5.1
>
>
> In case we have a referral, and if the LdapURLs stored in the ref values refers to Ldap serve r(if they start by ldap://), RFC 3296 states that :
> "If the URI contained in a ref attribute value refers to a LDAP
>    [RFC2251] server, it MUST be in the form of a LDAP URL [RFC2255].
>    The LDAP URL SHOULD NOT contain an explicit scope specifier, filter,
>    attribute description list, or any extensions.  The LDAP URL SHOULD
>    contain a non-empty DN"
> The current ReferralService code does not really implement those controls. We can have empty DNs, scope, filter ... 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Closed: (DIRSERVER-853) Ldap ref values incorrectly handled for referrals

Posted by "Emmanuel Lecharny (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/DIRSERVER-853?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Emmanuel Lecharny closed DIRSERVER-853.
---------------------------------------

    Resolution: Fixed

Fixed :

http://svn.apache.org/viewvc?rev=569730&view=rev
http://svn.apache.org/viewvc?rev=569731&view=rev

> Ldap ref values incorrectly handled for referrals
> -------------------------------------------------
>
>                 Key: DIRSERVER-853
>                 URL: https://issues.apache.org/jira/browse/DIRSERVER-853
>             Project: Directory ApacheDS
>          Issue Type: Bug
>            Reporter: Emmanuel Lecharny
>            Priority: Minor
>             Fix For: 1.5.1
>
>
> In case we have a referral, and if the LdapURLs stored in the ref values refers to Ldap serve r(if they start by ldap://), RFC 3296 states that :
> "If the URI contained in a ref attribute value refers to a LDAP
>    [RFC2251] server, it MUST be in the form of a LDAP URL [RFC2255].
>    The LDAP URL SHOULD NOT contain an explicit scope specifier, filter,
>    attribute description list, or any extensions.  The LDAP URL SHOULD
>    contain a non-empty DN"
> The current ReferralService code does not really implement those controls. We can have empty DNs, scope, filter ... 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.