You are viewing a plain text version of this content. The canonical link for it is here.
Posted to derby-dev@db.apache.org by "Daniel John Debrunner (JIRA)" <ji...@apache.org> on 2006/11/17 18:52:45 UTC

[jira] Created: (DERBY-2096) Change the Parser.parserStatement() to return the more specific StatementNode instead of QueryTreeNode.

Change the Parser.parserStatement() to return the more specific StatementNode instead of QueryTreeNode.
-------------------------------------------------------------------------------------------------------

                 Key: DERBY-2096
                 URL: http://issues.apache.org/jira/browse/DERBY-2096
             Project: Derby
          Issue Type: Improvement
          Components: SQL
            Reporter: Daniel John Debrunner
         Assigned To: Daniel John Debrunner
            Priority: Minor


Since this is compilinga statement returning the specific node makes more sense and will lead to a little more clarity in the code.
Some of the methods defined on QueryTreeNode such as generate() and needsSavepoint() can move down to StatementNode and thus make the code more readable ("which generate is called for a value node?") and remove implementations of these methods that can never be called.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] Closed: (DERBY-2096) Change the Parser.parserStatement() to return the more specific StatementNode instead of QueryTreeNode.

Posted by "Daniel John Debrunner (JIRA)" <ji...@apache.org>.
     [ http://issues.apache.org/jira/browse/DERBY-2096?page=all ]

Daniel John Debrunner closed DERBY-2096.
----------------------------------------

    Fix Version/s: 10.3.0.0
       Resolution: Fixed

Committed revision 481421 is last in a set of changes.

> Change the Parser.parserStatement() to return the more specific StatementNode instead of QueryTreeNode.
> -------------------------------------------------------------------------------------------------------
>
>                 Key: DERBY-2096
>                 URL: http://issues.apache.org/jira/browse/DERBY-2096
>             Project: Derby
>          Issue Type: Improvement
>          Components: SQL
>            Reporter: Daniel John Debrunner
>         Assigned To: Daniel John Debrunner
>            Priority: Minor
>             Fix For: 10.3.0.0
>
>
> Since this is compilinga statement returning the specific node makes more sense and will lead to a little more clarity in the code.
> Some of the methods defined on QueryTreeNode such as generate() and needsSavepoint() can move down to StatementNode and thus make the code more readable ("which generate is called for a value node?") and remove implementations of these methods that can never be called.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira