You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@tinkerpop.apache.org by dk...@apache.org on 2018/11/30 15:28:24 UTC
[tinkerpop] branch TINKERPOP-2017 created (now e007748)
This is an automated email from the ASF dual-hosted git repository.
dkuppitz pushed a change to branch TINKERPOP-2017
in repository https://gitbox.apache.org/repos/asf/tinkerpop.git.
at e007748 TINKERPOP-2017 Added failing test case
This branch includes the following new commits:
new e007748 TINKERPOP-2017 Added failing test case
The 1 revisions listed above as "new" are entirely new to this
repository and will be described in separate emails. The revisions
listed as "add" were already present in the repository and have only
been added to this reference.
[tinkerpop] 01/01: TINKERPOP-2017 Added failing test case
Posted by dk...@apache.org.
This is an automated email from the ASF dual-hosted git repository.
dkuppitz pushed a commit to branch TINKERPOP-2017
in repository https://gitbox.apache.org/repos/asf/tinkerpop.git
commit e007748c273b5e742f33889d111f40052b5f7612
Author: Daniel Kuppitz <da...@hotmail.com>
AuthorDate: Fri Nov 30 08:28:05 2018 -0700
TINKERPOP-2017 Added failing test case
---
gremlin-test/features/filter/Dedup.feature | 10 ++++++++++
.../gremlin/process/traversal/step/filter/DedupTest.java | 15 +++++++++++++++
2 files changed, 25 insertions(+)
diff --git a/gremlin-test/features/filter/Dedup.feature b/gremlin-test/features/filter/Dedup.feature
index 501d02b..56f3ee1 100644
--- a/gremlin-test/features/filter/Dedup.feature
+++ b/gremlin-test/features/filter/Dedup.feature
@@ -235,3 +235,13 @@ Feature: Step - dedup()
| result |
| d[0].l |
+ Scenario: g_V_bothE_properties_dedup_count
+ Given the modern graph
+ And the traversal of
+ """
+ g.V().bothE().properties().dedup().count()
+ """
+ When iterated to list
+ Then the result should be unordered
+ | result |
+ | d[6].l |
diff --git a/gremlin-test/src/main/java/org/apache/tinkerpop/gremlin/process/traversal/step/filter/DedupTest.java b/gremlin-test/src/main/java/org/apache/tinkerpop/gremlin/process/traversal/step/filter/DedupTest.java
index 0877ddb..386ce41 100644
--- a/gremlin-test/src/main/java/org/apache/tinkerpop/gremlin/process/traversal/step/filter/DedupTest.java
+++ b/gremlin-test/src/main/java/org/apache/tinkerpop/gremlin/process/traversal/step/filter/DedupTest.java
@@ -91,6 +91,8 @@ public abstract class DedupTest extends AbstractGremlinProcessTest {
public abstract Traversal<Vertex, Long> get_g_V_repeatXdedupX_timesX2X_count();
+ public abstract Traversal<Vertex, Long> get_g_V_bothE_properties_dedup_count();
+
@Test
@LoadGraphWith(MODERN)
public void g_V_out_in_valuesXnameX_fold_dedupXlocalX_unfold() {
@@ -312,6 +314,14 @@ public abstract class DedupTest extends AbstractGremlinProcessTest {
assertFalse(traversal.hasNext());
}
+ @Test
+ @LoadGraphWith(MODERN)
+ public void g_V_bothE_properties_dedup_count() {
+ final Traversal<Vertex, Long> traversal = get_g_V_bothE_properties_dedup_count();
+ printTraversalForm(traversal);
+ assertEquals(6L, traversal.next().longValue());
+ assertFalse(traversal.hasNext());
+ }
public static class Traversals extends DedupTest {
@Override
@@ -393,5 +403,10 @@ public abstract class DedupTest extends AbstractGremlinProcessTest {
public Traversal<Vertex, Long> get_g_V_repeatXdedupX_timesX2X_count() {
return g.V().repeat(dedup()).times(2).count();
}
+
+ @Override
+ public Traversal<Vertex, Long> get_g_V_bothE_properties_dedup_count() {
+ return g.V().bothE().properties().dedup().count();
+ }
}
}