You are viewing a plain text version of this content. The canonical link for it is here.
Posted to c-dev@axis.apache.org by Samisa Abeysinghe <sa...@gmail.com> on 2005/11/07 05:44:13 UTC

[AXIS2] param ordering of AXIS2_PARAM_CHECK macro]


We have
#define AXIS2_PARAM_CHECK(env, object, error_return)

IMHO it should be
#define AXIS2_PARAM_CHECK(param, env, error_return)
to keep it in sync with the convention that we are using.

Samisa...


Samisa Abeysinghe wrote:

> AXIS2_ERROR_HANDLE is really seting env error's values.
>
> Why not call it AXIS2_ERROR_SET
>
> Samisa...
>



[AXIS2] AXIS2_ERROR_SET parameters

Posted by Samisa Abeysinghe <sa...@gmail.com>.
We have
#define AXIS2_ERROR_SET(env, error_number, error_return)
I think it should be:
#define AXIS2_ERROR_SET(error, error_number, error_return)
We should pass the error, not env as we are setting the env.

Samisa...

Samisa Abeysinghe wrote:

>
>
> We have
> #define AXIS2_PARAM_CHECK(env, object, error_return)
>
> IMHO it should be
> #define AXIS2_PARAM_CHECK(param, env, error_return)
> to keep it in sync with the convention that we are using.
>
> Samisa...
>
>
> Samisa Abeysinghe wrote:
>
>> AXIS2_ERROR_HANDLE is really seting env error's values.
>>
>> Why not call it AXIS2_ERROR_SET
>>
>> Samisa...
>>
>
>
>