You are viewing a plain text version of this content. The canonical link for it is here.
Posted to jira@kafka.apache.org by "Mario Fiore Vitale (Jira)" <ji...@apache.org> on 2026/01/19 10:15:00 UTC
[jira] [Assigned] (KAFKA-20079) Improve Connect configurable components discoverability
[ https://issues.apache.org/jira/browse/KAFKA-20079?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Mario Fiore Vitale reassigned KAFKA-20079:
------------------------------------------
Assignee: Mario Fiore Vitale
> Improve Connect configurable components discoverability
> -------------------------------------------------------
>
> Key: KAFKA-20079
> URL: https://issues.apache.org/jira/browse/KAFKA-20079
> Project: Kafka
> Issue Type: Improvement
> Components: connect
> Reporter: Mario Fiore Vitale
> Assignee: Mario Fiore Vitale
> Priority: Major
>
> This improvement, related to [KIP-1272|https://cwiki.apache.org/confluence/display/KAFKA/KIP-1272%3A+Improve+Connect+configurable+components+discoverability], introduces a common {{ConfigSpecifier}} interface for Kafka Connect components that expose configuration metadata. By unifying the existing {{config()}} method across connectors, converters, transformations, and predicates under a single contract, it simplifies component discovery, reduces code duplication, and enables uniform tooling for configuration introspection, validation, documentation, and UI generation. The change is fully backward compatible and requires no modifications to existing component implementations.
--
This message was sent by Atlassian Jira
(v8.20.10#820010)