You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@commons.apache.org by "Benedikt Ritter (Created) (JIRA)" <ji...@apache.org> on 2012/01/20 17:31:39 UTC

[jira] [Created] (SANDBOX-360) Rename Converter to Transformer

Rename Converter<T, S> to Transformer<T, S>
-------------------------------------------

                 Key: SANDBOX-360
                 URL: https://issues.apache.org/jira/browse/SANDBOX-360
             Project: Commons Sandbox
          Issue Type: Improvement
          Components: BeanUtils2
    Affects Versions: Nightly Builds
            Reporter: Benedikt Ritter
            Priority: Minor


Since org.apache.commons.beanutils2.Converter is essentially a from of a Transformer (see org.apache.commons.collections.Transformer), it should be named this way. The same applies for org.apache.commons.beanutils2.converters.AbstractConverter<T,S>.


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Resolved] (SANDBOX-360) Rename Converter to Transformer

Posted by "Simone Tripodi (Resolved) (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/SANDBOX-360?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Simone Tripodi resolved SANDBOX-360.
------------------------------------

    Resolution: Fixed
      Assignee: Simone Tripodi

Refactor successfully applied, thanks Benedikt and Matt for the hints! see [r1234122|https://svn.apache.org/viewvc?view=revision&revision=1234122]
                
> Rename Converter<T, S> to Transformer<T, S>
> -------------------------------------------
>
>                 Key: SANDBOX-360
>                 URL: https://issues.apache.org/jira/browse/SANDBOX-360
>             Project: Commons Sandbox
>          Issue Type: Improvement
>          Components: BeanUtils2
>    Affects Versions: Nightly Builds
>            Reporter: Benedikt Ritter
>            Assignee: Simone Tripodi
>            Priority: Minor
>
> Since org.apache.commons.beanutils2.Converter is essentially a from of a Transformer (see org.apache.commons.collections.Transformer), it should be named this way. The same applies for org.apache.commons.beanutils2.converters.AbstractConverter<T,S>.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (SANDBOX-360) Rename Converter to Transformer

Posted by "Benedikt Ritter (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/SANDBOX-360?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13189919#comment-13189919 ] 

Benedikt Ritter commented on SANDBOX-360:
-----------------------------------------

As I mentioned on the mailing list, to me it seems, that concepts like Transformer, Predicate, Closure, etc. are missing in Java, giving the fact that for example commons collections and guava define nearly the same interfaces. Adding another label for something that basically transforms an object of one type into another an object of another type, does not seem to be the best thing to do. I would rather call it a transformer, like other libraries do and hope to see a JSR one day to get rid of it ;-)

I agree with you, that having the same interface defined in two projects is bad also. But I guess that is the price of having no dependencies. Maybe it would make sense to have a very minimal _commons essentials_ or _commons basics_ that has stuff like that in it. Some sort of base that really all projects share. Validation of input parameters is another thing that every project has to implement. 
But I think I'm drifting away... ;-)
                
> Rename Converter<T, S> to Transformer<T, S>
> -------------------------------------------
>
>                 Key: SANDBOX-360
>                 URL: https://issues.apache.org/jira/browse/SANDBOX-360
>             Project: Commons Sandbox
>          Issue Type: Improvement
>          Components: BeanUtils2
>    Affects Versions: Nightly Builds
>            Reporter: Benedikt Ritter
>            Priority: Minor
>
> Since org.apache.commons.beanutils2.Converter is essentially a from of a Transformer (see org.apache.commons.collections.Transformer), it should be named this way. The same applies for org.apache.commons.beanutils2.converters.AbstractConverter<T,S>.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (SANDBOX-360) Rename Converter to Transformer

Posted by "Matt Benson (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/SANDBOX-360?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13189901#comment-13189901 ] 

Matt Benson commented on SANDBOX-360:
-------------------------------------

The [collections] functors are all but deprecated; I wouldn't necessarily base other classes' names on theirs.  I would argue that in a full-blown transformation framework e.g. Morph, "transformer" is a generalization of "converter" and "copier".  My WIP object transformation library (which might become Morph 2) uses this type of nomenclature as well.
                
> Rename Converter<T, S> to Transformer<T, S>
> -------------------------------------------
>
>                 Key: SANDBOX-360
>                 URL: https://issues.apache.org/jira/browse/SANDBOX-360
>             Project: Commons Sandbox
>          Issue Type: Improvement
>          Components: BeanUtils2
>    Affects Versions: Nightly Builds
>            Reporter: Benedikt Ritter
>            Priority: Minor
>
> Since org.apache.commons.beanutils2.Converter is essentially a from of a Transformer (see org.apache.commons.collections.Transformer), it should be named this way. The same applies for org.apache.commons.beanutils2.converters.AbstractConverter<T,S>.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

[jira] [Commented] (SANDBOX-360) Rename Converter to Transformer

Posted by "Simone Tripodi (Commented) (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/SANDBOX-360?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13189894#comment-13189894 ] 

Simone Tripodi commented on SANDBOX-360:
----------------------------------------

I agree and like it, I was using the {{Converter}} keyword just because in the old API was named in that way :P

Just the time to leave the office and once get back home, will be done :)
Thanks!
                
> Rename Converter<T, S> to Transformer<T, S>
> -------------------------------------------
>
>                 Key: SANDBOX-360
>                 URL: https://issues.apache.org/jira/browse/SANDBOX-360
>             Project: Commons Sandbox
>          Issue Type: Improvement
>          Components: BeanUtils2
>    Affects Versions: Nightly Builds
>            Reporter: Benedikt Ritter
>            Priority: Minor
>
> Since org.apache.commons.beanutils2.Converter is essentially a from of a Transformer (see org.apache.commons.collections.Transformer), it should be named this way. The same applies for org.apache.commons.beanutils2.converters.AbstractConverter<T,S>.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira