You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@apisix.apache.org by Abhishek Choudhary <sh...@apache.org> on 2026/10/01 08:56:42 UTC

CVE-2026-94212: Apache APISIX: unauthenticated impersonation issue in saml-auth

Severity: 
    CVSS 4.0: 6.4 (medium) CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N

Affected versions:

- Apache APISIX 3.17.0 through 3.18.0

Description:

Improper verification of cryptographic signature vulnerability in Apache APISIX.



Any unauthenticated attacker could impersonate any user on every route protected by the saml-auth plugin under default configuration. This issue affects Apache APISIX: from 3.17.0 through 3.18.0.



Users are recommended to upgrade to version 3.19.0, which fixes the issue.

Credit:

LucasFutures (reporter)
shreemaan-abhishek (coordinator)
shreemaan-abhishek (remediation developer)

References:

https://apisix.apache.org
https://www.cve.org/CVERecord?id=CVE-2026-94212