You are viewing a plain text version of this content. The canonical link for it is here.
Posted to reviews@mesos.apache.org by Jojy Varghese <jo...@mesosphere.io> on 2016/03/18 01:16:50 UTC
Review Request 45002: Added FTS_PHYSICAL option to fts_open for rmdir.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/45002/
-----------------------------------------------------------
Review request for mesos, Jie Yu and Neil Conway.
Repository: mesos
Description
-------
According to the documentation for fts_open, either FTS_PHYSICAL or FTS_LOGICAL
SHOULD be provided. We need FTS_PHYSICAL for the case of rmdir as we dont want
to resolve the symlink targets while deleting them.
Diffs
-----
3rdparty/libprocess/3rdparty/stout/include/stout/os/posix/rmdir.hpp cbc97596cd8ed1e6d4261568fd0086c86e063232
3rdparty/libprocess/3rdparty/stout/tests/os/rmdir_tests.cpp daa46e05d113fd62ea9dad042ec41aaab28ad003
Diff: https://reviews.apache.org/r/45002/diff/
Testing
-------
make check.
Thanks,
Jojy Varghese
Re: Review Request 45002: Added FTS_PHYSICAL option to fts_open for
rmdir.
Posted by Cong Wang <xi...@gmail.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/45002/#review125120
-----------------------------------------------------------
Ship it!
Ship It!
- Cong Wang
On March 18, 2016, 12:16 a.m., Jojy Varghese wrote:
>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/45002/
> -----------------------------------------------------------
>
> (Updated March 18, 2016, 12:16 a.m.)
>
>
> Review request for mesos, Jie Yu and Neil Conway.
>
>
> Repository: mesos
>
>
> Description
> -------
>
> According to the documentation for fts_open, either FTS_PHYSICAL or FTS_LOGICAL
> SHOULD be provided. We need FTS_PHYSICAL for the case of rmdir as we dont want
> to resolve the symlink targets while deleting them.
>
>
> Diffs
> -----
>
> 3rdparty/libprocess/3rdparty/stout/include/stout/os/posix/rmdir.hpp cbc97596cd8ed1e6d4261568fd0086c86e063232
> 3rdparty/libprocess/3rdparty/stout/tests/os/rmdir_tests.cpp daa46e05d113fd62ea9dad042ec41aaab28ad003
>
> Diff: https://reviews.apache.org/r/45002/diff/
>
>
> Testing
> -------
>
> make check.
>
>
> Thanks,
>
> Jojy Varghese
>
>
Re: Review Request 45002: Added FTS_PHYSICAL option to fts_open for
rmdir.
Posted by Cong Wang <xi...@gmail.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/45002/#review125121
-----------------------------------------------------------
Not related to your patch, but it also makes sense to add FTS_NOSTAT flag to speed up? We don't need statp anyway.
- Cong Wang
On March 18, 2016, 12:16 a.m., Jojy Varghese wrote:
>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/45002/
> -----------------------------------------------------------
>
> (Updated March 18, 2016, 12:16 a.m.)
>
>
> Review request for mesos, Jie Yu and Neil Conway.
>
>
> Repository: mesos
>
>
> Description
> -------
>
> According to the documentation for fts_open, either FTS_PHYSICAL or FTS_LOGICAL
> SHOULD be provided. We need FTS_PHYSICAL for the case of rmdir as we dont want
> to resolve the symlink targets while deleting them.
>
>
> Diffs
> -----
>
> 3rdparty/libprocess/3rdparty/stout/include/stout/os/posix/rmdir.hpp cbc97596cd8ed1e6d4261568fd0086c86e063232
> 3rdparty/libprocess/3rdparty/stout/tests/os/rmdir_tests.cpp daa46e05d113fd62ea9dad042ec41aaab28ad003
>
> Diff: https://reviews.apache.org/r/45002/diff/
>
>
> Testing
> -------
>
> make check.
>
>
> Thanks,
>
> Jojy Varghese
>
>
Re: Review Request 45002: Added FTS_PHYSICAL option to fts_open for
rmdir.
Posted by Jojy Varghese <jo...@mesosphere.io>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/45002/
-----------------------------------------------------------
(Updated March 24, 2016, 1:34 a.m.)
Review request for mesos, Jie Yu and Neil Conway.
Changes
-------
review addressed.
Repository: mesos
Description
-------
According to the documentation for fts_open, either FTS_PHYSICAL or FTS_LOGICAL
SHOULD be provided. We need FTS_PHYSICAL for the case of rmdir as we dont want
to resolve the symlink targets while deleting them.
Diffs (updated)
-----
3rdparty/libprocess/3rdparty/stout/include/stout/os/posix/rmdir.hpp cbc97596cd8ed1e6d4261568fd0086c86e063232
3rdparty/libprocess/3rdparty/stout/tests/os/rmdir_tests.cpp 5bd154e40c6eeeeb45e74967b620141cc373bdee
Diff: https://reviews.apache.org/r/45002/diff/
Testing
-------
make check.
Thanks,
Jojy Varghese
Re: Review Request 45002: Added FTS_PHYSICAL option to fts_open for
rmdir.
Posted by Neil Conway <ne...@gmail.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/45002/#review125167
-----------------------------------------------------------
3rdparty/libprocess/3rdparty/stout/tests/os/rmdir_tests.cpp (line 268)
<https://reviews.apache.org/r/45002/#comment187956>
`os::touch` would be a bit more readable, I think.
- Neil Conway
On March 24, 2016, 1:07 a.m., Jojy Varghese wrote:
>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/45002/
> -----------------------------------------------------------
>
> (Updated March 24, 2016, 1:07 a.m.)
>
>
> Review request for mesos, Jie Yu and Neil Conway.
>
>
> Repository: mesos
>
>
> Description
> -------
>
> According to the documentation for fts_open, either FTS_PHYSICAL or FTS_LOGICAL
> SHOULD be provided. We need FTS_PHYSICAL for the case of rmdir as we dont want
> to resolve the symlink targets while deleting them.
>
>
> Diffs
> -----
>
> 3rdparty/libprocess/3rdparty/stout/include/stout/os/posix/rmdir.hpp cbc97596cd8ed1e6d4261568fd0086c86e063232
> 3rdparty/libprocess/3rdparty/stout/tests/os/rmdir_tests.cpp 5bd154e40c6eeeeb45e74967b620141cc373bdee
> src/tests/containerizer/provisioner_appc_tests.cpp 23a5b1059b4d9fde1e4a1aab5cd4fa6d05862332
>
> Diff: https://reviews.apache.org/r/45002/diff/
>
>
> Testing
> -------
>
> make check.
>
>
> Thanks,
>
> Jojy Varghese
>
>
Re: Review Request 45002: Added FTS_PHYSICAL option to fts_open for
rmdir.
Posted by Jojy Varghese <jo...@mesosphere.io>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/45002/
-----------------------------------------------------------
(Updated March 24, 2016, 1:07 a.m.)
Review request for mesos, Jie Yu and Neil Conway.
Changes
-------
review addressed.
Repository: mesos
Description
-------
According to the documentation for fts_open, either FTS_PHYSICAL or FTS_LOGICAL
SHOULD be provided. We need FTS_PHYSICAL for the case of rmdir as we dont want
to resolve the symlink targets while deleting them.
Diffs (updated)
-----
3rdparty/libprocess/3rdparty/stout/include/stout/os/posix/rmdir.hpp cbc97596cd8ed1e6d4261568fd0086c86e063232
3rdparty/libprocess/3rdparty/stout/tests/os/rmdir_tests.cpp 5bd154e40c6eeeeb45e74967b620141cc373bdee
src/tests/containerizer/provisioner_appc_tests.cpp 23a5b1059b4d9fde1e4a1aab5cd4fa6d05862332
Diff: https://reviews.apache.org/r/45002/diff/
Testing
-------
make check.
Thanks,
Jojy Varghese
Re: Review Request 45002: Added FTS_PHYSICAL option to fts_open for
rmdir.
Posted by Jojy Varghese <jo...@mesosphere.io>.
> On March 20, 2016, 2:36 a.m., Neil Conway wrote:
> > Per discussion in https://reviews.apache.org/r/45003/, if we can actually run into `FTS_SLNONE`, we should have a test-case for it.
I dont think with FTS_PHYSICAL (and without FTW_COMFOLLOW) we will get FTS_SLNONE. I could be wrong but having a peek inside the glibc code for fts_open, I believe thats the case.
- Jojy
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/45002/#review124434
-----------------------------------------------------------
On March 18, 2016, 12:16 a.m., Jojy Varghese wrote:
>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/45002/
> -----------------------------------------------------------
>
> (Updated March 18, 2016, 12:16 a.m.)
>
>
> Review request for mesos, Jie Yu and Neil Conway.
>
>
> Repository: mesos
>
>
> Description
> -------
>
> According to the documentation for fts_open, either FTS_PHYSICAL or FTS_LOGICAL
> SHOULD be provided. We need FTS_PHYSICAL for the case of rmdir as we dont want
> to resolve the symlink targets while deleting them.
>
>
> Diffs
> -----
>
> 3rdparty/libprocess/3rdparty/stout/include/stout/os/posix/rmdir.hpp cbc97596cd8ed1e6d4261568fd0086c86e063232
> 3rdparty/libprocess/3rdparty/stout/tests/os/rmdir_tests.cpp daa46e05d113fd62ea9dad042ec41aaab28ad003
>
> Diff: https://reviews.apache.org/r/45002/diff/
>
>
> Testing
> -------
>
> make check.
>
>
> Thanks,
>
> Jojy Varghese
>
>
Re: Review Request 45002: Added FTS_PHYSICAL option to fts_open for
rmdir.
Posted by Neil Conway <ne...@gmail.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/45002/#review124434
-----------------------------------------------------------
Per discussion in https://reviews.apache.org/r/45003/, if we can actually run into `FTS_SLNONE`, we should have a test-case for it.
3rdparty/libprocess/3rdparty/stout/include/stout/os/posix/rmdir.hpp (line 50)
<https://reviews.apache.org/r/45002/#comment186997>
This merits a comment explaining why we're setting `FTS_PHYSICAL`, I think.
- Neil Conway
On March 18, 2016, 12:16 a.m., Jojy Varghese wrote:
>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/45002/
> -----------------------------------------------------------
>
> (Updated March 18, 2016, 12:16 a.m.)
>
>
> Review request for mesos, Jie Yu and Neil Conway.
>
>
> Repository: mesos
>
>
> Description
> -------
>
> According to the documentation for fts_open, either FTS_PHYSICAL or FTS_LOGICAL
> SHOULD be provided. We need FTS_PHYSICAL for the case of rmdir as we dont want
> to resolve the symlink targets while deleting them.
>
>
> Diffs
> -----
>
> 3rdparty/libprocess/3rdparty/stout/include/stout/os/posix/rmdir.hpp cbc97596cd8ed1e6d4261568fd0086c86e063232
> 3rdparty/libprocess/3rdparty/stout/tests/os/rmdir_tests.cpp daa46e05d113fd62ea9dad042ec41aaab28ad003
>
> Diff: https://reviews.apache.org/r/45002/diff/
>
>
> Testing
> -------
>
> make check.
>
>
> Thanks,
>
> Jojy Varghese
>
>
Re: Review Request 45002: Added FTS_PHYSICAL option to fts_open for
rmdir.
Posted by Jie Yu <yu...@gmail.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/45002/#review125066
-----------------------------------------------------------
Fix it, then Ship it!
3rdparty/libprocess/3rdparty/stout/include/stout/os/posix/rmdir.hpp (line 50)
<https://reviews.apache.org/r/45002/#comment187810>
+1 on adding a comments about why FTS_PHYSICAL is needed.
- Jie Yu
On March 18, 2016, 12:16 a.m., Jojy Varghese wrote:
>
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/45002/
> -----------------------------------------------------------
>
> (Updated March 18, 2016, 12:16 a.m.)
>
>
> Review request for mesos, Jie Yu and Neil Conway.
>
>
> Repository: mesos
>
>
> Description
> -------
>
> According to the documentation for fts_open, either FTS_PHYSICAL or FTS_LOGICAL
> SHOULD be provided. We need FTS_PHYSICAL for the case of rmdir as we dont want
> to resolve the symlink targets while deleting them.
>
>
> Diffs
> -----
>
> 3rdparty/libprocess/3rdparty/stout/include/stout/os/posix/rmdir.hpp cbc97596cd8ed1e6d4261568fd0086c86e063232
> 3rdparty/libprocess/3rdparty/stout/tests/os/rmdir_tests.cpp daa46e05d113fd62ea9dad042ec41aaab28ad003
>
> Diff: https://reviews.apache.org/r/45002/diff/
>
>
> Testing
> -------
>
> make check.
>
>
> Thanks,
>
> Jojy Varghese
>
>