You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@poi.apache.org by bu...@apache.org on 2015/08/18 05:30:51 UTC

[Bug 58253] New: [PATCH] Minor changes to CellReference

https://bz.apache.org/bugzilla/show_bug.cgi?id=58253

            Bug ID: 58253
           Summary: [PATCH] Minor changes to CellReference
           Product: POI
           Version: unspecified
          Hardware: PC
                OS: Linux
            Status: NEW
          Severity: enhancement
          Priority: P2
         Component: SS Common
          Assignee: dev@poi.apache.org
          Reporter: javenoneal@gmail.com

Created attachment 33006
  --> https://bz.apache.org/bugzilla/attachment.cgi?id=33006&action=edit
CellReference.java patch

A few minor changes to CellReference:

* Compare cellRefString.toUpperCase() with "#REF!" for CellReference(String)
* Change private separateRefParts(String) to return a struct instead of a
3-element String array. The goal here was to make the code easier to read and
more flexible if POI supports cell references external to the workbook, though
I don't know if creating an object is more expensive (time or memory) than a
String array. Do we have a good way to test this?
* Update javadoc for separateRefParts

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@poi.apache.org
For additional commands, e-mail: dev-help@poi.apache.org


[Bug 58253] [PATCH] Minor changes to CellReference

Posted by bu...@apache.org.
https://bz.apache.org/bugzilla/show_bug.cgi?id=58253

Nick Burch <ap...@gagravarr.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
         Resolution|---                         |FIXED
             Status|NEW                         |RESOLVED

--- Comment #1 from Nick Burch <ap...@gagravarr.org> ---
Thanks, patch committed in r1696430.

(Even if the string[] is a smidgen faster, readability is important to, so
seems worth it)

-- 
You are receiving this mail because:
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@poi.apache.org
For additional commands, e-mail: dev-help@poi.apache.org