You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-commits@hadoop.apache.org by Apache Wiki <wi...@apache.org> on 2015/03/29 05:16:53 UTC

[Hadoop Wiki] Update of "HowToContribute" by SomeOtherAccount

Dear Wiki user,

You have subscribed to a wiki page or wiki category on "Hadoop Wiki" for change notification.

The "HowToContribute" page has been changed by SomeOtherAccount:
https://wiki.apache.org/hadoop/HowToContribute?action=diff&rev1=104&rev2=105

Comment:
some git and jira issue bits

  
   * reformat code unrelated to the bug being fixed: formatting changes should be separate patches/commits.
   * comment out code that is now obsolete: just remove it.
-  * insert comments around each change, marking the change: folks can use subversion to figure out what's changed and by whom.
+  * insert comments around each change, marking the change: folks can use git to figure out what's changed and by whom.
   * make things public which are not required by end users.
  
  Please do:
@@ -154, +154 @@

  
  Patches for trunk should be named according to the Jira, with a version number: '''<jiraName>.<versionNum>.patch''', e.g. HADOOP-1234.001.patch, HDFS-4321.002.patch.
  
- Patches for a non-trunk branch should be named '''<jiraName>-<branchName>.<versionNum>.patch''', e.g. HDFS-1234-branch-0.23.003.patch.  The branch name suffix should be the exact name of a Subversion branch under hadoop/common/branches/, such as "branch-0.23". Please note that the Jenkins pre-commit build is only run against trunk.
+ Patches for a non-trunk branch should be named '''<jiraName>-<branchName>.<versionNum>.patch''', e.g. HDFS-1234-branch-0.23.003.patch.  The branch name suffix should be the exact name of a git branch, such as "branch-0.23". Please note that the Jenkins pre-commit build is only run against trunk.
  
  It's also OK to upload a new patch to Jira with the same name as an existing patch. If you select the "Activity>All" tab then the different versions are linked in the comment stream, providing context. However, many reviewers find it helpful to include a version number in the patch name (three-digit version number is recommended), '''so including a version number is the preferred style'''.
  
@@ -201, +201 @@

  
  == Contributing your work ==
    1. Finally, patches should be ''attached'' to an issue report in [[http://issues.apache.org/jira/browse/HADOOP|Jira]] via the '''Attach File''' link on the issue's Jira. Please add a comment that asks for a code review following our [[CodeReviewChecklist|code review checklist]]. Please note that the attachment should be granted license to ASF for inclusion in ASF works (as per the [[http://www.apache.org/licenses/LICENSE-2.0|Apache License]] ยง5).
-   1. When you believe that your patch is ready to be committed, select the '''Submit Patch''' link on the issue's Jira.  Submitted patches will be automatically tested against "trunk" by [[http://hudson.zones.apache.org/hudson/view/Hadoop/|Hudson]], the project's continuous integration engine.  Upon test completion, Hudson will add a success ("+1") message or failure ("-1") to your issue report in Jira.  If your issue contains multiple patch versions, Hudson tests the last patch uploaded.
+   1. When you believe that your patch is ready to be committed, select the '''Submit Patch''' link on the issue's Jira.  Submitted patches will be automatically tested against "trunk" by [[http://hudson.zones.apache.org/hudson/view/Hadoop/|Hudson]], the project's continuous integration engine.  Upon test completion, Hudson will add a success ("+1") message or failure ("-1") to your issue report in Jira.  If your issue contains multiple patch versions, Hudson tests the last patch uploaded.  It is preferable to upload the trunk version last.
    1. Folks should run {{{mvn clean install javadoc:javadoc checkstyle:checkstyle}}} before selecting '''Submit Patch'''.
      1. Tests must all pass.
      1. Javadoc should report '''no''' warnings or errors.
@@ -222, +222 @@

  
  Please refrain from editing descriptions and comments if possible, as edits spam the mailing list and clutter Jira's "All" display, which is otherwise very useful.  Instead, preview descriptions and comments using the preview button (on the right) before posting them.  Keep descriptions brief and save more elaborate proposals for comments, since descriptions are included in Jira's automatically sent messages.  If you change your mind, note this in a new comment, rather than editing an older comment.  The issue should preserve this history of the discussion.
  
+ Additionally, do not set the Fix Version. Committers use this field to determine which branches have had patches committed.  Instead, use the Affects and Target Versions to notify others of the branches that should be considered.
+ 
  == Stay involved ==
  Contributors should join the [[http://hadoop.apache.org/core/mailing_lists.html|Hadoop mailing lists]].  In particular, the commit list (to see changes as they are made), the dev list (to join discussions of changes) and the user list (to help others).