You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@hc.apache.org by "Dmitry Potapov (JIRA)" <ji...@apache.org> on 2014/07/03 19:06:33 UTC
[jira] [Updated] (HTTPCORE-386) BasicHttpResponse and
BasicAsync(Response/Request)Producer should have proper .toString()
implementation
[ https://issues.apache.org/jira/browse/HTTPCORE-386?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Dmitry Potapov updated HTTPCORE-386:
------------------------------------
Attachment: toString.patch
Please, consider this patch as a solution for this ticket.
> BasicHttpResponse and BasicAsync(Response/Request)Producer should have proper .toString() implementation
> --------------------------------------------------------------------------------------------------------
>
> Key: HTTPCORE-386
> URL: https://issues.apache.org/jira/browse/HTTPCORE-386
> Project: HttpComponents HttpCore
> Issue Type: Improvement
> Reporter: Dmitry Potapov
> Priority: Trivial
> Attachments: toString.patch
>
>
> Sometimes it is useful to print Response/Request producer info to log. Doing this every time by hands leads to code duplications and poor code quality.
> My suggestion is to add proper .toString() implementation to AbstractHttpEntity, BasicHttpResponse, BasicAsyncResponseProducer and BasicAsyncRequestProducer.
--
This message was sent by Atlassian JIRA
(v6.2#6252)
---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@hc.apache.org
For additional commands, e-mail: dev-help@hc.apache.org