You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@ignite.apache.org by "Pavel Tupitsyn (Jira)" <ji...@apache.org> on 2024/06/07 04:57:00 UTC

[jira] [Created] (IGNITE-22428) Rename JobExecutionContext.isInterrupted to isCancelled

Pavel Tupitsyn created IGNITE-22428:
---------------------------------------

             Summary: Rename JobExecutionContext.isInterrupted to isCancelled
                 Key: IGNITE-22428
                 URL: https://issues.apache.org/jira/browse/IGNITE-22428
             Project: Ignite
          Issue Type: Improvement
          Components: compute
    Affects Versions: 3.0.0-beta1
            Reporter: Pavel Tupitsyn
            Assignee: Pavel Tupitsyn
             Fix For: 3.0.0-beta2


Javadoc says:
{code}
returns {@code false} when the job couldn't be cancelled (either it's not yet started...
{code}

If the job is not yet started, it should be removed from the queue:
* Make sure the method works as expected
* Fix javadoc



--
This message was sent by Atlassian Jira
(v8.20.10#820010)