You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@camel.apache.org by Aki Yoshida <el...@gmail.com> on 2014/08/06 11:26:40 UTC
problem with current 2.14-SNAPSHOT on karaf-3.0.1?
I am getting this error when using camel feature for 2.14-SNAPSHOT on
karaf-3.0.1.
Error executing command: Could not start bundle
mvn:org.apache.camel.karaf/camel-karaf-commands/2.14-SNAPSHOT in
feature(s) camel-core-2.14-SNAPSHOT: Unresolved constraint in bundle
org.apache.camel.karaf.camel-karaf-commands [85]: Unable to resolve
85.0: missing requirement [85.0] osgi.wiring.package;
(&(osgi.wiring.package=jline.console.completer)(version>=2.12.0)(!(version>=3.0.0)))
I noticed that karaf-3.0.1 comes with jline 2.11.
karaf@root()> list -t 0 | grep JLine
26 | Active | 30 | 2.11.0 | JLine
but org.apache.karaf.shell/org.apache.karaf.shell.console/2.3.6 is
asking for jline 2.12.
camel-2.14-SNAPSHOT has recently upgraded to use karaf 2.3.6.
https://git-wip-us.apache.org/repos/asf?p=camel.git;a=commit;h=14cb8b1c6afcbf7b2e13252e7c4b90d85909f013
Is there a simple workaround for this? I'm not sure if something was
messed up on my system or if this is an issue.
And if this is an issue, I don't know if we are supposed to add jline
2.12 in the camel's feature or revert this 2.3.6 upgrade?
regards, aki
Re: problem with current 2.14-SNAPSHOT on karaf-3.0.1?
Posted by Aki Yoshida <el...@gmail.com>.
This version range setting is no under camel's control.
camel asks for karaf feature 2.3.6 and
org.apache.karaf.shell.console/2.3.6 is asking for jline 2.12.
karaf-3.0.2-SNAPSHOT comes with jline 2.12, so there is no problem
with the next karaf 3.0.x version.
But with the current karaf 3.0.1 version, I needed to swap the jline
version in system/jline and adjust etc/startup.properties.
So, we will need to add a release note about this jline swap required
for karaf 3.0.1 if camel-2.14.0 is released with karaf feature 2.3.6.
I asked at user@karaf a couple of things.
http://karaf.922171.n3.nabble.com/karaf-shell-console-2-3-6-asking-for-jline-2-12-td4034628.html
(had to repost this today to the right ML because I posted it
yesterday to users@karaf.apache.org and not to user@karaf.apache.org.)
regards, aki
2014-08-06 18:01 GMT+02:00 Claus Ibsen <cl...@gmail.com>:
> Maybe the jline import version should be wider, and be [2.11,3). This
> just bites next time there is a jline / karaf / whatever upgrade
> somewhere.
>
>
> On Wed, Aug 6, 2014 at 11:26 AM, Aki Yoshida <el...@gmail.com> wrote:
>> I am getting this error when using camel feature for 2.14-SNAPSHOT on
>> karaf-3.0.1.
>>
>> Error executing command: Could not start bundle
>> mvn:org.apache.camel.karaf/camel-karaf-commands/2.14-SNAPSHOT in
>> feature(s) camel-core-2.14-SNAPSHOT: Unresolved constraint in bundle
>> org.apache.camel.karaf.camel-karaf-commands [85]: Unable to resolve
>> 85.0: missing requirement [85.0] osgi.wiring.package;
>> (&(osgi.wiring.package=jline.console.completer)(version>=2.12.0)(!(version>=3.0.0)))
>>
>> I noticed that karaf-3.0.1 comes with jline 2.11.
>>
>> karaf@root()> list -t 0 | grep JLine
>> 26 | Active | 30 | 2.11.0 | JLine
>>
>> but org.apache.karaf.shell/org.apache.karaf.shell.console/2.3.6 is
>> asking for jline 2.12.
>>
>> camel-2.14-SNAPSHOT has recently upgraded to use karaf 2.3.6.
>> https://git-wip-us.apache.org/repos/asf?p=camel.git;a=commit;h=14cb8b1c6afcbf7b2e13252e7c4b90d85909f013
>>
>> Is there a simple workaround for this? I'm not sure if something was
>> messed up on my system or if this is an issue.
>>
>> And if this is an issue, I don't know if we are supposed to add jline
>> 2.12 in the camel's feature or revert this 2.3.6 upgrade?
>>
>> regards, aki
>
>
>
> --
> Claus Ibsen
> -----------------
> Red Hat, Inc.
> Email: cibsen@redhat.com
> Twitter: davsclaus
> Blog: http://davsclaus.com
> Author of Camel in Action: http://www.manning.com/ibsen
> hawtio: http://hawt.io/
> fabric8: http://fabric8.io/
Re: problem with current 2.14-SNAPSHOT on karaf-3.0.1?
Posted by Claus Ibsen <cl...@gmail.com>.
Maybe the jline import version should be wider, and be [2.11,3). This
just bites next time there is a jline / karaf / whatever upgrade
somewhere.
On Wed, Aug 6, 2014 at 11:26 AM, Aki Yoshida <el...@gmail.com> wrote:
> I am getting this error when using camel feature for 2.14-SNAPSHOT on
> karaf-3.0.1.
>
> Error executing command: Could not start bundle
> mvn:org.apache.camel.karaf/camel-karaf-commands/2.14-SNAPSHOT in
> feature(s) camel-core-2.14-SNAPSHOT: Unresolved constraint in bundle
> org.apache.camel.karaf.camel-karaf-commands [85]: Unable to resolve
> 85.0: missing requirement [85.0] osgi.wiring.package;
> (&(osgi.wiring.package=jline.console.completer)(version>=2.12.0)(!(version>=3.0.0)))
>
> I noticed that karaf-3.0.1 comes with jline 2.11.
>
> karaf@root()> list -t 0 | grep JLine
> 26 | Active | 30 | 2.11.0 | JLine
>
> but org.apache.karaf.shell/org.apache.karaf.shell.console/2.3.6 is
> asking for jline 2.12.
>
> camel-2.14-SNAPSHOT has recently upgraded to use karaf 2.3.6.
> https://git-wip-us.apache.org/repos/asf?p=camel.git;a=commit;h=14cb8b1c6afcbf7b2e13252e7c4b90d85909f013
>
> Is there a simple workaround for this? I'm not sure if something was
> messed up on my system or if this is an issue.
>
> And if this is an issue, I don't know if we are supposed to add jline
> 2.12 in the camel's feature or revert this 2.3.6 upgrade?
>
> regards, aki
--
Claus Ibsen
-----------------
Red Hat, Inc.
Email: cibsen@redhat.com
Twitter: davsclaus
Blog: http://davsclaus.com
Author of Camel in Action: http://www.manning.com/ibsen
hawtio: http://hawt.io/
fabric8: http://fabric8.io/
Re: problem with current 2.14-SNAPSHOT on karaf-3.0.1?
Posted by Aki Yoshida <el...@gmail.com>.
I just saw some messages on dev@karaf.
I could try replacing Jline manually in karaf-3.0.1 for now.
2014-08-06 11:26 GMT+02:00 Aki Yoshida <el...@gmail.com>:
> I am getting this error when using camel feature for 2.14-SNAPSHOT on
> karaf-3.0.1.
>
> Error executing command: Could not start bundle
> mvn:org.apache.camel.karaf/camel-karaf-commands/2.14-SNAPSHOT in
> feature(s) camel-core-2.14-SNAPSHOT: Unresolved constraint in bundle
> org.apache.camel.karaf.camel-karaf-commands [85]: Unable to resolve
> 85.0: missing requirement [85.0] osgi.wiring.package;
> (&(osgi.wiring.package=jline.console.completer)(version>=2.12.0)(!(version>=3.0.0)))
>
> I noticed that karaf-3.0.1 comes with jline 2.11.
>
> karaf@root()> list -t 0 | grep JLine
> 26 | Active | 30 | 2.11.0 | JLine
>
> but org.apache.karaf.shell/org.apache.karaf.shell.console/2.3.6 is
> asking for jline 2.12.
>
> camel-2.14-SNAPSHOT has recently upgraded to use karaf 2.3.6.
> https://git-wip-us.apache.org/repos/asf?p=camel.git;a=commit;h=14cb8b1c6afcbf7b2e13252e7c4b90d85909f013
>
> Is there a simple workaround for this? I'm not sure if something was
> messed up on my system or if this is an issue.
>
> And if this is an issue, I don't know if we are supposed to add jline
> 2.12 in the camel's feature or revert this 2.3.6 upgrade?
>
> regards, aki