You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@hbase.apache.org by Nick Dimiduk <nd...@gmail.com> on 2014/11/20 11:29:47 UTC

Table#setAutoFlushTo

Heya,

Do we want to change this method name in the new Table interface to just
setAutoFlush? Will this be confusing for folks migrating from the
HTableInterface methods?

Would be good to make a decision on this (and any other Client API changes)
before 1.0.

-n

Re: Table#setAutoFlushTo

Posted by Solomon Duskis <sd...@gmail.com>.
setAutoFlush(boolean) and setAutoFlushTo(boolean) have slightly different
behavior regarding to the deprecated value of clearBufferOnFail.  I have
enough background with the nuances of what clearBufferOnFail actually
does, but I leveraged that difference while making a change related to the
difference while trying to eliminate calls to setAutoFlush(boolean,
boolean).  Some decision should probably be made on how to
handle clearBufferOnFail as part of the setAutoFlushTo(boolean) vs.
setAutoFlush(boolean).

>From HTable:

  @Deprecated
  @Override
  public void setAutoFlush(boolean autoFlush) {
    setAutoFlush(autoFlush, *autoFlush*);
  }

  @Override
  public void setAutoFlushTo(boolean autoFlush) {
    setAutoFlush(autoFlush, *clearBufferOnFail*);
  }

  @Override
  public void setAutoFlush(boolean autoFlush, boolean clearBufferOnFail) {
    this.autoFlush = autoFlush;
    this.clearBufferOnFail = autoFlush || clearBufferOnFail;
  }

On Thu, Nov 20, 2014 at 5:29 AM, Nick Dimiduk <nd...@gmail.com> wrote:

> Heya,
>
> Do we want to change this method name in the new Table interface to just
> setAutoFlush? Will this be confusing for folks migrating from the
> HTableInterface methods?
>
> Would be good to make a decision on this (and any other Client API changes)
> before 1.0.
>
> -n
>

Re: Table#setAutoFlushTo

Posted by Nick Dimiduk <nd...@gmail.com>.
Also, #incrementColumnValue seems like it's "tacked on". It appears to be a
subset of functionality provided by #increment. Why do we provide this
interface but not an equivalent #appendColumnValue ?

Rename #mutateRow to just #mutate ? This would make mutate/checkAndMutate
consistent with put/checkAndPut and delete/checkAndDelete.

Do we want to drop the @deprecated methods from this interface as well, or
is that put off for 2.0 ?

On Thu, Nov 20, 2014 at 11:29 AM, Nick Dimiduk <nd...@gmail.com> wrote:

> Heya,
>
> Do we want to change this method name in the new Table interface to just
> setAutoFlush? Will this be confusing for folks migrating from the
> HTableInterface methods?
>
> Would be good to make a decision on this (and any other Client API
> changes) before 1.0.
>
> -n
>