You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@hbase.apache.org by "nkeywal (Updated) (JIRA)" <ji...@apache.org> on 2011/12/14 14:43:30 UTC
[jira] [Updated] (HBASE-5025) Two threads named pool-1-thread-1 and
pool-2-thread-1 remains after the shutdown of a cluster
[ https://issues.apache.org/jira/browse/HBASE-5025?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
nkeywal updated HBASE-5025:
---------------------------
Description:
There are two issues with these threads:
- there should have a better name. pool-x-thread-y is the default name given by java.util.concurrent.Executors
- these threads should not survive to a minicluster shutdown
They are created by org.apache.hadoop.ipc.Server$Listener (with version 0.20.205.0; the code was different before), so the first issue is a hadoop common one. It's unclear for the second one, it could be hadoop-common as well.
Constructor for org.apache.hadoop.ipc.Server$Listener:
{noformat}
public Listener() throws IOException {
//...
readPool = Executors.newFixedThreadPool(readThreads); // Lack a ThreadFactory to set the names
//...
}
{noformat}
Server#stop shutdowns the thread pool.
was:
There are two issues with these threads:
- there should have a better name. pool-x-thread-y is the default name given by java.util.concurrent.Executors
- these threads should not survive to a minicluster shutdown
They are created by org.apache.hadoop.ipc.Server$Listener (with version 0.20.205.0; the code was different before), so the first issue is a hadoop common one. It's unclear for the second one, it could be hadoop-common as well.
> Two threads named pool-1-thread-1 and pool-2-thread-1 remains after the shutdown of a cluster
> ---------------------------------------------------------------------------------------------
>
> Key: HBASE-5025
> URL: https://issues.apache.org/jira/browse/HBASE-5025
> Project: HBase
> Issue Type: Bug
> Components: ipc, test
> Affects Versions: 0.94.0
> Reporter: nkeywal
> Priority: Minor
>
> There are two issues with these threads:
> - there should have a better name. pool-x-thread-y is the default name given by java.util.concurrent.Executors
> - these threads should not survive to a minicluster shutdown
> They are created by org.apache.hadoop.ipc.Server$Listener (with version 0.20.205.0; the code was different before), so the first issue is a hadoop common one. It's unclear for the second one, it could be hadoop-common as well.
> Constructor for org.apache.hadoop.ipc.Server$Listener:
> {noformat}
> public Listener() throws IOException {
> //...
> readPool = Executors.newFixedThreadPool(readThreads); // Lack a ThreadFactory to set the names
> //...
> }
> {noformat}
> Server#stop shutdowns the thread pool.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira