You are viewing a plain text version of this content. The canonical link for it is here.
Posted to reviews@mesos.apache.org by Chun-Hung Hsiao <ch...@apache.org> on 2019/01/15 05:58:33 UTC

Re: Review Request 69158: Added an integration test for resource provider removal.

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/69158/#review211996
-----------------------------------------------------------




src/tests/slave_tests.cpp
Lines 10617 (patched)
<https://reviews.apache.org/r/69158/#comment297583>

    We could rename it to `updateSlaveMessage` and reuse it below.



src/tests/slave_tests.cpp
Lines 10625-10626 (patched)
<https://reviews.apache.org/r/69158/#comment297585>

    ```
    Owned<MasterDetector> detector = master.get()->createDetector();
    Try<Owned<cluster::Slave>> slave = StartSlave(detector.get(), slavFlags);
    ```



src/tests/slave_tests.cpp
Lines 10633 (patched)
<https://reviews.apache.org/r/69158/#comment297586>

    `org.apache.mesos.rp.test`, or maybe `org.apache.mesos.rp.mock`, for consistency.



src/tests/slave_tests.cpp
Lines 10652 (patched)
<https://reviews.apache.org/r/69158/#comment297582>

    `std::move(endpointDetector)`


- Chun-Hung Hsiao


On Oct. 25, 2018, 10:47 a.m., Benjamin Bannier wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/69158/
> -----------------------------------------------------------
> 
> (Updated Oct. 25, 2018, 10:47 a.m.)
> 
> 
> Review request for mesos, Chun-Hung Hsiao and Jan Schlicht.
> 
> 
> Bugs: MESOS-8403
>     https://issues.apache.org/jira/browse/MESOS-8403
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Added an integration test for resource provider removal.
> 
> 
> Diffs
> -----
> 
>   src/tests/slave_tests.cpp 1e918712d73d0a03c4c15b41babff1f649ba9c07 
> 
> 
> Diff: https://reviews.apache.org/r/69158/diff/4/
> 
> 
> Testing
> -------
> 
> `make check`
> 
> 
> Thanks,
> 
> Benjamin Bannier
> 
>


Re: Review Request 69158: Added an integration test for resource provider removal.

Posted by Benjamin Bannier <be...@mesosphere.io>.

> On Jan. 15, 2019, 6:58 a.m., Chun-Hung Hsiao wrote:
> > src/tests/slave_tests.cpp
> > Lines 10625-10626 (patched)
> > <https://reviews.apache.org/r/69158/diff/4/?file=2111265#file2111265line10625>
> >
> >     ```
> >     Owned<MasterDetector> detector = master.get()->createDetector();
> >     Try<Owned<cluster::Slave>> slave = StartSlave(detector.get(), slavFlags);
> >     ```

Could you explain the pattern we follow? I mostly went for a `StandaloneMasterDetector` instead of an `Owned<MasterDetector>` because of the conceptually simpler type (value vs pointer), but we seem to use both here.


- Benjamin


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/69158/#review211996
-----------------------------------------------------------


On Jan. 15, 2019, 4:03 p.m., Benjamin Bannier wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/69158/
> -----------------------------------------------------------
> 
> (Updated Jan. 15, 2019, 4:03 p.m.)
> 
> 
> Review request for mesos, Chun-Hung Hsiao and Jan Schlicht.
> 
> 
> Bugs: MESOS-8403
>     https://issues.apache.org/jira/browse/MESOS-8403
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Added an integration test for resource provider removal.
> 
> 
> Diffs
> -----
> 
>   src/tests/slave_tests.cpp dc711de96053ebecb6b71b98f14f22cb9b050c52 
> 
> 
> Diff: https://reviews.apache.org/r/69158/diff/5/
> 
> 
> Testing
> -------
> 
> `make check`
> 
> 
> Thanks,
> 
> Benjamin Bannier
> 
>


Re: Review Request 69158: Added an integration test for resource provider removal.

Posted by Benjamin Bannier <be...@mesosphere.io>.

> On Jan. 15, 2019, 6:58 a.m., Chun-Hung Hsiao wrote:
> > src/tests/slave_tests.cpp
> > Lines 10625-10626 (patched)
> > <https://reviews.apache.org/r/69158/diff/4/?file=2111265#file2111265line10625>
> >
> >     ```
> >     Owned<MasterDetector> detector = master.get()->createDetector();
> >     Try<Owned<cluster::Slave>> slave = StartSlave(detector.get(), slavFlags);
> >     ```
> 
> Benjamin Bannier wrote:
>     Could you explain the pattern we follow? I mostly went for a `StandaloneMasterDetector` instead of an `Owned<MasterDetector>` because of the conceptually simpler type (value vs pointer), but we seem to use both here.

Dropping, see discussion in https://reviews.apache.org/r/68147/#comment_rc297584-212023.


- Benjamin


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/69158/#review211996
-----------------------------------------------------------


On Jan. 16, 2019, 11:51 a.m., Benjamin Bannier wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/69158/
> -----------------------------------------------------------
> 
> (Updated Jan. 16, 2019, 11:51 a.m.)
> 
> 
> Review request for mesos, Chun-Hung Hsiao and Jan Schlicht.
> 
> 
> Bugs: MESOS-8403
>     https://issues.apache.org/jira/browse/MESOS-8403
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Added an integration test for resource provider removal.
> 
> 
> Diffs
> -----
> 
>   src/tests/slave_tests.cpp dc711de96053ebecb6b71b98f14f22cb9b050c52 
> 
> 
> Diff: https://reviews.apache.org/r/69158/diff/6/
> 
> 
> Testing
> -------
> 
> `make check`
> 
> 
> Thanks,
> 
> Benjamin Bannier
> 
>