You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-dev@hadoop.apache.org by "Pi Song (JIRA)" <ji...@apache.org> on 2008/02/09 14:35:07 UTC

[jira] Issue Comment Edited: (HADOOP-2759) creating a file in hdfs should not automatically create the parent directories

    [ https://issues.apache.org/jira/browse/HADOOP-2759?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12567307#action_12567307 ] 

pi_song edited comment on HADOOP-2759 at 2/9/08 5:33 AM:
---------------------------------------------------------

This issue involves two things

- data file creation
- directory creation

At the moment if you create any of them, all the parents will be created!!!

I plan to add new mkdir and createFile that don't create all the parent dirs instead of changing the old ones because I don't want to have backward compatibility problems.  Now the question is should I mark the old mkdir and createFile as @deprecated? I still feel sometimes we need methods that ensure parent dir creation but then if I don't it will encourage people to still use the old ones and here comes problems like in HADOOP-2391.

I also need a new name for createFile that doesn't create parents. (For mkdir it's easy, the old one is mkdirs and the new one is mkdir therefore like in Java)

      was (Author: pi_song):
    This issue involves two things

- data file creation
- directory creation

I plan to add new mkdir and createFile that don't create all the parent dirs instead of changing the old ones because I don't want to have backward compatibility problems.  Now the question is should I mark the old mkdir and createFile as @deprecated? I still feel sometimes we need methods that ensure parent dir creation but then if I don't it will encourage people to still use the old ones and here comes problems like in HADOOP-2391.

I also need a new name for createFile that doesn't create parents. (For mkdir it's easy, the old one is mkdirs and the new one is mkdir therefore like in Java)
  
> creating a file in hdfs should not automatically create the parent directories
> ------------------------------------------------------------------------------
>
>                 Key: HADOOP-2759
>                 URL: https://issues.apache.org/jira/browse/HADOOP-2759
>             Project: Hadoop Core
>          Issue Type: Bug
>          Components: dfs
>    Affects Versions: 0.17.0
>            Reporter: Owen O'Malley
>             Fix For: 0.17.0
>
>         Attachments: HADOOP-2759_1.patch
>
>
> I think it would be better if HDFS didn't automatically create directories for the user. In particular, in clean up code, it would be nice if deleting a directory couldn't be undone by mistake by a process that hasn't been killed yet creating a new file.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.