You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@lucene.apache.org by "Simon Willnauer (JIRA)" <ji...@apache.org> on 2010/11/25 11:51:13 UTC

[jira] Created: (LUCENE-2777) Revise PagedBytes#fillUsingLengthPrefix* methods names

Revise PagedBytes#fillUsingLengthPrefix* methods names
------------------------------------------------------

                 Key: LUCENE-2777
                 URL: https://issues.apache.org/jira/browse/LUCENE-2777
             Project: Lucene - Java
          Issue Type: Task
    Affects Versions: CSF branch, 4.0
            Reporter: Simon Willnauer
            Priority: Minor


PagedBytes has 3 different variants of fillUsingLengthPrefix. We need better names for that since CSFBranch already added a 4th one.


here are some suggestions:

{code}
/** Reads length as 1 or 2 byte vInt prefix, starting @ start */
    public BytesRef fillLengthAndOffset(BytesRef b, long start) 
//    was: public BytesRef fillUsingLengthPrefix(BytesRef b, long start) 


 /** @lucene.internal  Reads length as 1 or 2 byte vInt prefix, starting @ start.  Returns the block number of the term. */
    public int getBlockAndFill(BytesRef b, long start) 
//    was: public BytesRef fillUsingLengthPrefix2(BytesRef b, long start) 

/** @lucene.internal  Reads length as 1 or 2 byte vInt prefix, starting @ start. 
     * Returns the start offset of the next part, suitable as start parameter on next call
     * to sequentially read all BytesRefs. */
    public long getNextOffsetAndFill(BytesRef b, long start) 
//    was: public BytesRef fillUsingLengthPrefix3(BytesRef b, long start) 

{code}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


[jira] Commented: (LUCENE-2777) Revise PagedBytes#fillUsingLengthPrefix* methods names

Posted by "Michael McCandless (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/LUCENE-2777?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12936007#action_12936007 ] 

Michael McCandless commented on LUCENE-2777:
--------------------------------------------

Looks good Simon!

> Revise PagedBytes#fillUsingLengthPrefix* methods names
> ------------------------------------------------------
>
>                 Key: LUCENE-2777
>                 URL: https://issues.apache.org/jira/browse/LUCENE-2777
>             Project: Lucene - Java
>          Issue Type: Task
>    Affects Versions: CSF branch, 4.0
>            Reporter: Simon Willnauer
>            Assignee: Simon Willnauer
>            Priority: Minor
>         Attachments: LUCENE-2777.patch
>
>
> PagedBytes has 3 different variants of fillUsingLengthPrefix. We need better names for that since CSFBranch already added a 4th one.
> here are some suggestions:
> {code}
> /** Reads length as 1 or 2 byte vInt prefix, starting @ start */
>     public BytesRef fillLengthAndOffset(BytesRef b, long start) 
> //    was: public BytesRef fillUsingLengthPrefix(BytesRef b, long start) 
>  /** @lucene.internal  Reads length as 1 or 2 byte vInt prefix, starting @ start.  Returns the block number of the term. */
>     public int getBlockAndFill(BytesRef b, long start) 
> //    was: public BytesRef fillUsingLengthPrefix2(BytesRef b, long start) 
> /** @lucene.internal  Reads length as 1 or 2 byte vInt prefix, starting @ start. 
>      * Returns the start offset of the next part, suitable as start parameter on next call
>      * to sequentially read all BytesRefs. */
>     public long getNextOffsetAndFill(BytesRef b, long start) 
> //    was: public BytesRef fillUsingLengthPrefix3(BytesRef b, long start) 
> {code}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


[jira] Updated: (LUCENE-2777) Revise PagedBytes#fillUsingLengthPrefix* methods names

Posted by "Simon Willnauer (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/LUCENE-2777?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Simon Willnauer updated LUCENE-2777:
------------------------------------

    Attachment: LUCENE-2777.patch

here is a patch that renames the methods. I used fill, fillSlice, fillAndGetIndex, and fillAndGetNext
I also added javadoc that some of those methods don't support slices spanning across blocks.

> Revise PagedBytes#fillUsingLengthPrefix* methods names
> ------------------------------------------------------
>
>                 Key: LUCENE-2777
>                 URL: https://issues.apache.org/jira/browse/LUCENE-2777
>             Project: Lucene - Java
>          Issue Type: Task
>    Affects Versions: CSF branch, 4.0
>            Reporter: Simon Willnauer
>            Assignee: Simon Willnauer
>            Priority: Minor
>         Attachments: LUCENE-2777.patch
>
>
> PagedBytes has 3 different variants of fillUsingLengthPrefix. We need better names for that since CSFBranch already added a 4th one.
> here are some suggestions:
> {code}
> /** Reads length as 1 or 2 byte vInt prefix, starting @ start */
>     public BytesRef fillLengthAndOffset(BytesRef b, long start) 
> //    was: public BytesRef fillUsingLengthPrefix(BytesRef b, long start) 
>  /** @lucene.internal  Reads length as 1 or 2 byte vInt prefix, starting @ start.  Returns the block number of the term. */
>     public int getBlockAndFill(BytesRef b, long start) 
> //    was: public BytesRef fillUsingLengthPrefix2(BytesRef b, long start) 
> /** @lucene.internal  Reads length as 1 or 2 byte vInt prefix, starting @ start. 
>      * Returns the start offset of the next part, suitable as start parameter on next call
>      * to sequentially read all BytesRefs. */
>     public long getNextOffsetAndFill(BytesRef b, long start) 
> //    was: public BytesRef fillUsingLengthPrefix3(BytesRef b, long start) 
> {code}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


[jira] Assigned: (LUCENE-2777) Revise PagedBytes#fillUsingLengthPrefix* methods names

Posted by "Simon Willnauer (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/LUCENE-2777?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Simon Willnauer reassigned LUCENE-2777:
---------------------------------------

    Assignee: Simon Willnauer

> Revise PagedBytes#fillUsingLengthPrefix* methods names
> ------------------------------------------------------
>
>                 Key: LUCENE-2777
>                 URL: https://issues.apache.org/jira/browse/LUCENE-2777
>             Project: Lucene - Java
>          Issue Type: Task
>    Affects Versions: CSF branch, 4.0
>            Reporter: Simon Willnauer
>            Assignee: Simon Willnauer
>            Priority: Minor
>
> PagedBytes has 3 different variants of fillUsingLengthPrefix. We need better names for that since CSFBranch already added a 4th one.
> here are some suggestions:
> {code}
> /** Reads length as 1 or 2 byte vInt prefix, starting @ start */
>     public BytesRef fillLengthAndOffset(BytesRef b, long start) 
> //    was: public BytesRef fillUsingLengthPrefix(BytesRef b, long start) 
>  /** @lucene.internal  Reads length as 1 or 2 byte vInt prefix, starting @ start.  Returns the block number of the term. */
>     public int getBlockAndFill(BytesRef b, long start) 
> //    was: public BytesRef fillUsingLengthPrefix2(BytesRef b, long start) 
> /** @lucene.internal  Reads length as 1 or 2 byte vInt prefix, starting @ start. 
>      * Returns the start offset of the next part, suitable as start parameter on next call
>      * to sequentially read all BytesRefs. */
>     public long getNextOffsetAndFill(BytesRef b, long start) 
> //    was: public BytesRef fillUsingLengthPrefix3(BytesRef b, long start) 
> {code}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org


[jira] Resolved: (LUCENE-2777) Revise PagedBytes#fillUsingLengthPrefix* methods names

Posted by "Simon Willnauer (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/LUCENE-2777?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Simon Willnauer resolved LUCENE-2777.
-------------------------------------

       Resolution: Fixed
    Fix Version/s: 4.0

Committed in revision: 1039382

> Revise PagedBytes#fillUsingLengthPrefix* methods names
> ------------------------------------------------------
>
>                 Key: LUCENE-2777
>                 URL: https://issues.apache.org/jira/browse/LUCENE-2777
>             Project: Lucene - Java
>          Issue Type: Task
>    Affects Versions: CSF branch, 4.0
>            Reporter: Simon Willnauer
>            Assignee: Simon Willnauer
>            Priority: Minor
>             Fix For: 4.0
>
>         Attachments: LUCENE-2777.patch
>
>
> PagedBytes has 3 different variants of fillUsingLengthPrefix. We need better names for that since CSFBranch already added a 4th one.
> here are some suggestions:
> {code}
> /** Reads length as 1 or 2 byte vInt prefix, starting @ start */
>     public BytesRef fillLengthAndOffset(BytesRef b, long start) 
> //    was: public BytesRef fillUsingLengthPrefix(BytesRef b, long start) 
>  /** @lucene.internal  Reads length as 1 or 2 byte vInt prefix, starting @ start.  Returns the block number of the term. */
>     public int getBlockAndFill(BytesRef b, long start) 
> //    was: public BytesRef fillUsingLengthPrefix2(BytesRef b, long start) 
> /** @lucene.internal  Reads length as 1 or 2 byte vInt prefix, starting @ start. 
>      * Returns the start offset of the next part, suitable as start parameter on next call
>      * to sequentially read all BytesRefs. */
>     public long getNextOffsetAndFill(BytesRef b, long start) 
> //    was: public BytesRef fillUsingLengthPrefix3(BytesRef b, long start) 
> {code}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@lucene.apache.org
For additional commands, e-mail: dev-help@lucene.apache.org