You are viewing a plain text version of this content. The canonical link for it is here.
Posted to commits@lucene.apache.org by cp...@apache.org on 2021/03/08 15:31:17 UTC

[lucene-solr] branch master updated: LUCENE-8626: enforce name standardisation for org.apache.lucene tests (#2441)

This is an automated email from the ASF dual-hosted git repository.

cpoerschke pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/lucene-solr.git


The following commit(s) were added to refs/heads/master by this push:
     new 419db23  LUCENE-8626: enforce name standardisation for org.apache.lucene tests (#2441)
419db23 is described below

commit 419db2304113fd97d79a8148dbdbb492ad879eb6
Author: Christine Poerschke <cp...@apache.org>
AuthorDate: Mon Mar 8 15:30:59 2021 +0000

    LUCENE-8626: enforce name standardisation for org.apache.lucene tests (#2441)
    
    Co-authored-by: Dawid Weiss <dw...@apache.org>
---
 .../org/apache/lucene/util/LuceneTestCase.java     |  4 ++
 .../util/VerifyTestClassNamingConvention.java      | 52 ++++++++++++++++++++++
 2 files changed, 56 insertions(+)

diff --git a/lucene/test-framework/src/java/org/apache/lucene/util/LuceneTestCase.java b/lucene/test-framework/src/java/org/apache/lucene/util/LuceneTestCase.java
index 930c02e..8bf1973 100644
--- a/lucene/test-framework/src/java/org/apache/lucene/util/LuceneTestCase.java
+++ b/lucene/test-framework/src/java/org/apache/lucene/util/LuceneTestCase.java
@@ -95,6 +95,7 @@ import java.util.concurrent.ThreadPoolExecutor;
 import java.util.concurrent.TimeUnit;
 import java.util.concurrent.atomic.AtomicReference;
 import java.util.logging.Logger;
+import java.util.regex.Pattern;
 import java.util.stream.Collectors;
 import junit.framework.AssertionFailedError;
 import org.apache.lucene.analysis.Analyzer;
@@ -612,6 +613,9 @@ public abstract class LuceneTestCase extends Assert {
         RuleChain.outerRule(new TestRuleIgnoreTestSuites())
             .around(ignoreAfterMaxFailures)
             .around(suiteFailureMarker = new TestRuleMarkFailure())
+            .around(
+                new VerifyTestClassNamingConvention(
+                    "org.apache.lucene", Pattern.compile("(.+\\.)(Test)([^.]+)")))
             .around(new TestRuleAssertionsRequired())
             .around(new TestRuleLimitSysouts(suiteFailureMarker))
             .around(tempFilesCleanupRule = new TestRuleTemporaryFilesCleanup(suiteFailureMarker));
diff --git a/lucene/test-framework/src/java/org/apache/lucene/util/VerifyTestClassNamingConvention.java b/lucene/test-framework/src/java/org/apache/lucene/util/VerifyTestClassNamingConvention.java
new file mode 100644
index 0000000..00a8321
--- /dev/null
+++ b/lucene/test-framework/src/java/org/apache/lucene/util/VerifyTestClassNamingConvention.java
@@ -0,0 +1,52 @@
+/*
+ * Licensed to the Apache Software Foundation (ASF) under one or more
+ * contributor license agreements.  See the NOTICE file distributed with
+ * this work for additional information regarding copyright ownership.
+ * The ASF licenses this file to You under the Apache License, Version 2.0
+ * (the "License"); you may not use this file except in compliance with
+ * the License.  You may obtain a copy of the License at
+ *
+ *     http://www.apache.org/licenses/LICENSE-2.0
+ *
+ * Unless required by applicable law or agreed to in writing, software
+ * distributed under the License is distributed on an "AS IS" BASIS,
+ * WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ * See the License for the specific language governing permissions and
+ * limitations under the License.
+ */
+package org.apache.lucene.util;
+
+import com.carrotsearch.randomizedtesting.RandomizedContext;
+import java.util.regex.Matcher;
+import java.util.regex.Pattern;
+
+/** Enforce test naming convention. */
+public class VerifyTestClassNamingConvention extends AbstractBeforeAfterRule {
+  private final String packagePrefix;
+  private final Pattern namingConvention;
+
+  public VerifyTestClassNamingConvention(String packagePrefix, Pattern namingConvention) {
+    this.packagePrefix = packagePrefix;
+    this.namingConvention = namingConvention;
+  }
+
+  @Override
+  protected void before() throws Exception {
+    if (TestRuleIgnoreTestSuites.isRunningNested()) {
+      // Ignore nested test suites that test the test framework itself.
+      return;
+    }
+
+    String suiteName = RandomizedContext.current().getTargetClass().getName();
+
+    Matcher matcher = namingConvention.matcher(suiteName);
+    if (suiteName.startsWith(packagePrefix) && !matcher.matches()) {
+      throw new AssertionError(
+          packagePrefix
+              + " suite must follow "
+              + namingConvention
+              + " naming convention: "
+              + suiteName);
+    }
+  }
+}