You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@commons.apache.org by "Henri Yandell (JIRA)" <ji...@apache.org> on 2007/08/15 07:27:30 UTC

[jira] Updated: (COLLECTIONS-223) CollectionUtils.addAll() methods should return the input collection

     [ https://issues.apache.org/jira/browse/COLLECTIONS-223?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Henri Yandell updated COLLECTIONS-223:
--------------------------------------

    Fix Version/s: 4.0

Would be very nice; but a definite backwards compat issue. Marking as 4.0.

I suspect the backwards compat pain outweighs the usefulness of having this.

> CollectionUtils.addAll() methods should return the input collection
> -------------------------------------------------------------------
>
>                 Key: COLLECTIONS-223
>                 URL: https://issues.apache.org/jira/browse/COLLECTIONS-223
>             Project: Commons Collections
>          Issue Type: Improvement
>          Components: Collection
>    Affects Versions: 3.2
>            Reporter: Vasily Ivanov
>            Priority: Minor
>             Fix For: 4.0
>
>
> Like MapUtils.putAll() method returns input map, CollectionUtils.addAll() methods should return the input collection.
> This will allow to init and populate collection at the same line:
> ArrayList inputs = (ArrayList) CollectionUtils.addAll(new ArrayList(), new String[] { "value1", "value2" });

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Re: [jira] Updated: (COLLECTIONS-223) CollectionUtils.addAll() methods should return the input collection

Posted by Henri Yandell <fl...@gmail.com>.
My assumption is that generics is an experimental branch, and that 4.0 will
happen when 3.x issues are exhausted. ie) 4.0 is way off there in the future
somewhere, and if the generics experiment is complete before 4.0 starts,
then they'll be the same.

If generics isn't experimental, but is definitely the next thing, then no
need for a 4.0.. or rather generics is 4.0 is generics.

Hen

On 8/15/07, Stephen Kestle <st...@orionhealth.com> wrote:
>
> Shouldn't version 4.0 be the same as generics?  Perhaps if this (1) issue
> is moved, and we rename generics to 4.0-generics
>
> Cheers
>
> Stephen
>
> Henri Yandell (JIRA) wrote:
>
>      [ https://issues.apache.org/jira/browse/COLLECTIONS-223?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]  Henri Yandell updated COLLECTIONS-223: --------------------------------------      Fix Version/s: 4.0  Would be very nice; but a definite backwards compat issue. Marking as 4.0.  I suspect the backwards compat pain outweighs the usefulness of having this.
>
> CollectionUtils.addAll() methods should return the input collection -------------------------------------------------------------------                  Key: COLLECTIONS-223                 URL: https://issues.apache.org/jira/browse/COLLECTIONS-223             Project: Commons Collections          Issue Type: Improvement          Components: Collection    Affects Versions: 3.2            Reporter: Vasily Ivanov            Priority: Minor             Fix For: 4.0   Like MapUtils.putAll() method returns input map, CollectionUtils.addAll() methods should return the input collection. This will allow to init and populate collection at the same line: ArrayList inputs = (ArrayList) CollectionUtils.addAll(new ArrayList(), new String[] { "value1", "value2" });
>
>
> --
> ------------------------------
> * <http://www.orionhealth.com>*
>
> *Stephen Kestle Software Engineer*
> stephen.kestle@orionhealth.com
> P: +64 9 638 0619
> M: +64 27 453 7853
> F: +64 9 638 0699
> S: skestle
> www.orionhealth.com
>
> This e-mail and any attachments are intended only for the person to whom
> it is addressed and may contain privileged, proprietary, or other data
> protected from disclosure under applicable law. If you are not the addressee
> or the person responsible for delivering this to the addressee you are
> hereby notified that reading, copying or distributing this transmission is
> prohibited. If you have received this e-mail in error, please telephone us
> immediately and remove all copies of it from your system. Thank you for your
> co-operation.
>

Re: [jira] Updated: (COLLECTIONS-223) CollectionUtils.addAll() methods should return the input collection

Posted by Stephen Kestle <st...@orionhealth.com>.
Shouldn't version 4.0 be the same as generics?  Perhaps if this (1) 
issue is moved, and we rename generics to 4.0-generics

Cheers

Stephen

Henri Yandell (JIRA) wrote:
>      [ https://issues.apache.org/jira/browse/COLLECTIONS-223?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
>
> Henri Yandell updated COLLECTIONS-223:
> --------------------------------------
>
>     Fix Version/s: 4.0
>
> Would be very nice; but a definite backwards compat issue. Marking as 4.0.
>
> I suspect the backwards compat pain outweighs the usefulness of having this.
>
>   
>> CollectionUtils.addAll() methods should return the input collection
>> -------------------------------------------------------------------
>>
>>                 Key: COLLECTIONS-223
>>                 URL: https://issues.apache.org/jira/browse/COLLECTIONS-223
>>             Project: Commons Collections
>>          Issue Type: Improvement
>>          Components: Collection
>>    Affects Versions: 3.2
>>            Reporter: Vasily Ivanov
>>            Priority: Minor
>>             Fix For: 4.0
>>
>>
>> Like MapUtils.putAll() method returns input map, CollectionUtils.addAll() methods should return the input collection.
>> This will allow to init and populate collection at the same line:
>> ArrayList inputs = (ArrayList) CollectionUtils.addAll(new ArrayList(), new String[] { "value1", "value2" });
>>     
>
>   

-- 
------------------------------------------------------------------------
* <http://www.orionhealth.com>*
	
	

*Stephen Kestle Software Engineer*
stephen.kestle@orionhealth.com <ma...@orionhealth.com>
P: +64 9 638 0619
M: +64 27 453 7853
F: +64 9 638 0699
S: skestle <callto:skestle>
www.orionhealth.com <http://www.orionhealth.com>


This e-mail and any attachments are intended only for the person to whom 
it is addressed and may contain privileged, proprietary, or other data 
protected from disclosure under applicable law. If you are not the 
addressee or the person responsible for delivering this to the addressee 
you are hereby notified that reading, copying or distributing this 
transmission is prohibited. If you have received this e-mail in error, 
please telephone us immediately and remove all copies of it from your 
system. Thank you for your co-operation.