You are viewing a plain text version of this content. The canonical link for it is here.
Posted to notifications@accumulo.apache.org by "David Medinets (JIRA)" <ji...@apache.org> on 2013/06/06 04:30:20 UTC

[jira] [Created] (ACCUMULO-1499) Move sanity checks from MiniAccumuloCluster constructor into MiniAccumuloConfig.initialize method.

David Medinets created ACCUMULO-1499:
----------------------------------------

             Summary: Move sanity checks from MiniAccumuloCluster constructor into MiniAccumuloConfig.initialize method.
                 Key: ACCUMULO-1499
                 URL: https://issues.apache.org/jira/browse/ACCUMULO-1499
             Project: Accumulo
          Issue Type: Improvement
    Affects Versions: 1.6.0
            Reporter: David Medinets
            Priority: Trivial
             Fix For: 1.6.0


The code below seems like it should be in the config class:

    if (config.getDir().exists() && !config.getDir().isDirectory())
      throw new IllegalArgumentException("Must pass in directory, " + config.getDir() + " is a file");

    if (config.getDir().exists() && config.getDir().list().length != 0)
      throw new IllegalArgumentException("Directory " + config.getDir() + " is not empty");

    this.config = config.initialize();

Any objections to this change?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira