You are viewing a plain text version of this content. The canonical link for it is here.
Posted to yarn-issues@hadoop.apache.org by "Szilard Nemeth (JIRA)" <ji...@apache.org> on 2019/07/15 14:48:00 UTC

[jira] [Created] (YARN-9679) Regular code cleanup in TestResourcePluginManager

Szilard Nemeth created YARN-9679:
------------------------------------

             Summary: Regular code cleanup in TestResourcePluginManager
                 Key: YARN-9679
                 URL: https://issues.apache.org/jira/browse/YARN-9679
             Project: Hadoop YARN
          Issue Type: Improvement
            Reporter: Szilard Nemeth


There are several things could be cleaned up in this class: 
1. stubResourcePluginmanager should be private.
2. In tearDown, the result of dest.delete() should be checked
3. In class CustomizedResourceHandler, there are several methods where exceptions decalarations are unnecessary.
4. Class MyMockNM should be renamed to some more meaningful name.
5. There are some danling javadoc comments, for example: 

{code:java}
/*
   * Make sure ResourcePluginManager is initialized during NM start up.
   */
{code}

6. There are some exceptions unnecessarily declared on test methods but they are never thrown, an example: 
testLinuxContainerExecutorWithResourcePluginsEnabled

7. Assert.assertTrue(false); expressions should be replaced with Assert.fail()
8. A handful of usages of Mockito's spy method. This method is not preferred so we should think about replacing it with mocks, somehow.

The rest can be figured out by whoever takes this jira :) 



--
This message was sent by Atlassian JIRA
(v7.6.14#76016)

---------------------------------------------------------------------
To unsubscribe, e-mail: yarn-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: yarn-issues-help@hadoop.apache.org