You are viewing a plain text version of this content. The canonical link for it is here.
Posted to user@ofbiz.apache.org by ian tabangay <it...@gmail.com> on 2009/01/13 15:47:33 UTC

Prettifying error messages

Hi. I would like to get the group's opinion on how they made errors being
displayed on ofbiz more readable to none technical users. What I mean is,
if, for example, I am creating a new facility and I did not put a name for
the facility, the page would display (in bold red letters) the message:

*The Following Errors Occurred:*

*The following required parameter is missing: [createFacility.facilityName]*

While this may be informative to us as users/developers of ofbiz, other
users might understand better if the message was:

*The Following Errors Occurred:*

*The following **parameter is **required: Name*

Thanks for any input and suggestion that you would give.

~ ian

Re: Prettifying error messages

Posted by Bilgin Ibryam <bi...@iguanait.com>.
Hi ian,
you can specify error message for every service parameter in service  
definition, using type-validate element. Fo facilityName field, it  
would be something like this

<override name="facilityName" optional="false">
    <type-validate >
	<fail-property resource="FacilityUiLabels"  
property="facilityNameRequire"/>
     </type-validate>
</override>

Bilgin


On Jan 13, 2009, at 4:47 PM, ian tabangay wrote:

> Hi. I would like to get the group's opinion on how they made errors  
> being
> displayed on ofbiz more readable to none technical users. What I  
> mean is,
> if, for example, I am creating a new facility and I did not put a  
> name for
> the facility, the page would display (in bold red letters) the  
> message:
>
> *The Following Errors Occurred:*
>
> *The following required parameter is missing:  
> [createFacility.facilityName]*
>
> While this may be informative to us as users/developers of ofbiz,  
> other
> users might understand better if the message was:
>
> *The Following Errors Occurred:*
>
> *The following **parameter is **required: Name*
>
> Thanks for any input and suggestion that you would give.
>
> ~ ian