You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@mesos.apache.org by Benjamin Hindman <be...@berkeley.edu> on 2012/08/29 21:18:38 UTC

Review Request: Added Duration comparison tests.

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/6837/
-----------------------------------------------------------

Review request for mesos, John Sirois and Vinod Kone.


Description
-------

See summary.


Diffs
-----

  src/tests/stout_tests.cpp 91bcc13 

Diff: https://reviews.apache.org/r/6837/diff/


Testing
-------

make check


Thanks,

Benjamin Hindman


Re: Review Request: Added Duration comparison tests.

Posted by Benjamin Hindman <be...@berkeley.edu>.

> On Aug. 30, 2012, 1:13 a.m., Vinod Kone wrote:
> > src/tests/stout_tests.cpp, line 33
> > <https://reviews.apache.org/r/6837/diff/1/?file=147201#file147201line33>
> >
> >     s/3/3.5/ to test double parsing

Added a later check for double parsing.


> On Aug. 30, 2012, 1:13 a.m., Vinod Kone wrote:
> > src/tests/stout_tests.cpp, line 35
> > <https://reviews.apache.org/r/6837/diff/1/?file=147201#file147201line35>
> >
> >     convert all ints to doubles

Done ... but honestly I'm still not sure if I think the 'n.0' style is more readable. :(


- Benjamin


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/6837/#review10868
-----------------------------------------------------------


On Aug. 29, 2012, 7:18 p.m., Benjamin Hindman wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/6837/
> -----------------------------------------------------------
> 
> (Updated Aug. 29, 2012, 7:18 p.m.)
> 
> 
> Review request for mesos, John Sirois and Vinod Kone.
> 
> 
> Description
> -------
> 
> See summary.
> 
> 
> Diffs
> -----
> 
>   src/tests/stout_tests.cpp 91bcc13 
> 
> Diff: https://reviews.apache.org/r/6837/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Benjamin Hindman
> 
>


Re: Review Request: Added Duration comparison tests.

Posted by Vinod Kone <vi...@gmail.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/6837/#review10868
-----------------------------------------------------------

Ship it!



src/tests/stout_tests.cpp
<https://reviews.apache.org/r/6837/#comment23427>

    s/3/3.5/ to test double parsing



src/tests/stout_tests.cpp
<https://reviews.apache.org/r/6837/#comment23428>

    convert all ints to doubles


- Vinod Kone


On Aug. 29, 2012, 7:18 p.m., Benjamin Hindman wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/6837/
> -----------------------------------------------------------
> 
> (Updated Aug. 29, 2012, 7:18 p.m.)
> 
> 
> Review request for mesos, John Sirois and Vinod Kone.
> 
> 
> Description
> -------
> 
> See summary.
> 
> 
> Diffs
> -----
> 
>   src/tests/stout_tests.cpp 91bcc13 
> 
> Diff: https://reviews.apache.org/r/6837/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Benjamin Hindman
> 
>


Re: Review Request: Added Duration comparison tests.

Posted by Ben Mahler <be...@gmail.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/6837/#review10958
-----------------------------------------------------------



src/tests/stout_tests.cpp
<https://reviews.apache.org/r/6837/#comment23528>

    it's definitely not more readable, but it makes it obvious that the constructors take doubles
    
    which do we prefer? I like the look of the non-decimal numbers, but I wouldn't want to have any code passing int literals for doubles


- Ben Mahler


On Aug. 29, 2012, 7:18 p.m., Benjamin Hindman wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/6837/
> -----------------------------------------------------------
> 
> (Updated Aug. 29, 2012, 7:18 p.m.)
> 
> 
> Review request for mesos, John Sirois and Vinod Kone.
> 
> 
> Description
> -------
> 
> See summary.
> 
> 
> Diffs
> -----
> 
>   src/tests/stout_tests.cpp 91bcc13 
> 
> Diff: https://reviews.apache.org/r/6837/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Benjamin Hindman
> 
>


Re: Review Request: Added Duration comparison tests.

Posted by John Sirois <jo...@gmail.com>.
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/6837/#review10874
-----------------------------------------------------------

Ship it!


Ship It!

- John Sirois


On Aug. 29, 2012, 7:18 p.m., Benjamin Hindman wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/6837/
> -----------------------------------------------------------
> 
> (Updated Aug. 29, 2012, 7:18 p.m.)
> 
> 
> Review request for mesos, John Sirois and Vinod Kone.
> 
> 
> Description
> -------
> 
> See summary.
> 
> 
> Diffs
> -----
> 
>   src/tests/stout_tests.cpp 91bcc13 
> 
> Diff: https://reviews.apache.org/r/6837/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Benjamin Hindman
> 
>