You are viewing a plain text version of this content. The canonical link for it is here.
Posted to reviews@kudu.apache.org by "Mike Percy (Code Review)" <ge...@cloudera.org> on 2017/10/17 16:30:42 UTC

[kudu-CR] consensus: Rename CHANGE ROLE op => CHANGE REPLICA TYPE

Hello Alexey Serbin,

I'd like you to do a code review. Please visit

    http://gerrit.cloudera.org:8080/8295

to review the following change.


Change subject: consensus: Rename CHANGE_ROLE op => CHANGE_REPLICA_TYPE
......................................................................

consensus: Rename CHANGE_ROLE op => CHANGE_REPLICA_TYPE

"Role" is currently a pretty ambiguous term in Kudu because role is
currently defined as LEADER, FOLLOWER, LEARNER, etc. "member_type" is
the standard type name but "replica" is more descriptive. Let's rename
this operation CHANGE_REPLICA_TYPE.

This is a wire-compatible change.

Change-Id: I29c8bed1f6b5c84b86be3997b76ac4f825fa2f0e
---
M src/kudu/consensus/consensus.proto
M src/kudu/consensus/raft_consensus.cc
M src/kudu/tools/tool_action_tablet.cc
3 files changed, 7 insertions(+), 6 deletions(-)



  git pull ssh://gerrit.cloudera.org:29418/kudu refs/changes/95/8295/1
-- 
To view, visit http://gerrit.cloudera.org:8080/8295
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: newchange
Gerrit-Change-Id: I29c8bed1f6b5c84b86be3997b76ac4f825fa2f0e
Gerrit-Change-Number: 8295
Gerrit-PatchSet: 1
Gerrit-Owner: Mike Percy <mp...@apache.org>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>

[kudu-CR] consensus: Rename CHANGE ROLE op => CHANGE REPLICA TYPE

Posted by "Alexey Serbin (Code Review)" <ge...@cloudera.org>.
Alexey Serbin has submitted this change and it was merged. ( http://gerrit.cloudera.org:8080/8295 )

Change subject: consensus: Rename CHANGE_ROLE op => CHANGE_REPLICA_TYPE
......................................................................

consensus: Rename CHANGE_ROLE op => CHANGE_REPLICA_TYPE

"Role" is currently a pretty ambiguous term in Kudu because role is
currently defined as LEADER, FOLLOWER, LEARNER, etc. "member_type" is
the standard type name but "replica" is more descriptive. Let's rename
this operation CHANGE_REPLICA_TYPE.

This is a wire-compatible change.

Change-Id: I29c8bed1f6b5c84b86be3997b76ac4f825fa2f0e
Reviewed-on: http://gerrit.cloudera.org:8080/8295
Tested-by: Kudu Jenkins
Reviewed-by: Alexey Serbin <as...@cloudera.com>
---
M src/kudu/consensus/consensus.proto
M src/kudu/consensus/raft_consensus.cc
M src/kudu/tools/tool_action_tablet.cc
3 files changed, 7 insertions(+), 6 deletions(-)

Approvals:
  Kudu Jenkins: Verified
  Alexey Serbin: Looks good to me, approved

-- 
To view, visit http://gerrit.cloudera.org:8080/8295
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: merged
Gerrit-Change-Id: I29c8bed1f6b5c84b86be3997b76ac4f825fa2f0e
Gerrit-Change-Number: 8295
Gerrit-PatchSet: 2
Gerrit-Owner: Mike Percy <mp...@apache.org>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: Kudu Jenkins

[kudu-CR] consensus: Rename CHANGE ROLE op => CHANGE REPLICA TYPE

Posted by "Alexey Serbin (Code Review)" <ge...@cloudera.org>.
Alexey Serbin has posted comments on this change. ( http://gerrit.cloudera.org:8080/8295 )

Change subject: consensus: Rename CHANGE_ROLE op => CHANGE_REPLICA_TYPE
......................................................................


Patch Set 1: Code-Review+2


-- 
To view, visit http://gerrit.cloudera.org:8080/8295
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: I29c8bed1f6b5c84b86be3997b76ac4f825fa2f0e
Gerrit-Change-Number: 8295
Gerrit-PatchSet: 1
Gerrit-Owner: Mike Percy <mp...@apache.org>
Gerrit-Reviewer: Alexey Serbin <as...@cloudera.com>
Gerrit-Reviewer: Kudu Jenkins
Gerrit-Comment-Date: Tue, 17 Oct 2017 21:50:26 +0000
Gerrit-HasComments: No