You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@flink.apache.org by "humengyu (Jira)" <ji...@apache.org> on 2021/06/03 08:28:00 UTC

[jira] [Comment Edited] (FLINK-21686) Duplicate code in hive parser file should be abstracted into functions

    [ https://issues.apache.org/jira/browse/FLINK-21686?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17356281#comment-17356281 ] 

humengyu edited comment on FLINK-21686 at 6/3/21, 8:27 AM:
-----------------------------------------------------------

Thanks for your guidance, I will finish these work.


was (Author: humengyu):
Thank you for your guidance, I will finish these work.

> Duplicate code in hive parser file should be abstracted into functions
> ----------------------------------------------------------------------
>
>                 Key: FLINK-21686
>                 URL: https://issues.apache.org/jira/browse/FLINK-21686
>             Project: Flink
>          Issue Type: Improvement
>          Components: Connectors / Hive
>            Reporter: humengyu
>            Priority: Minor
>              Labels: pull-request-available
>
> It would be better to use functions rather than duplicate code in hive parser file:
>  # <IF> <EXISTS> option should be abstracted into a function;
>  # <IF> <NOT> <EXISTS> option should be abstracted into a function.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)