You are viewing a plain text version of this content. The canonical link for it is here.
Posted to derby-dev@db.apache.org by "Dag H. Wanvik (Commented) (JIRA)" <ji...@apache.org> on 2012/04/03 22:02:24 UTC
[jira] [Commented] (DERBY-5683)
BaseJDBCTestCase.getDatabaseProperty() should close resources before
returning
[ https://issues.apache.org/jira/browse/DERBY-5683?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13245660#comment-13245660 ]
Dag H. Wanvik commented on DERBY-5683:
--------------------------------------
Looks like an improvement. +1 Nit: the new name closeStatement doesn't convey the semantics for "forgetting/removing" the statement from "statements". What about "removeStatement"?
> BaseJDBCTestCase.getDatabaseProperty() should close resources before returning
> ------------------------------------------------------------------------------
>
> Key: DERBY-5683
> URL: https://issues.apache.org/jira/browse/DERBY-5683
> Project: Derby
> Issue Type: Improvement
> Components: Test
> Affects Versions: 10.9.0.0
> Reporter: Knut Anders Hatlen
> Assignee: Knut Anders Hatlen
> Priority: Minor
> Attachments: d5683-1a-close-and-forget.diff
>
>
> BaseJDBCTestCase.getDatabaseProperty() creates a PreparedStatement and a ResultSet that are not closed before the method returns. If a test case calls getDatabaseProperty() many times, the open statements may have a big memory footprint.
> This can be seen for example by running jdbcapi.AuthenticationTest with -Xmx64. It will fail with an OutOfMemoryError when testNoCollisionsWithConfigurableHash() runs in client/server mode.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira