You are viewing a plain text version of this content. The canonical link for it is here.
Posted to dev@hive.apache.org by "Prasad Chakka (JIRA)" <ji...@apache.org> on 2009/09/07 18:32:57 UTC

[jira] Commented: (HIVE-675) add database/scheme support Hive QL

    [ https://issues.apache.org/jira/browse/HIVE-675?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12752204#action_12752204 ] 

Prasad Chakka commented on HIVE-675:
------------------------------------

1) more test clientpositive & clientnegative tests
2) db location should take an URI rather than a path. since location can point to a different HDFS instance
3) this path does not support <DBNAME>.<TBLNAME>.<COLUMN>. If you are not planning to add that support then create a new JIRA.
4) there should be a way to easily move tbl from on db to another db. may be open a JIRA for that as well?
5) HiveMetaStore.java: if the given db location is not a proper URI then it is silently ignored and default path is being used. HiveMetastore should throw an error instead if the path is not absolute or a proper URI
6) remove ql/junit233767264.properties from patch
7) remove ql/junitvmwatcher1237844024.properties from patch
8) there are lot of other locations where MetaStoreUtils.DEFAULT_DATABASE_NAME is used. It should be replaced by Hive.currentDatabase
9) is Hive.currentDatabase thread-safe. does it work in HiveServer where multiple threads can each have separate currentDatabases?
10) Hive.createDatabase() & dropDatabase() should throw AlreadyExistsException() instead of throwin HiveException
11) rename isDatabaseExist() to databaseExists()
12) currentDatabase should either be in SessionState or Hive. There is no need for it to be stored in both objects.

> add database/scheme support Hive QL
> -----------------------------------
>
>                 Key: HIVE-675
>                 URL: https://issues.apache.org/jira/browse/HIVE-675
>             Project: Hadoop Hive
>          Issue Type: New Feature
>          Components: Query Processor
>            Reporter: Prasad Chakka
>         Attachments: hive-675-2009-9-7.patch
>
>
> Currently all Hive tables reside in single namespace (default). Hive should support multiple namespaces (databases or schemas) such that users can create tables in their specific namespaces. These name spaces can have different warehouse directories (with a default naming scheme) and possibly different properties.
> There is already some support for this in metastore but Hive query parser should have this feature as well.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.