You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@maven.apache.org by "Robert Scholte (JIRA)" <ji...@apache.org> on 2018/03/24 16:28:00 UTC
[jira] [Closed] (MRELEASE-1007) Rework usage workingDirectory and
commonBasedir
[ https://issues.apache.org/jira/browse/MRELEASE-1007?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Robert Scholte closed MRELEASE-1007.
------------------------------------
Resolution: Fixed
Fix Version/s: 3.0.0
Fixed in [9ea29a796d0e6191bebdf9accf4338fde541195d|https://gitbox.apache.org/repos/asf?p=maven-release.git;a=commit;h=9ea29a796d0e6191bebdf9accf4338fde541195d]
> Rework usage workingDirectory and commonBasedir
> -----------------------------------------------
>
> Key: MRELEASE-1007
> URL: https://issues.apache.org/jira/browse/MRELEASE-1007
> Project: Maven Release Plugin
> Issue Type: Improvement
> Reporter: Robert Scholte
> Assignee: Robert Scholte
> Priority: Major
> Fix For: 3.0.0
>
>
> All over the code are recalculations based on commonbasedir and workingdirectory. Add several places the usage is unclear and is the intention hard to read. Quite often they're simply the same.
> Better to use the commonbasedir as the workingdirectory and calculate the pomFile(s) relative to the working directory.
> This step is required to better control the plugin when using an aggregator to do multiple releases at once.
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)