You are viewing a plain text version of this content. The canonical link for it is here.
Posted to common-dev@hadoop.apache.org by "Sharad Agarwal (JIRA)" <ji...@apache.org> on 2009/02/11 11:30:59 UTC

[jira] Created: (HADOOP-5217) Split the AllTestDriver for core, hdfs and mapred

Split the AllTestDriver for core, hdfs and mapred
-------------------------------------------------

                 Key: HADOOP-5217
                 URL: https://issues.apache.org/jira/browse/HADOOP-5217
             Project: Hadoop Core
          Issue Type: Sub-task
          Components: test
            Reporter: Sharad Agarwal


The sub projects would have individual test jar. This would require separate driver class for each.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HADOOP-5217) Split the AllTestDriver for core, hdfs and mapred

Posted by "Sharad Agarwal (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HADOOP-5217?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Sharad Agarwal updated HADOOP-5217:
-----------------------------------

    Status: Open  (was: Patch Available)

> Split the AllTestDriver for core, hdfs and mapred
> -------------------------------------------------
>
>                 Key: HADOOP-5217
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5217
>             Project: Hadoop Core
>          Issue Type: Sub-task
>          Components: test
>            Reporter: Sharad Agarwal
>            Assignee: Sharad Agarwal
>         Attachments: 5217_v1.patch, 5217_v2.patch
>
>
> The sub projects would have individual test jar. This would require separate driver class for each.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HADOOP-5217) Split the AllTestDriver for core, hdfs and mapred

Posted by "Sharad Agarwal (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HADOOP-5217?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Sharad Agarwal updated HADOOP-5217:
-----------------------------------

    Assignee: Sharad Agarwal
      Status: Patch Available  (was: Open)

> Split the AllTestDriver for core, hdfs and mapred
> -------------------------------------------------
>
>                 Key: HADOOP-5217
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5217
>             Project: Hadoop Core
>          Issue Type: Sub-task
>          Components: test
>            Reporter: Sharad Agarwal
>            Assignee: Sharad Agarwal
>         Attachments: 5217_v1.patch
>
>
> The sub projects would have individual test jar. This would require separate driver class for each.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HADOOP-5217) Split the AllTestDriver for core, hdfs and mapred

Posted by "Sharad Agarwal (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HADOOP-5217?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Sharad Agarwal updated HADOOP-5217:
-----------------------------------

    Attachment: 5217_v3.patch

Changed HdfsIntTestDriver name to HdfsWithMRTestDriver. Added some javadoc comments.

> Split the AllTestDriver for core, hdfs and mapred
> -------------------------------------------------
>
>                 Key: HADOOP-5217
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5217
>             Project: Hadoop Core
>          Issue Type: Sub-task
>          Components: test
>            Reporter: Sharad Agarwal
>            Assignee: Sharad Agarwal
>             Fix For: 0.21.0
>
>         Attachments: 5217_v1.patch, 5217_v2.patch, 5217_v3.patch
>
>
> The sub projects would have individual test jar. This would require separate driver class for each.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (HADOOP-5217) Split the AllTestDriver for core, hdfs and mapred

Posted by "Hadoop QA (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HADOOP-5217?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12673146#action_12673146 ] 

Hadoop QA commented on HADOOP-5217:
-----------------------------------

+1 overall.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12400014/5217_v1.patch
  against trunk revision 743941.

    +1 @author.  The patch does not contain any @author tags.

    +1 tests included.  The patch appears to include 15 new or modified tests.

    +1 javadoc.  The javadoc tool did not generate any warning messages.

    +1 javac.  The applied patch does not increase the total number of javac compiler warnings.

    +1 findbugs.  The patch does not introduce any new Findbugs warnings.

    +1 Eclipse classpath. The patch retains Eclipse classpath integrity.

    +1 release audit.  The applied patch does not increase the total number of release audit warnings.

    +1 core tests.  The patch passed core unit tests.

    +1 contrib tests.  The patch passed contrib unit tests.

Test results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3842/testReport/
Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3842/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
Checkstyle results: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3842/artifact/trunk/build/test/checkstyle-errors.html
Console output: http://hudson.zones.apache.org/hudson/job/Hadoop-Patch/3842/console

This message is automatically generated.

> Split the AllTestDriver for core, hdfs and mapred
> -------------------------------------------------
>
>                 Key: HADOOP-5217
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5217
>             Project: Hadoop Core
>          Issue Type: Sub-task
>          Components: test
>            Reporter: Sharad Agarwal
>            Assignee: Sharad Agarwal
>         Attachments: 5217_v1.patch
>
>
> The sub projects would have individual test jar. This would require separate driver class for each.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (HADOOP-5217) Split the AllTestDriver for core, hdfs and mapred

Posted by "Jothi Padmanabhan (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HADOOP-5217?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12703591#action_12703591 ] 

Jothi Padmanabhan commented on HADOOP-5217:
-------------------------------------------

In AllTestDriver.java, instead of calling the run for each driver,  a single call to pgd.driver(argv) should suffice

> Split the AllTestDriver for core, hdfs and mapred
> -------------------------------------------------
>
>                 Key: HADOOP-5217
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5217
>             Project: Hadoop Core
>          Issue Type: Sub-task
>          Components: test
>            Reporter: Sharad Agarwal
>            Assignee: Sharad Agarwal
>         Attachments: 5217_v1.patch
>
>
> The sub projects would have individual test jar. This would require separate driver class for each.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HADOOP-5217) Split the AllTestDriver for core, hdfs and mapred

Posted by "Sharad Agarwal (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HADOOP-5217?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Sharad Agarwal updated HADOOP-5217:
-----------------------------------

    Attachment: 5217_v1.patch

> Split the AllTestDriver for core, hdfs and mapred
> -------------------------------------------------
>
>                 Key: HADOOP-5217
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5217
>             Project: Hadoop Core
>          Issue Type: Sub-task
>          Components: test
>            Reporter: Sharad Agarwal
>         Attachments: 5217_v1.patch
>
>
> The sub projects would have individual test jar. This would require separate driver class for each.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (HADOOP-5217) Split the AllTestDriver for core, hdfs and mapred

Posted by "Jothi Padmanabhan (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HADOOP-5217?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12705477#action_12705477 ] 

Jothi Padmanabhan commented on HADOOP-5217:
-------------------------------------------

Looks good. 
A couple of minor points:
# Should we rename HdfsIntTestDriver to something more descriptive?
# I think java doc for the classes would be useful, especially to highlight the difference between the HdfsTestDriver and HdfsIntTestDriver classes, no?

> Split the AllTestDriver for core, hdfs and mapred
> -------------------------------------------------
>
>                 Key: HADOOP-5217
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5217
>             Project: Hadoop Core
>          Issue Type: Sub-task
>          Components: test
>            Reporter: Sharad Agarwal
>            Assignee: Sharad Agarwal
>             Fix For: 0.21.0
>
>         Attachments: 5217_v1.patch, 5217_v2.patch
>
>
> The sub projects would have individual test jar. This would require separate driver class for each.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (HADOOP-5217) Split the AllTestDriver for core, hdfs and mapred

Posted by "Jothi Padmanabhan (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HADOOP-5217?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12705513#action_12705513 ] 

Jothi Padmanabhan commented on HADOOP-5217:
-------------------------------------------

+1. Changes look fine.

> Split the AllTestDriver for core, hdfs and mapred
> -------------------------------------------------
>
>                 Key: HADOOP-5217
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5217
>             Project: Hadoop Core
>          Issue Type: Sub-task
>          Components: test
>            Reporter: Sharad Agarwal
>            Assignee: Sharad Agarwal
>             Fix For: 0.21.0
>
>         Attachments: 5217_v1.patch, 5217_v2.patch, 5217_v3.patch
>
>
> The sub projects would have individual test jar. This would require separate driver class for each.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HADOOP-5217) Split the AllTestDriver for core, hdfs and mapred

Posted by "Sharad Agarwal (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HADOOP-5217?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Sharad Agarwal updated HADOOP-5217:
-----------------------------------

    Fix Version/s: 0.21.0
           Status: Patch Available  (was: Open)

> Split the AllTestDriver for core, hdfs and mapred
> -------------------------------------------------
>
>                 Key: HADOOP-5217
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5217
>             Project: Hadoop Core
>          Issue Type: Sub-task
>          Components: test
>            Reporter: Sharad Agarwal
>            Assignee: Sharad Agarwal
>             Fix For: 0.21.0
>
>         Attachments: 5217_v1.patch, 5217_v2.patch
>
>
> The sub projects would have individual test jar. This would require separate driver class for each.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HADOOP-5217) Split the AllTestDriver for core, hdfs and mapred

Posted by "Sharad Agarwal (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HADOOP-5217?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Sharad Agarwal updated HADOOP-5217:
-----------------------------------

      Resolution: Fixed
    Hadoop Flags: [Reviewed]
          Status: Resolved  (was: Patch Available)

I just committed this.

> Split the AllTestDriver for core, hdfs and mapred
> -------------------------------------------------
>
>                 Key: HADOOP-5217
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5217
>             Project: Hadoop Core
>          Issue Type: Sub-task
>          Components: test
>            Reporter: Sharad Agarwal
>            Assignee: Sharad Agarwal
>             Fix For: 0.21.0
>
>         Attachments: 5217_v1.patch, 5217_v2.patch, 5217_v3.patch
>
>
> The sub projects would have individual test jar. This would require separate driver class for each.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Updated: (HADOOP-5217) Split the AllTestDriver for core, hdfs and mapred

Posted by "Sharad Agarwal (JIRA)" <ji...@apache.org>.
     [ https://issues.apache.org/jira/browse/HADOOP-5217?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Sharad Agarwal updated HADOOP-5217:
-----------------------------------

    Attachment: 5217_v2.patch

Incorporated review comments.

> Split the AllTestDriver for core, hdfs and mapred
> -------------------------------------------------
>
>                 Key: HADOOP-5217
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5217
>             Project: Hadoop Core
>          Issue Type: Sub-task
>          Components: test
>            Reporter: Sharad Agarwal
>            Assignee: Sharad Agarwal
>         Attachments: 5217_v1.patch, 5217_v2.patch
>
>
> The sub projects would have individual test jar. This would require separate driver class for each.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


[jira] Commented: (HADOOP-5217) Split the AllTestDriver for core, hdfs and mapred

Posted by "Hudson (JIRA)" <ji...@apache.org>.
    [ https://issues.apache.org/jira/browse/HADOOP-5217?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12705696#action_12705696 ] 

Hudson commented on HADOOP-5217:
--------------------------------

Integrated in Hadoop-trunk #826 (See [http://hudson.zones.apache.org/hudson/job/Hadoop-trunk/826/])
    . Split AllTestDriver for core, hdfs and mapred.


> Split the AllTestDriver for core, hdfs and mapred
> -------------------------------------------------
>
>                 Key: HADOOP-5217
>                 URL: https://issues.apache.org/jira/browse/HADOOP-5217
>             Project: Hadoop Core
>          Issue Type: Sub-task
>          Components: test
>            Reporter: Sharad Agarwal
>            Assignee: Sharad Agarwal
>             Fix For: 0.21.0
>
>         Attachments: 5217_v1.patch, 5217_v2.patch, 5217_v3.patch
>
>
> The sub projects would have individual test jar. This would require separate driver class for each.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.