You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@maven.apache.org by "Diego Rivera (JIRA)" <ji...@apache.org> on 2016/11/08 23:09:58 UTC

[jira] [Updated] (MSHADE-239) Shaded Source JAR not following finalName pattern

     [ https://issues.apache.org/jira/browse/MSHADE-239?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Diego Rivera updated MSHADE-239:
--------------------------------
    Description: 
When enabling the <createSourcesJar> and <shadedSourcesContent> configurations, while also using a custom naming scheme in <finalName>, the sources JAR is named incorrectly.

For instance, given the following configuration:
{code}
<configuration>
    <finalName>${project.artifactId}-${project.version}-${some-other-crap}-exe</finalName>
    <createSourcesJar>true</createSourcesJar>
    <shadedSourcesContent>true</shadedSourcesContent>
    <shadedArtifactAttached>true</shadedArtifactAttached>
    <shadedClassifierName>exe</shadedClassifierName>
</configuration>
{code}

The shaded artifact is appropriately named artifact-version-crapola-exe.jar, while the source jar is named artifact-version-exe-sources.jar (note the missing "-crapola", from the variable $\{some-other-crap\} in <finalName>). The correct name should be artifact-version-crapola-exe-sources.jar (i.e. $\{finalName\}-sources.jar).

As a side note: it might be a good idea to enable the use of a $\{shadedClassifierName\} variable that can be referenced and interpolated within the <finalName> evaluation.

  was:
When enabling the <createSourcesJar> and <shadedSourcesContent> configurations, while also using a custom naming scheme in <finalName>, the sources JAR is named incorrectly.

For instance, given the following configuration:
{code}
<configuration>
    <finalName>${project.artifactId}-${project.version}-${some-other-crap}-exe</finalName>
    <createSourcesJar>true</createSourcesJar>
    <shadedSourcesContent>true</shadedSourcesContent>
    <shadedArtifactAttached>true</shadedArtifactAttached>
    <shadedClassifierName>exe</shadedClassifierName>
</configuration>
{code}

The shaded artifact is appropriately named artifact-version-crapola-exe.jar, while the source jar is named artifact-version-exe-sources.jar (note the missing "-crapola", from the variable ${some-other-crap} in <finalName>). The correct name should be artifact-version-crapola-exe-sources.jar (i.e. ${finalName}-sources.jar).

As a side note: it might be a good idea to enable the use of a ${shadedClassifierName} variable that can be referenced and interpolated within the <finalName> evaluation.


> Shaded Source JAR not following finalName pattern
> -------------------------------------------------
>
>                 Key: MSHADE-239
>                 URL: https://issues.apache.org/jira/browse/MSHADE-239
>             Project: Maven Shade Plugin
>          Issue Type: Bug
>    Affects Versions: 2.4.3
>            Reporter: Diego Rivera
>
> When enabling the <createSourcesJar> and <shadedSourcesContent> configurations, while also using a custom naming scheme in <finalName>, the sources JAR is named incorrectly.
> For instance, given the following configuration:
> {code}
> <configuration>
>     <finalName>${project.artifactId}-${project.version}-${some-other-crap}-exe</finalName>
>     <createSourcesJar>true</createSourcesJar>
>     <shadedSourcesContent>true</shadedSourcesContent>
>     <shadedArtifactAttached>true</shadedArtifactAttached>
>     <shadedClassifierName>exe</shadedClassifierName>
> </configuration>
> {code}
> The shaded artifact is appropriately named artifact-version-crapola-exe.jar, while the source jar is named artifact-version-exe-sources.jar (note the missing "-crapola", from the variable $\{some-other-crap\} in <finalName>). The correct name should be artifact-version-crapola-exe-sources.jar (i.e. $\{finalName\}-sources.jar).
> As a side note: it might be a good idea to enable the use of a $\{shadedClassifierName\} variable that can be referenced and interpolated within the <finalName> evaluation.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)