You are viewing a plain text version of this content. The canonical link for it is here.
Posted to issues@maven.apache.org by "Karl Heinz Marbaise (JIRA)" <ji...@apache.org> on 2015/06/21 09:48:00 UTC

[jira] [Created] (MCLEAN-63) Make naming of properties consistent

Karl Heinz Marbaise created MCLEAN-63:
-----------------------------------------

             Summary: Make naming of properties consistent
                 Key: MCLEAN-63
                 URL: https://issues.apache.org/jira/browse/MCLEAN-63
             Project: Maven Clean Plugin
          Issue Type: Improvement
    Affects Versions: 2.6.1
            Reporter: Karl Heinz Marbaise


The list of properties looks like this:
{code}
 @Parameter( property = "clean.verbose" )
    @Parameter( property = "clean.followSymLinks", defaultValue = "false" )
    @Parameter( property = "clean.skip", defaultValue = "false" )
    @Parameter( property = "maven.clean.failOnError", defaultValue = "true" )
    @Parameter( property = "maven.clean.retryOnError", defaultValue = "true" )
    @Parameter( property = "clean.excludeDefaultDirectories", defaultValue = "false" )
{code}

The property names should follow the naming convention: {{maven.PLUGIN.WhatEver}} So  {{clean.verbose}} should be changed into {{maven.clean.verbose}}, {{clean.followSymLinks}} should be changed into {{maven.clean.followSymLinks}}, {{clean.skip}} should be changed into {{maven.clean.skip}}, and {{clean.excludeDefaultDirectories}} should be changed into {{maven.clean.excludeDefaultDirectories}}.

The old properties {{clean.*}} should be marked deprecated and a WARNING should be emitted. With version 3.X they can be replaced completely.




--
This message was sent by Atlassian JIRA
(v6.3.4#6332)